Homey Community Forum

8 knops Wandzender (Zigbee) niet alle knoppen doen het!

vraag het eens aan @TedTolboom die weet er alles van.

Ik gebruik de app van Ted Tolboom voor de Remotec schakelaar, ook 8 knops, maar Zwave. Als je niet tot een oplossing komt is dat het overwegen zeker waard.

@Mark_Stevens de Zigbee wandzender moet alle knoppen individueel koppelen aan Homey; door andere Zigbee communicatie kan het zijn dat enkele groepen niet correct gekoppeld zijn.
Tijdens het starten van de app, zal de driver altijd proberen om de ontbrekende groepen alsnog te koppelen.

De (beste) suggestie om dit probleem op te lossen is de volgende:

  • met de wandzender in de buurt van Homey; start de ROBB smarrt app opnieuw op (instellingen > APPS > ROBB smarrt app > instellingen > herstart app
  • blijf tijdens het opstarten van de app om de twee seconden op een van de knoppen drukken (maakt niet uit welke)
  • de app is opnieuw opgestart wanneer alle aan ROBB smarrt app gekoppelde apparaten geen uitroepteken / circle meer tonen

Ik hoor graag of dit je probleem oplost.

1 Like

Aller eerst bedankt voor je bericht,

Helaas heeft het niet geholpen, een aantal keer heb ik de app opnieuw opgestart en de knop om de twee seconden ingedrukt.

Al na een halve minuut komt er een notificatie binnen van de flow die ik heb gemaakt om te controleren welke knop het doet. Nog steeds doet knop 2 niks jammer genoeg.

Update nogmaals contact gehad met Robbshop dit zou de oplossing zijn, heb het onderstaande een aantal keer geprobeerd maar het heeft weer niks geholpen.

Beste Mark Stevens,

wat je dan even moet doen is alle knoppen tijdens het toevoegen het 1x drukken comando en langdurig indrukken.

De status van het ticket is gewijzigd naar Wachten op klant

Met vriendelijke groet,
W***

mmm, ik zou zeggen knopje kapot? omruilen voor een nieuwe?

Hoi Joost dat zou wel heel apart zijn ik heb al een nieuwe gekregen de eerst had het zelfde probleem het is steeds knop 2 die niks doet.

Ah, dat had ik even gemist, stond geloof ik ook niet hierboven? Dat zou wel heel erg toeval zijn ja…

Ik heb net hetzelfde probleem: group 1,3 & 4 werken, group 2 niet. Ondertussen reeds meerdere malen een factory reset gedaan maar het probleem blijft.

Hoi Kris erg vervelend probleem ik heb van ROBBshop weer een bericht gekregen ik mag weer een RMA aanmaken.

Heb jij de wandzender ook bij ROBBshop gekocht?

Dag Mark,
Inderdaad, ik heb deze wandzender ook bij ROBBshop gekocht.
Ik ga hen contacteren hiervoor om te zien of ik ook RMA moet aanmaken. Toch wel teleurstellend…

@Mark_Stevens @KrisG, waarschijnlijk is het geen defecte wandzender, maar zoals eerder aangegeven een onvolledige initializatie.

Zouden jullie onderstaande stappen kunnen proberen, met toevoeging van de stappen in vet

Wanneer dit niet werkt, zouden jullie me dan een diagnostics log kunnen sturen?
Settings > Apps > ROBBsmarrt app > stuur diagnostisch log

Ik zal vanavond nog mijn 8 knops Wandzender opnieuw verwijderen en toevoegen om de initialisatie opnieuw te valideren.

Beste Ted,

Ik heb jouw instructies gevolgd, maar nu reageert er geen enkele toets meer. De wandzender is nog steeds herkend en de led brandt telkens ik op een toets druk.
Ik heb een diagnostic log gemaakt met id 4d7c5b13-e2ee-4b69-acae-d3a4628ff7a1.

Hopelijk kan je hier iets mee.
Alvast bedankt.

Kris.

@KrisG bedankt voor het testen en delen van het diagnostics rapport:

---- stdout ----
2020-05-25 21:28:42 [log] [ROBBsmarrtApp] ROBB smarrt app is running...
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] ZigBeeDevice has been inited
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] { '1_genOnOff_bind': true,
  '1_genLevelCtrl_bind': true,
  '2_genOnOff_bind': true,
  '2_genLevelCtrl_bind': true,
  '3_genOnOff_bind': true,
  '3_genLevelCtrl_bind': true,
  attrReport_0_genPowerCfg_batteryPercentageRemaining: { minInt: 10, maxInt: 60, repChange: 1 },
  '0_genOnOff_bind': true,
  '0_genLevelCtrl_bind': true }
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] registerAttrReportListener() -> already configured attr reporting attrReport_0_genPowerCfg_batteryPercentageRemaining
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] [ 'genOnOff', 'genLevelCtrl' ] [ '0', '1' ]
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] - Endpoints: 0
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] -- Clusters: genOnOff
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] -- Clusters: genLevelCtrl
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] - Endpoints: 1
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] -- Clusters: genOnOff
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] -- Clusters: genLevelCtrl
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] - Endpoints: 2
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] -- Clusters: genOnOff
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] -- Clusters: genLevelCtrl
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] - Endpoints: 3
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] -- Clusters: genOnOff
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] -- Clusters: genLevelCtrl
2020-05-25 21:28:43 [log] [ManagerDrivers] [ZB_WallController_8] [0] registered attr report listener
2020-05-25 21:28:44 [log] [ManagerDrivers] [ZB_WallController_8] [0] onPowerCfgBatteryPercentageRemainingReport 100
2020-05-25 21:29:19 [log] [ManagerDrivers] [ZB_WallController_8] [0] onPowerCfgBatteryPercentageRemainingReport 100
2020-05-25 21:29:20 [log] [ManagerDrivers] [ZB_WallController_8] [0] onPowerCfgBatteryPercentageRemainingReport 100
2020-05-25 21:29:23 [log] [ManagerDrivers] [ZB_WallController_8] [0] onPowerCfgBatteryPercentageRemainingReport 100
2020-05-25 21:30:19 [log] [ManagerDrivers] [ZB_WallController_8] [0] onPowerCfgBatteryPercentageRemainingReport 100
2020-05-25 21:31:20 [log] [ManagerDrivers] [ZB_WallController_8] [0] onPowerCfgBatteryPercentageRemainingReport 100
2020-05-25 21:32:20 [log] [ManagerDrivers] [ZB_WallController_8] [0] onPowerCfgBatteryPercentageRemainingReport 100

---- stderr ---- 

Er zijn geen errors zichtbaar en ook de Zigbee bindings lijken ok te zijn.

Zou je eens kunnen proberen om de wandzender te verwijderen en daarna opnieuw toe te voegen aan Homey?
Wanneer het toevoegen gestart is, kun je dan de wandzender wakker houden door regelmatig 3-4 seconden op een van de onderste knoppen te drukken?

Ik kan geen problemen vinden in de driver code en het probleem hier niet reproduceren; er lijkt dus iets fout te gaan in de communicatie tussen de wandzender en je Homey.

@TedTolboom bedankt voor al je hulp ik heb van alles geprobeerd maar steeds zonder resultaat. Ik mag mijn wandzender terug sturen en ga nu voor een zwave wandzender.

Hierbij alsnog de Diagnose rapportage.
e4f731a2-c408-42b0-91f3-a3ee4eb4cf7e

@Mark_Stevens bedankt voor het testen en delen van de materialen.
Zodra de Zigbee wandzender terug is bij ROBBshop, zal ik nog wat extra tests met jouw wandzender doen, om het probleem beter te kunnen begrijpen en ondervangen.

Ben erg benieuwd wat het probleem is geweest mocht je meer informatie nodig hebben hoor ik het wel.
Het is erg jammer dat ik het niet werkend heb gekregen.

Ik heb ook nog steeds hetzelfde probleem: verschillende keren de wandzender verwijdert en opnieuw ‘gepaired’, app gereset, homey gereset … en nu wordt de flow helemaal niet meer getriggered, door geen enkele knop.
Na enkele uren heb ik het nu toch wel opgegeven hoor.

Robbshop gaf me dezelfde instructies maar ga ook daar reageren dat de wandzender helemaal niet meer werkt.

Beste Ted,

Ook ik heb probleem dat groep 2 niet werkt. Ik heb een keertje op Github hier een melding van gemaakt en toen kreeg ik netjes reactie van je, ook ik heb e.e.a geprobeerd. Aanvullend het Zigbee kanaal van Hue ook op kanaal 11 gezet, zodat dit op hetzelfde kanaal als Homey zou zitten. Omdat ik genoeg knoppen heb, heb ik er verder geen aandacht meer aan geschonken, ik dacht de code moet goed zijn van Ted, dus mogelijk met de Zigbee rewite van Homey, nieuwe ronde nieuwe kansen.

Het zou mooi zijn als het probleem ondervangen kan worden, dan heb ik er weer vier knoppen bij (ik heb 2 x 4 knoppen naast elkaar hangen)

Groet,
Werner

Ik heb het bovenstaande dus ook ondervonden met de zigbee uitvoeringen 2 knops, 4 knops en 8 knops. Alle bovenstaande geprobeerd en niets hielp. Ik was in alle staten en rijp voor een inrichting. Mijn vriendin heeft alle flows verwijderd alle schakelaars ook. Toen opnieuw begonnen. Ik zeg jij bent gek. Dat heb ik al 10 keer gedaan. Haar lukte het wel en waarom? Omdat zij de schakelaars dus iets anders op de Homey legt. En geloof me 1 cm anders, of niet te koppelen, of wel te koppelen maar geen functie op groep 2. Dit echt paar keer gecheckt. 1cm anders en hij zegt fuck you. Of het zo precies luistert? Het zal wel, hier werkt het nu na een weekend stress.