Homey Community Forum

Acces control Heimdall and Homey

Thanks for the drawing, makes it more clear to me :+1:

This Drawing is from robbshop without optocoupler

Yes, but that’s a different keypad. The keypad I mentioned outputs the input voltage on the Lock connections so to be sure you’d better use an optocoupler to not fry the Fibaro Binary sensor.

I will have an china wifi doorbell with NO electric door lock. It has keypad, rfid, wifi, 433mhz and code function to unlock.


How would you suggest me to wire it to a Fibaro universal sensor?

Wiring diagram is below, i will use NO = unlocked when power on.

As my access control open my door (Danalock V3 BTZE) and switches of my alarm (Heimdall) I don’t want to use any RFID device with the electronic part on the outside of the house. If you know a little bit about GND, NO and NC contacts you could bypass the RFID bit after destroying its casing. I have therefor chosen a RFID reader with a separate coil to be fitted on the outside wall and the electronic part to be fitted inside the house. I have used it in combination with a 12v relais and a modified Neo Coolcam doorsensor and it works perfectly, but instead a Fibaro Binary Sensor can be used as well.

I just use a pin code on my phone that triggers a webhook which then turns on the status of my alarm. this work very well i must say.

Hoi Danee,

Since 2 days I suddenly get the same messages multiple time.


Is there something changed. I also here the voice messages twice. (alarm is off) that’s a card I made myself but it sounds twice?

Greetz Frans

Hi @Frans_Keeman, Version 2.0.17 was published 20-03-2019 so no changes in Heimdall since then. Sorry, I guess you have to find the reason elsewhere.

That’s a bummer :confused:. Oké seems that I am the only one also. Wil restart homey maybe this helps.

Greetz Frans

Doesn’t the Heimdall app already announce the alarm is active or deactivated? If you have a flow doing this also, then it would trigger twice.
Check your settings within the Heimdall app, Go to apps, Heimdall, and select configure app, settings, then scroll down to the heading “Let Homey tell you when”. Check what is active here, and then you could remove your own personal Voice flow.