Homey Community Forum

Aeotec range extender 7 issues

Hi All,

I added my range extender 7 to my homey with the beta 5 rc firmware. Somehow I don’t know how it should work? it is there, but not secure and I don’t see any routes where this extender is used. With fibaro I see it sometimes this socket between devices.
Do I need to make it secure ( I did not see a way to do this) or can I do something more to make it work,

thanks Edwin

You just have to be patient, z-wave will create the mesh when (and if) required.

Your network anyway looks very good so the question is why did you get the extender to start with?

And any z-wave mains powered device is itself a router/extender. The Aeotec extender is nothing different than a Fibaro plug. Just cheaper and you cannot plug anything into it.

In conclusion, there is nothing wrong with the unit.

1 Like

I agree with @danone .

Generally it is not possible to choose if the device should be included secure or unsecure, it depends on the device. With some devices it is possible, e.g. if you press the include-button once or twice. With the RE 7 this is unfortunately not possible (with Homey), or it is not known by me.
It would be good if Athom could include such an option (Feature Request).

If security is not important for you, then it makes sense to include the devices unsecured. I haven’t done it completely myself (but I will), but some users say that the response times within the Z-Wave network are much faster.

With the “Heal” function in Developer you can force the routing over new devices. But basically it is not necessary as @danone explained.

thanks, I got some door sensors (battery) which are unreachable and to test it I put it 2 meters in front of homey and would suspect I would to see this one used in the networking route at some moment . This did not happen for some days. the fibaro ones are used indeed.

So will this extender also do secure traffic or is it now only focused on unsecure traffic.

Did a lot of Heal(ing) on those hhehe

thanks

The RE7 is “unsecure” included. If devices are “unsecure” or “secure” included can also be checked in the advanced settings of the devices.
I do not know if the RE7 can be included “secure”, but I guess not (with Homey). Please ask Athom (support@athom.com).

Battery powered devices need to be woken up before using the “Heal function”.
For the sensors I would also activate the option “Wake-Up Interval” in the advanced settings and set it e.g. to 43200 s.
Here the description of the parameter:

thanks will do that.

on the aeotec device it is saying unsecure , there is pincode and see this on the device

this is from the manual.

If you pairing with S2 encryption/security, enter the first 5 digits of the DSK into your controller/gateway/hub
interface when requested.

I have no option to this.

Yes, I know that part of the manual.
That’s why I wrote that there is currently no general possibility to select if the device should be included “Secure” or “Unsecure”.
At the moment it seems to be the only possibility if the device is capable to choose between “Unsecure” and “Secure”, e.g. by a single click or double click (see screenshot of the Aeotec Multisensor 6).

That’ s why I wrote that you should contact Athom about this.

aeotect took over the support of this app , here is the response. of aeotect

The Range Extender 7 only support S2 security and does not support S0 security. If S2 security is not supported, only S2 security or non-secure can only work. ​ Even if Range Extender 7 is paired without security, by Z-Wave standards, it will still repeat secure signals. Z-Wave security is only encrypted and decryped at the controller and at the ending receiving device. - The Pin code is for S2 security, if this method of security is not supported, the pin code is not necessary. The general steps to pair this device normally is: 1. Set controller into pair mode 2. Tap the button on the Range Extender 7 to pair it.

As the RE7 is unsecure included, Homey does not seem to support S2, right?
My RE6 is included secure.

Homey supports S2 partially, S2 has the option for sort of 2 factor authentication for inclusion (an additional 5 digit code on the device that you need to enter during inclusion) which is indeed not supported yet, but once connected it can handle S2 just fine.

1 Like

Thanks for clearing that up!

good news I saw at least the route

it looks like homey is preferred way of connecting and if not it uses the range extender.

I will ask aeotec when they will add support for the s2 5 digit code for their homey app.

The routes will change from time to time, that is quite normal. Also the routes do not always seem to be logically structured, but that is also quite normal.

I don’t think Aeotec can answer this question. Even if Aeotec supports the app development, in the end Athom will probably say what is done and what is not done.
Also, I guess that the “problem” is not a problem of the app, I guess it depends on the Z-Wave code. @Caseda can you clarify this?

Correct, this can’t be done on app level, needs to be done in the core by Athom.
From what I heard “they are working on it, but it is difficult”, but that’s a littlebit of a standard answer from Athom.

2 Likes

Maybe a stupid question but… where can i view this screen on my system?

Go to Homey Developer

1 Like

Thanks! That’s really helpfull…