Homey Community Forum

Aeotec Siren 6 installed, but won't work

Hi all,
Today I received my Aeotec Siren 6. It installed like a breeze and I created flows for/ with it. But as soon as I tested the flows I got an error “device not available”. In the device list the siren now has a red triangle with an exclamation mark. Whwn long clicking the siren, i get the message “apparaat niet beschikbaar” (device not available) and “device.setUnavailable is not a function”

My Homey Pro is running on 7.1.3
Hopefully one of you can help me fix this
Greetings, Cor

There is a good chance that it is out of range, too far away from Homey. Please test with both close together.

Not sure what is going on here, but I have had the Siren 6 for some time and today it is also telling me that is is not available. It is only a couple of meters away from the homey.

Resetting makes no difference, so thought I would remove it and reinstall it.
Removing is fine, but when trying to reistall the Aeotec app has a warning sign over it an can not be selected…

Perhaps this is caused by an application update?

Edit:
Homey also tells me that the Aeotec app has been updated 6 hours ago to version 3.2.1….
Definately something there.

Restarting Homey removes the warning sign, but I have not so far been able to install the Siren 6 again. - No response, so far, from homey when the Sirens 6 join-button is pressed.

Try to remove it via the developer site:
https://tools.developer.homey.app/tools/devices
Enter the exact device name in the search field. When it’s displayed, hit the recycle bin icon.

I would recommend to disable auto-updates if you don’t like these kind of surprises.

And, did you try a brand new battery. Can’t do any harm.:blush:

Thanks Peter.
I understand where you are coming from on disabling updates, but Homey have a big installed base of users now, so I expect a “little” more than this to be honest.
The Siren 6 is gone, but thanks for reminding on removing from the develop site. The trick now is to get it back into the system again. I have a total of 3 Siren 6 in the house here all the same all over… The alarms run on on 230V only with a rechargeable battery inside, but I agree. Batteries are always a good first move.
Again thanks Peter. A supportcase have been started. I a looking forward to see how that works :wink:

1 Like

Homey and siren are 50 cm apart, so that won’t be the issue.
Thanks for thinking along

I removed my siren and could install it again, but again when testing it, the error came back. Do you also get the same notification when you press and hold the siren tile?
“device.setUnavailable is not a function”
I get the feeling there’s a typo in the program, since there’s no space between the t and U. Hopefully someone can check this.

Please contact Aeotec (Aeotec support). I guess also that the new app version has something to do with these issues, because in this version they made some changes regarding the Siren 6.
Here you find some more information:

1 Like

Just reported it at Aeotec. If there’s any news, I’ll share it here.

1 Like

New app version v3.2.2 already released!

2 Likes

Can confirm that with 3.2.2 everyting is back again and can be triggered from Homey.

1 Like

Working now with version 3.2.2

1 Like