Homey Community Forum

Again Zigbee annoyance

Anyone have any idea? All lamps in the home can be operated with a wired Xiaomi zigbee wall switch. In principle they all do fine, only … sometimes the lamp switches, sometimes not. Sometimes you can turn on a lamp, but you can no longer turn it off. Then you get the message that an unknown error has occurred. The problem can then be solved by restarting Homey. That there are problems with the zigbee network at Homey will not be a secret. Apparently that is not a priority for Athom because since the introduction of the software 2.0 in January and after 10 updates, nothing has been fixed. But maybe there is more going on. Zigbee works on a frequency of 2.4 Mhz, and let that now also be the fequent that the WiFi network uses. Would it be possible for both to influence each other and thus cause a bad Zigbee network? Who has experience with that. By the way, as mentioned, these are wired switches that are all recognized as a router for insights at Homey. So I’m looking for a way to have a stable Zigbee mesh network, one that always works.

Yes

Operating a ZigBee network and a WiFi network on the same frequency will cause them to interfere with each other. Usually, the ZigBee network will take the hit.

I have the same experience with ZigBee and homey.
Since a use the Hue Bridge no issues anymore.

Btw. Hue Bride doesn’t have WLAN only LAN, it must be a reason behind!

This would only occur if you have a terrible wireless router which has a lot of frequency spread. Zigbee operates on channels of the wifi channels 1-14. See here
What could interfere is other equipment running in 2.4ghz band. Like for example some cheap wireless camera or babyphone or wireless audiolink. Try turn these of and see if this is a problem or not. Might even that neighbours use such device.

Instead of restarting Homey did you also try to just restart the Xiaomi app and see if that fixes your issues too?

The explanation I received from Da_JoJo was very useful. I also went to work and searched for a channel on my router that had little or no interest in the Zigbee network. Until now with little success. I thought the cause might have been too many devices, but on the forum I think there are users with many more Zigbee related devices. I did notice something. On others I see that their zigbee network is displayed like this on the developers page

.
When I went to look at this page with me, I saw the following. All devices are there, but there is no reference to a network. What did I do wrong with the installation or how should I read and understand this? I would like to know more about this.

It may take several minutes for the network layout to appear.

That is something I am aware of, but it has always been like that. So I ask myself if I did something wrong during the installation. On the other hand, mention that all switches actually work, but it is true that some now and then give the error message that they cannot be reached, so that they can be operated a little later. It is always the question does he do it or does he not do it. Or is it just the Homey Zigbee software. Apparently I am not alone, because there is a lot to be found on the foum.

The routes that are shown don’t make sense (devices routing themselves), so if it doesn’t show the proper routes eventually, there might be something wrong in the rendering of that page.

As you state: Zigbee is flaky on Homey currently.

After a while of clicking with cursor on zigbee devices, routes will appear :slight_smile:

Automatic dynamic routing seems not to be working on the Homey. What might help (helped me a lot) is adding Zigbee devices on their final location in your home.
First add powered devices (router) to be placed near the homey. Proceed with routers further away but during installment close to the router you expect it to link with.
Finish with battery powered devices. Install those close to the router you expect it to link to.
So basically you are building your own mesh routes. Worked great for me.

That is exactly how I installed it. And in principle, everything works fine. Only. it is not really stable. A lamp that does well cannot be reached without any apparent reason and therefore no longer works. The next day the lamp does well again, but there is another that suddenly becomes unreachable. And so there is something every day that fails and works properly after a while. So it seems to me that Homey is going wrong here.