Homey Community Forum

[Alpha : 1.7.1] Amazon - Alexa Text to Speech, Announcements, Weather, News, Traffic and more

Thanks again for all your work on this great app! @Jamie I’ve installed v1.6.3 and I”ll report back soon.

I will test it. Thanks again @Jamie

Was checking the app status in the Homey app and saw that it has crashed. Don’t know when this exactly happened.

I restarted the app and it works again. Will check if it will last.

It’s worth mentioning that some people have had to remove and re add the devices In order to connect

1 Like

Indeed. For me it was the only way to reactivate the devices. After the update I had only the red angle with exclamation mark and no restart of the app or disable/enable if the app worked to fix it.

But deinstalling and a fresh install of the app and then readd the devices worked for me.

1.6.4 has been released - which contains a fix for an error upon PUSH_MEDIA_PROGRESS_CHANGE.


If you notice something isnt working (text to speech for example). If you could please to do the action again manually and then send an error report - so that I can find the issue. If you could also please try clicking the ‘weather’ button on the device and letting me know if that still works.

Also, if the app is working for you - it would be great to know.

Thanks

2 Likes

Hy, @Jamie, where can i find this reales.
I can not wait to test it. I have 2 Fire Tv Stickstoff, 3 Echo Dost, 1 Echo and 2 Fire tabs ( for dasch).
Thanks

Just installed 1.6.4a, will test and report back.
So far 1.6.3 had worked great since install with only one instance of disconnecting, where the flow used informed me of it straight away.

1 Like

Hi @Viorel_Dimitrescu - I am currently alpha testing this app until such time as it is stable.


@autolycos Thanks for the feedback, it is jsut as important to know who the app is working for as it is to know who it is not working for. Did the app auto-reconnect for you as well?

No, at least not within the minute from I got the information that it got disconnected until I manually reconnected again.

Hi @Jamie, I understaud that is not the stable version and I will be glad to test it also. I would install it localy.

Thanks

If it detects that it is ‘disconnected’ from amazon, it will keep trying to ‘connect’ again every 5 minutes (its a setting you will be able change).

Not to be confused with a ‘unauthenticate’ - we means the app need you to authenticate again.

1 Like

Ah, great feature. I’ll let it run its course the next time it may happen then and report back my findings.
I’m just too damn quick for Alexa… :joy:

Has anyone else had an issue where the app continues to work, however Alexa stops doing TTS?

Yes, I had this last evening (1.6.3). I’m going to install 1.6.4 in a bit.

Edit:
Installed 1.6.4a and everything is working great so far. Starting the weather report via the button still works. Didn’t have the time yesterday evening to make a log of the TTS that stopped working, but will do if it will encounter again.

Just checked in the Homey app if everything was still on point. Everything seemed fine, but unfortunately TTS isn’t working again.

Log: 074e0b1d-2d39-41b6-a4b6-ae849c1b216f @Jamie

Hallo Jamie,

Same problem here. App is working, no error. But no tts working

Hey @Novatrust

The log I received, it looks like Alexa had just connected and 10 seconds later you requested the weather, did the weather command work? I am guessing that the log was from after a restart?

@Skorpion how long was the TTS working before it stopped, and how long was Alexa connected for? If you pressed the weather button was the weather spoken?

When you go to the Alexa App home screen (more -> apps -> alexa) , is there a red warning upon it?

Thanks

Hello jamie,

sorry, i can’t remember exactly. For now the app starts after 3hours via flow. Last restart 35 minutes ago, but tts won’t work

12fdd90f-44bf-4bd8-a611-536bea4b4da5

@Novatrust

No noticed this in the log :

2019-07-03 21:31:59 [log] [ManagerDrivers] [echo-plus.2] [2] EchoDevice:command weather </EchoDevice:command>

I assume that the weather command didn’t work either?