Homey Community Forum

Any experts on sending z-wave RAW

z-wave
#1

I want to send to all my Greenwave Plugs every hour a z-wave raw command.

From the guide what is the RAW Command I need to send to set keep alive time to 255.

I have not had to send raw z-wave commands before - I have been able to use the HA config for the device before.

Any help would be appreciated.

(for clarity, if I can send a Raw command to the Greenwave every hour, alternating between setting 254 and 255 then I can stop it it from resisting it is ‘lost’ every 4:15 hours - normally I would just use the HA to send a poll/test every hour to stop a timeout - but cant work out how to do that automatically)

Athom support suggested that I use the Homey app every 4 hours and send a Parameter change to the 30+ devices. Not very practical, if I don’t wake up half way through the night every bedroom starts experiencing a very bright flashing in the room that feels like an Emergency beacon going off :slight_smile: - I am convinced there is a workaround to get Homey to poll somehow.

#2

image

#3

Thanks for that.

Got where to I understood how to construct the Raw ZWave, then worked out how Homey likes them presented, then identified a likely candidate that would effectively allow me to do a Poll by sending a Zwave Raw command.

I came up with the Greenwave Flashing issue by sending the Raw command “0x25, 0x02” once an hour to the Greenwave - basically asking ‘what is your switch status?’

That resets the time out status.

1 Like
#4

Somehow the greenwave wants to give out an hourly report about its powerconsumption. There’s a wheel with numbers and colors so you can designate different greenwave nodes to different rooms/powerusage schemes. So the controller needs to poll the device hourly or it will time-out and think connection is broken and thus blinking the led. I just turned the led off, problem solved.

#5

How did you turn off the led light?

#6

Yesterday I tried with 2 units PowerNode-6, to sent this command:
image
the result was for 1 unit, no more blinking whole day, the other unit was blinking as before,
just some minutes ago, I did sent it again.

Edit: This is not a solution, does not work for me!

see for documentation
https://www.vesternet.com/mwdownloads/download/link/id/1636/

#7

So far sending ‘0x25, 0x02’ every hour is stopping all (about 10 so far) from going to ‘lost’ mode.

#8

http://forum.micasaverde.com/index.php/topic,9212.0.html
Here you can find all the info about the device. Its long time ago so i can’t remember what i wrote about it xD
Edit: led off > parameter 1 set to 255

2 Likes