Homey Community Forum

[APP] Amazon - Alexa

Hi, It looks very interesting. I would like to do something like that - primary I used Siri like voice assistant in a home but lots of things don’t work with iOS. But with Alexa works perfectly but I have only one Alexa device. I have Bose portable home speaker with Alexa integration.

My idea is

  1. Crate virtual button in Homey
  2. For button create a flow which sends a text command to Alexa, for example, Turn On Tv
  3. Add virtual button to Apple Home Kit
  4. Create Siri shortcuts to change the virtual button state and run homey flow from point 2.

All points except the second are possible. Is it possible to do the second point with this module?
I don’t have a problem sending you a donation when you need to change something.

Thanks

Will the 4th generation be added soon? Pleease?

2 Likes

Hi, not to be rude but is this app not being maintained anymore? I so wish that someone would be kind enough to maintain it, the routines still don’t work and I use them a lot.

the code is not public, so it can not be adopted. i hope @Jamie is willing to accept some help. the issue seems localized to eu servers and its impossible to test for him without eu account with devices. I and others are more than willing to help, i have made homey apps so with the code i can fully test the problem and see if i can find a solution. i am also willing to register a echo dot to a eu account and give the credentials.
i loved the app while it worked, now its a mis that it is not

2 Likes

Loved that app too,really miss it…

I’ve had this issue on the EU servers for quite a while, it has increased a little over the last 2 months. If you need some logs etc, just let me know what you need and how i can help you investigate what is causing this. It doesn’t seem to be disconnected in homey, untill you click the device. You can just connec again and then everything works fine, sometimes it happens once a day, sometimes 3-4 times a day.

In some cases, after i reconnect, i don’t get the login screen but still seeems to be connected again, although i’m not (flows etc don’t work). If i disconnect and reconnect, including entering password) everything works fine again

Let me know if you need some help testing :+1:

It’s not just on the EU server. Same problem when I log in under Amazon.com.

1 Like

I live in Europe but I use the US servers and I’m also having all the above mentioned troubles, so yeah it’s not only the EU servers.

Have a new issue now, even when connected (disconnected and reconnected multiple times), for some reason my alexa doesn’t execute the flo, tried to play music from flow, start routine and other things. Alexa’s show up as connected in Homey, also the flow states it was executed correctly.

Does anyone else have this issue at the moment?

Hi is this project live or die? I bought amazon echo 3 gen only for this project because I want to send a text command from iso shortcut to Alexa and for me absolutely doesn’t work. I install this project without any problem connecting to the Eu server because I had a UK amazon account. I try to create a virtual button and run Alexa have a fun command. It doesn’t work I tried another command, the same situation. Is it possible to help me?? I don’t have any problem send donation for any help …

For me it seems to work fine, just disconnects on the UK servers sometimes (sometimes multiple times a day), can you explain exactly what you are doing and maybe share some screens so we can try to see if we can help you?

Small update, setup a new environment at a friends place over the weekend, including some new Alexa devices, so chose to setup a US account, and it has (so far) been working perfectly, without any disconnects. Since others here said they have issues with US servers too, could it be account related in any way (some other setting), or was I just lucky so far on the new setup :stuck_out_tongue:

For me it’s mostly that I can’t use routines anymore, more than it disconnects which bothers me, I use routines a lot in combination with flows and now I have to use ifttt every time I want to use one, I didn’t before and ifttt costs money, not that it’s a lot but still I liked the fact that homey’s Alexa could trigger the routine without or you know directly from the flow itself.

But you have an alexa routine, you see that routine in Homey, but you cant trigger it?
Did you try to go to apps, Alexa app and click the disconnect button, then try to reconnect (in homey)?

After that it should work, just tested it on my device. If for some reason it still doesn’t, can you disconnect and try to connect to another server (US for example) and see if it works then?

I’m already on the US server but the routines don’t show for me at all, none of them, in homey I mean, they did before the 5.0 update but not anymore. And it doesn’t help to disconnect and reconnect sadly.

I had a few flows using routines and they worked fine still, till I just added another one, the new ones do not show up in the list and now the old flows are not working anymore either, seems we are now having the same issue… :frowning:

Still the same problem here to.
No more routines showing up in the flow cards.
Text to speech not working anymore.
When disconnected it is always “When we are unable to be authenticated by the Amazon Server any more.”
Still no support for echo 4th gen, echo show 10

The Homey Alexa integration works fine for starting homey favorite flows or controlling homey devices on a Alexa device.

Hoping on a fix soon because text to speech is used a lot here…

1 Like

Echo Show 8 and 10 work through the app.

Echo show 8 yes. Got this one in my kitchen. But looking for adding the echo show 10 in my kitchen en replacing the show 8 to my bedroom but i dont see the tile for the show 10 in the app.

Hey everyone,

There are very clear instructions on what to do if you would like a new device added to this app.

If you have an issue with this app, letting me know what is going on in this thread is useful;

  • What exactly is happening
  • how often it is happening
  • how long has it been occurring for
  • what version of the app are you using
  • why its a problem
  • what devices do you have
  • what country you live in
  • what server are your alexa devices connected to
  • what server are you connecting to using the app.
  • Whats the diagnostic report num.

If you are experiencing the exact same issue as someone else - the like their pos so I can see it.

"its not working, is less then useful - it just a waste of time and space - I will be deleting posts like that going forward.


The code for this repo is currently private, but it is not a secret, happy to share with anyone who has the means and time to look deeper into the EU mystery, I estimated there is (for me) 40-80 hours of work required to look into it.

4 Likes