Homey Community Forum

[APP] Amazon - Alexa

I am hoping he goes public beta and not add alpha testers. Going public would increase the change to find patterns in the users with disconnect issues. Just mention this known issue in the beta release and all thatchoose to test can provide feedback.

how can i test it pleas?

can I also have a try?

Kind regards

Thanks for the offers, how ever there is a priority of people to join the alpha testers of this app. How to get on the list an/or get to the top is well documented in this thread.

Thanks again.

A quick update from me.
As of last week, everything related to this app has been running flawlessly and I haven’t run into the previous issues with disconnect or de-authorization resulting in no TTS. As the app hasn’t been updated (nor the firmware), my guess is that it’s either that I put all of my Echo devices on static IP or some other magic. :wink:

Must be some other magic, because all my Echo devices have had a static ip for some time now. @autolycos

@Jamie here’s another log 3b98a5bf-7b15-4c6e-a270-77e9ee6b4f0a
I tried (succesfully for a while) to periodically (every 2 days) to restart the app but now it was hanging despite the auto-restart. Manual restarting also didn’t work. It appeared the app was disconnected from Alexa. But I have triggers to send me a notification when that happens and that never happened.
Hope it helps.

Based on the log you sent through, you are not authorised, you will need to go the app settings page and login again.

Yes correct that fixed it but I had expected the “not authorized” trigger to trigger but it looked that never did. Anyway no help for the “doesn’t work after a few days but no reason why” issue for you. I’ll keep sending logs if I find something strange.

1 Like

After a homey reset, I can’t see t to be able to add my devices. It is stuck on asking Amazon. Any trouble shooting tips?

Is it still happening?

I checked yesterday to no avail, but this morning it worked. Nothing changed, but still happy :). Continue testing

Something else strange, I implemented an auto restart Alexa flow (every day) in the hope to fix the issue that TTS stops working after several days and a manual restart of Alexa app fixed it, but: auto restart doesn’t seem to really restart Alexa app… so it also doesn’t fix the lost TTS, I still need to manually restart the app.
Maybe fixing this gives a clue why the TTS is lost?

2 Likes

my first view:

(German Amazon Konto)

  • works fine with Sonos One, Echo Show 1, Echo Spot
  • with the Echo Show 2nd I´ve sometimes not all messages on this device

Has anyone tested it under 3.0?

still a bit scared to move to 3.0… due to app compatibility… on 2.0 is works awesome@

Works for me under 3.0

Works fine with Homey 3.0

After upgrade to 3.0 it didn’t work (was running and connected but no sound), after manually restarting app it worked. Didn’t try a new reboot of homey to see if it stops working then.

but no new install under 3.0 - right?