Homey Community Forum

[APP] Amazon - Alexa

For me it seems to work fine, just disconnects on the UK servers sometimes (sometimes multiple times a day), can you explain exactly what you are doing and maybe share some screens so we can try to see if we can help you?

Small update, setup a new environment at a friends place over the weekend, including some new Alexa devices, so chose to setup a US account, and it has (so far) been working perfectly, without any disconnects. Since others here said they have issues with US servers too, could it be account related in any way (some other setting), or was I just lucky so far on the new setup :stuck_out_tongue:

For me it’s mostly that I can’t use routines anymore, more than it disconnects which bothers me, I use routines a lot in combination with flows and now I have to use ifttt every time I want to use one, I didn’t before and ifttt costs money, not that it’s a lot but still I liked the fact that homey’s Alexa could trigger the routine without or you know directly from the flow itself.

But you have an alexa routine, you see that routine in Homey, but you cant trigger it?
Did you try to go to apps, Alexa app and click the disconnect button, then try to reconnect (in homey)?

After that it should work, just tested it on my device. If for some reason it still doesn’t, can you disconnect and try to connect to another server (US for example) and see if it works then?

I’m already on the US server but the routines don’t show for me at all, none of them, in homey I mean, they did before the 5.0 update but not anymore. And it doesn’t help to disconnect and reconnect sadly.

I had a few flows using routines and they worked fine still, till I just added another one, the new ones do not show up in the list and now the old flows are not working anymore either, seems we are now having the same issue… :frowning:

Still the same problem here to.
No more routines showing up in the flow cards.
Text to speech not working anymore.
When disconnected it is always “When we are unable to be authenticated by the Amazon Server any more.”
Still no support for echo 4th gen, echo show 10

The Homey Alexa integration works fine for starting homey favorite flows or controlling homey devices on a Alexa device.

Hoping on a fix soon because text to speech is used a lot here…

1 Like

Echo Show 8 and 10 work through the app.

Echo show 8 yes. Got this one in my kitchen. But looking for adding the echo show 10 in my kitchen en replacing the show 8 to my bedroom but i dont see the tile for the show 10 in the app.

Hey everyone,

There are very clear instructions on what to do if you would like a new device added to this app.

If you have an issue with this app, letting me know what is going on in this thread is useful;

  • What exactly is happening
  • how often it is happening
  • how long has it been occurring for
  • what version of the app are you using
  • why its a problem
  • what devices do you have
  • what country you live in
  • what server are your alexa devices connected to
  • what server are you connecting to using the app.
  • Whats the diagnostic report num.

If you are experiencing the exact same issue as someone else - the like their pos so I can see it.

"its not working, is less then useful - it just a waste of time and space - I will be deleting posts like that going forward.


The code for this repo is currently private, but it is not a secret, happy to share with anyone who has the means and time to look deeper into the EU mystery, I estimated there is (for me) 40-80 hours of work required to look into it.

3 Likes

Hello @Jamie

  • What exactly is happening: Disconnecting issues, unable to be authenticated by the Amazon Server any more. Alexa Routines not showing anymore in homey flow cards.
    When reconnecting, text to speech works again but still no routines showing up. I’m getting the error cannot read property “filter” of undefined.

  • how often it is happening: Not time or day related. Can disconnect once a day or even more.

  • how long has it been occurring for: Since version 3.5.100. Posted on 22 Jan for that problem.

  • what version of the app are you using: Your app Version 3.5.101 and homey version 5.0.4

  • why its a problem: As i use a lot text to speech and Alexa routines not showing anymore in homey this app becomes useless. However i’m in need of this.

  • what devices do you have: 3x Echo dot gen 3. 1x Echo plus gen 2. 1x Echo flex gen 1. 1x Echo show 8.

  • what country you live in: Belgium.

  • what server are your alexa devices connected to: EU Server.

  • what server are you connecting to using the app. EU Server.

  • Whats the diagnostic report num. Homey diagnostic: E6EF6E App diagnostic: 96cc876a-84b5-4cf6-84dc-ee8c72538430

Hope you find the problem soon.

5 Likes

I have the exact same issue as @ZvFreak

i am in the netherlands, uk account, app connected to the EU servers.

disconnects are near instant.
i reauthenticate, use a weather report button one off the devices, that works a couple of times and then its unauthorized again.

i own 2xecho dot 3, 3x echo show 5, 1x echo dot 4 premium

worth noting is that we use household features so several of them tend to be switched to my wifes profile.

use case, i use it a lot for making homey talk to the household. so now we are living in a smart home thats mute.

app 3.5.101
homey 5.0.4

Hi Jamie,
Good to hear from you,
Same issue here, the app disconnects itself unable to be authenticated by the Amazon Server.
It typically happens two to three times a day but sometimes much more…
It started around mid-january this year
I use app Version 3.5.101 and homey version 5.0.4
It is really a problem because I use text to speech and when the app is disconnected it doesn’t work so the app can not be considered as reliable
My devices are 3 Echo dot 3, Sonos One and Sonos beam
I live in France and use the EU server.
Hope this will help you to fix this great app.
Don’t hesitate if you need further info

1 Like

Hi, I have the same issue as the others but I’m on the US server although I live in Europe, Denmark.

Routines don’t show up in flows anymore after updating to Homey 5.0 and they are very essential to me, I use them a lot. This is the most important part which needs fixing in my opinion.

The Alexa app disconnects several times a day from the server.

I have a lot of echoes, 2 Echo Show first gen., 2 Echo Show second gen., 1 Echo Dot, 2 Echo Show 5. It’s the same on all of them.

Ps. If it’s possible, then I would be very grateful if you could add the Alexa Oral-b Guide as well. If you don’t know what it is, then it’s a toothbrush with an Alexa base attached to it :slight_smile: :slight_smile:

Disconnecting issues, unable to be authenticated by the Amazon Server any more

Two people have stated that they are unable to be authenticated by the Amazon Server. - But also that they are disconnected from the Amazon server immediately?

How are both possible (they are very different) and when you say “immediately” do you mean it DOESN’T authenticate - or you only stay authenticated for seconds/minutes/hours?

Other people have stated they are disconnected several times a day - I am assuming that this means that you are experiencing a different problem?

Hi @Jamie hope you’re doing well,
I also face the disconnecting issue. I use the EU server.
The authentification works, but the thing is, if I “press” on a added device, I lost the connection immediatey.
Regards

So does it “stay connected” so long as you don’t try and do an action?

Can you give this a go - and let me know what happens (in full detail)

1 Like

It stays connected but I cannot use any feature in a flow, even routines.

Some tests made with this version (more than hour left):
All Alexa commands → OK
Routines–> OK
And all devices are still connected to Amazon server. I’m using EU server.
Great job :slight_smile: