Homey Community Forum

[APP] Amazon - Alexa

Now i had some disconnections. Hitting the reconnect button connected again but the TTS didn‘t worked.

Then i deactivated the app and reactivated it again. Now TTS worked.

Before the App was Running without Problems for three days. So Jamie is on the Right way.

Same situation for me…3 days working perfectly and yesterday I had the first disconnection.
Using the “reconnect” button it works for the connection but I see all of my devices as unavailable.
Using the “connect” button it makes everything fully working again.

Didn’t really disconnect with mine, it says connected, but stopped working after a few days. Reconnecting did the same, till I restarted the app. So could be it is not amazon related, will keep testing, but wanted to share the update so others could share their experiences and try to resolve issues. This app is just amazing :+1:

1 Like

Have the v.3.7.101 been removed again? because I can only install the v3.5.101 :slight_smile:
I just purchased echo dot 4’th gen and the 4’th gen was added in the v3.7.101, so it would be nice to have that version :slight_smile:

Have a great day :smiley:

Full disclosure - the “reconnect” button is as it sounds - it assumes that there was some sort of disconnection it couldn’t recover from but your credentials are still valid.

If it doesn’t work, then it’s a “ real disconnect” where Amazon has said your now logged out - please log back in.

I was just testing with the reconnect - Phil do you mean to say that the reconnect button fails … but then simply restarting homey or the app and your automatically reconnected?

Same Problem here
App show me: connected
Flows doesn‘t work
After only restart App, everything is ok and flows runs fine

1 Like

Yep, that fixed it for me too, just restart app, then connect again. I have the idea it takes longer then before before it disconnects (actually it never disconnected, but stopped working), since the last update

1 Like

Yes. Only clicking „reconnect“ didn‘t fixed the no TTS. But When i deacticated the app and Then just reactivated it the TTS began to work.

Strange. Now the App runs after this behaviour for 2 days without a Problem.

I have to investigate further. But a massive step forward to the version before!

So you are on the Right way. I left you know if i find out More. I promise

Just see @DaWa74 and @Chris_nl comments abbiegen. Same here.

1 Like

Today i did get disconnected again, not sure if it is the same “issue” since I also had to approve the login attempt through a text-message, so maybe Amazon changed something and that was the reason for the disconnect. Will keep testing, but still feel it takes longer before it disconnects

UPDATE: 24 hours online and still working, 0 disconnects

I have thankfully not been disconnected for several days now, I think it only happened once with this new test app, so everything seems to work fine on my end. I’m on us server here. Thank you so much Jamie!! :pray::slightly_smiling_face::slightly_smiling_face:

1 Like

TTS worked fine a few days. Then I recognized that it stops working. The app/homey was still shown as connected so I couldn’t reconnect via the new button. A restart of the app didn’t help, but deactivating + reactivating the app solved the problem for me too. I’m still connected since days.

Thank’s a lot @Jamie for the update of the app and @PhilS for the tip!!

1 Like

TTS stopped again after 2 days. But now we know how to get it back:

App deactivating + reactivating

This works manually but also with a flow. So I decide to reactivate the app every time I want Alexa something to say:

First I tried to implement the Alexa speak card in the then part of the first flow. But it didn’t work because if you deactivate an app which card you use inside the same deactivation flow the flowcard becomes invalid at runtime and will not continue after reactivation of the app. But it works if you start another flow with a delay. In the delay time the second flow will become valid again.

PS: Sorry, cards are in German. But I hope it’s clear how it works.

Same for me, disconnected just short of 48 hours, it’s way better then the disconnects before :+1:

1 Like

As i mentioned :smirk:
Great if this workaround works :muscle:

hello everyone who ever managed to call homey alexa to
to perform a flow or an action with the voice of homey alexa

Groet Jonathan

Hi , I read the FAQ but I can’t get the routines to show up. I have a lot of routines and mosto of them have names, I even tried creating a new one for testing but it won’t appear in the flow card. I tried restarting the app and still no success. Any help?

I’m in EU and I have a lot of Alexa devices ( fire TV cube, show2nd gen, show5, echo plus dot flex and input)and if need be i can help with testing.

No matter what I do, the connected devices become unresponsive after a while (usually few hours). Regularly.

I even deactivated 2fa temporarily and it didn’t change anything.

In it’s current state this app is sadly not usable.

PS: Deactivating and reactivating the app does not do anything for me. The devices remain unavailable and I need to reconnect the app.

Just a hint and maybe you tried it before:

You have to type the first characters of your routine names in the selection box of the trigger card of the flow. Only then the routine names appear as a list.