Homey Community Forum

[APP] Amazon - Alexa

Sorry for the delay (I forgot), the test version of the Alexa app which has been out for a while now has been released to the public channel. This includes Echo gen4 etc.

1 Like

Hello just wondering, ive tried to add my Daikin AC units (since they are connected to Alexa), but they wont show up. I tried choosing Other as device type, any idea?

Just says time out after 30000ms.

From memory I was only able to backwards engineer on/off and dim (and change to a specific colour, though I never added that as it didnt work with the athom colour picker). But like Homey Alexa also has ‘devices’. So Switches and Lights … but I created ‘other’ which would ignore the device type and look for items with on/off or dim … when the device uses just the generic way of going about it.

ie. My Tuya diffuser has the on/off capability but is not a switch. My guess is anything as complex as a aircon would not be using default capabilities.

I have the same problem. Too bad I read this too late, after I deleted everything and re-added :slight_smile:

Sadly enough restarting the app and disconnecting/reconnecting doesn’t even work :frowning:

Jamie, is it possible that you could add the Alexa oral-b guide as well to the app? Only when and if you get the time of course. I understand if this is not easy to do, I just wanted to mention it in case it wasn’t that hard :slight_smile:

For a second I thought: “Alexa, brush my teeth” has become reality now :sweat_smile::crazy_face:

1 Like

LOL I think that would be much laziness, although I wouldn’t say no… :rofl::rofl::rofl:

Joking aside though, I would like the option to start the news or anything really every time I pick up my toothbrush. As it is right now the base is barely recognised as an Alexa device in the Alexa app, its at least all it is, I can’t do much with it. There used to be a skill for it which allowed me to create routines but for some reason it got removed, so now I can’t do anything with it, HOMEY won’t recognise it.

Hey OWA,

The information required to add a new device are outlines in the first two posts of this thread.

Thanks!

1 Like

@Jamie, first of all thanks for your effort, I believe it isn’t easy to run after alexa app. Anyhow as it happens to many users, also in my case, very often your app loose the connection with the alexa server. I saw that now you added the option “reconnect” that works and you are not asked to enter id and password (very well done!). Would it be possibile to have this option in a flow. In this way I could ask home to execute this operation automatically bypassing the frequent disconnection. Must say that before Homey 7 version (or at least since two weeks ago), your app was quite stable after a long nightmare period. But now the connection is lost very frequently again.

Thank you so much Jamie :pray::slightly_smiling_face: Your work is amazing. I missed those posts or forgot them. I used to be really really good at coding and building computers from scratch and any tech in general but then I got this brain injury some years ago, so now I can hardly do a few things. I rely on all these smart screens and my homey to help me out with my memory loss which I suffer from all the time. Your app means SO much to me, thank you. I’ll look at the info and see if I can figure it out, not sure if I can but I’ll try, I understand why you need it :slightly_smiling_face:

@Jamie , I saw that if you restart the app it works again. So I can use this solution to solve the problem.

I have the same situation: after the disconnection, if I use the “reconnect” button in settings the app reconnects the service, but the devices are shown as “unavailable”.

On the contrary, if I restart the app and use the “connect” button, I can have all my devices available again.