Homey Community Forum

[APP] deCONZ

I’ve investigated the case where the “Recal a Scene” flow card does not list the correct scenes. As I already though this is actually a bug in homey, see https://github.com/athombv/homey-apps-sdk-issues/issues/144

I hope they will resolve it soon but I cannot really fix it on my side

1 Like

Yes, but also a blank install ends in a messed up system after a reboot. I will send an email to phoscon to see if this is still a know bug. A few months ago a lot of people had this problem.

For now I connected my lights via IKEA bridge. It works good. But my sensors via Homey zigbee is terrible. Even with a lot of routers in my zigbee network.

I just received my Mi Light sensor yesterday, now trying to add it but it doesn’t show up. When looking at https://phoscon.de/en/conbee2/compatible i cannot find it being supported. it is however in the device list when trying to add it from the deCONZ app in Homey. Any thoughts what could be wrong?

When looking at deconz with VNC I can see a node is being added but nothing happens. Normally the ‘ready’ button becomes available but now it doesn’t. I can see some red lights flashing on the vnc view on the specific node but that’s it. Faulty module?

— Edit

Weirdness… I went upstairs where the conbee II stick resides. I tried adding it there, and it succeeded immediately. I cannot see it however in the phoscon web app, I can however add it to homey. The routing was still through downstairs and it works just fine downstairs… so … all is well i guess.

A lot of devices are not supported by the phoscon app but but by deconz and the api. This is why it works in homey. Btw: red flashing lights on a node in the vnc view indicate that there are errors in the communication. This is most likely why the pairing failed initially

Right, this means they are visible through deconz (vnc) and not phoscon. Works well enough now, just weird the initial pairing failed even though i tried it a dozen times. Only after taking the unit upstairs it paired, but through the light bulb downstairs, there is no reach in the second floor through that bulb so … oh well… it works, just sux I cannot rename it in phoscon, now there is a difference in naming between homey and deconz.

Trying to rename inside deconz doesnt seem to work. It just says ‘sending user descriptor set request’.

You can make a manual API call to rename it:

    "51": {
        "config": {
            "battery": 100,
            "on": true,
            "reachable": true,
            "temperature": 0,
            "tholddark": 12000,
            "tholdoffset": 7000
        },
        "ep": 1,
        "etag": "XXX",
        "manufacturername": "LUMI",
        "modelid": "lumi.sen_ill.mgl01",
        "name": "Verlichtingssensor Dak",
        "state": {
            "dark": true,
            "daylight": false,
            "lastupdated": "2020-09-17T04:36:06",
            "lightlevel": 3011,
            "lux": 2
        },
        "swversion": "20191118",
        "type": "ZHALightLevel",
        "uniqueid": "XXX"
    }

Here, “51” is the sensor id.

1 Like

I have been trying to connect connBee2 to homey for several days. I followed the instructions but I always get a generic error !!! where am i wrong?

the conBee is connected to a raspberryPie 4 on which HASSio is installed

thank you so much!

second message only for attachment

You’re running deCONZ/Phoscon in a Docker container, in which case auto-discovery will not work unless you’re using the macvlan network driver for that particular container (but since you’re using Hassio, which abstracts a lot of that away, I don’t know how you would need to configure that).

I’m getting the following error:

Request Method: PUT
Response Time: 0.01 seconds
Response Status: 400 - Bad Request

I know the ID is 68, so i’m doing http://IP/api/APIKEY/sensors/68 with a PUT, it results in:

[
{
“error”: {
“address”: “/sensors”,
“description”: “body contains invalid JSON”,
“type”: 2
}
}
]

Any thoughts? I tried putting some " around it, or ( ) , but doesn’t mater.

Ah sorry, my CLI tool converts the payload to JSON automatically. You should probably use this as payload: {"name":"New Name Here"}

1 Like

Just updated the docker container to the latest version and now it’s even visible in the app. Renaming with your convention did indeed work just fine. Thanks

what is the easiest and fastest way to manage deconz with raspberry pi4 from homey? docker or raspian?

Both are equally easy if you have the knowledge. I guess if you don’t want to do anything else on the raspian image, i’d say its a lot less hassle with implementing docker and all. If you want to do more with the pi, then I would go for docker.

1 Like

Grazie!!!