Homey Community Forum

[APP] deCONZ

That’s exactly what’s happening. Each Homekit implementation for Homey needs to decide how to represent the Homey device to iOS, and if it sees a contact sensor that has button inputs, it has to become either a contact sensor or a button, because iOS doesn’t allow both types into one device.

1 Like

Right, installed deCONZ on Pi1, added a few more repeaters (had to go to Ikea anyway). Transferred all lights, repeaters and sensors to deCONZ, repaired all flows and now the load from homey has decreased from ~20 back to the original 0.30. Case closed, i’m sticking with deConz.

Homey being unreachable and disconnecting all the time is gone now, so had primarily to do with the load being way to high.

The deconz proces only takes up to 30% cpu load on the Pi1, so that’s fine too. Great solution.

1 Like

Hi,
I’m using deConz-App for several time now (just with the Homey) to speak to my Sonoff ZBR3s. Since three days now the control of the ZBR3s doesn’t work anymore, so I deleted them today and wanted to re-learn them.
Unfortunately this doesn’t work anymore and the app tells me “Go to the app settings page and fill all fields”. But in the app itself I don’t know which IP etc. to enter (especially because - that’s my understanding - that is only needed for the connection to the Conbee, isn’t it?). I only want to learn the ZBR3 again :wink:

So it used to work. All of a sudden it didn’t anymore. The app is misconfigured and you get an informational message saying you have to fill all fields?

What happens if you login into the phoscon app? Do you still see the devices?

You should know the IP of the deCONZ at least… you could try to hit discover again.

Thanks for your answer. I also assume that the app is misconfigured (maybe the function did not exist before the update?) Actually I only had the deCONZ app installed on my Homey and I didn’t use any other app (not even the phoscon app) and I didn’t want to buy a conbee or something similar (since the Homey is used as hub).

deConz app looks so:

Ye but you need phoscon to add devices to deCONZ. And you need a conbee (2) or the gpio headers for the pi in order to have a zigbee network. So either I completely misunderstand you, or there is something very strange going on.

Maybe there is some kind of misunderstanding :slight_smile:
Until now, or at least until three days ago, I could simply add the ZBR3 to my home devices via the deCONZ app and access it with no more other devices.
This is no longer possible - and after deleting the devices - I can’t even add them again - but so far this worked without problems with the same constellation.

Right, so we can safely assume it’s either the config inside the app in homey. Or your deCONZ server / service is completely dead.

What happens if you click the discovery button.

it says “Error: Unable to find a deCONZ gateway”

Just to be absolutely sure: you have either a Conbee (II) or a Raspbee (II) device, right?

I have non of them but as I said, I also haven’t had one bevore and three days ago it worked

That’s simply not possible. You need a Conbee or Raspbee device for deCONZ to work, and you need a working deCONZ setup for the deCONZ Homey app to work.

Trust me, it worked before :slight_smile:

I think you paired the Sonoff device as a generic Zigbee device (Devices > Add > Homey > Zigbee), because all it needs is on/off support which Homey supports out of the box. The deCONZ app requires a working deCONZ setup, and if you don’t have one, the app cannot provide any device support.

hmm, okay. If you tell me so (I guess you know much better how this whole stuff here works) but than I wonder because the device was shown in the deCONZ app?
Nevertheless, I’ll try it your way, let you know if it worked.

@robertklep it worked to pair the Sonoff as a generic Zigbee device…I’m feeling kind of dumb now.
Never mind, thank you a lot for your help!

1 Like

That’s very strange. Are you running the experimental v5 firmware for Homey?