Homey Community Forum

[APP] DoorBird

Hi,
Thanks for a great app!
I had it working for a while, butt suddenly it won’t start any flow.
It has the same IP and it works to use the open door trigger.
I have also tried to uninstall and install the app again.
Anybody had the same problem ?

Hello, I am a new user and bought a homey specifically because of DoorBird compatibility. I have not been able to log into DoorBird inside the Homey app to connect the two and both doorbird and homey support has been of no help. I have gotten many different errors when I try to sign in and have tried with all of my accounts, admin and not, as well as the two versions prompted for. I would attached screenshots now to but add insult to injury this terrible form doesn’t allow me to upload more than one photo per post because I am a “new user.”

The first error seems to be a hiccup within Homey. The second error indicates you are not using proper credentials to log in. Please follow the instructions to the letter and create a user with the correct credentials (including api support).

I have followed the (very simple) instructions. I have repeatedly made new accounts in DoorBird with API rights and I always get this PairSession error.

That’s not an issue with my app. Someone on the developer slack channel suggested it may be solved by logging out and logging back in again on the mobile app. Give it at try and let me know.

Do you mean the Homey app?

Yes

I totally removed the DoorBird sub-App from within the Homey app, then logged out, then deleted the Homey app, downloaded it again, installed the sub-app and logged in, then created a new user account with API permissions as always in the full DoorBird app, went back to Homey and same “Could not find that PairSession” error when I try and login.

Someone else on Slack suggested this:

The pairsession not found is because the Homey app is being put to the background when the pairing has been started, to for example copy details from a page/other app, when you then come back to the Homey app, you’ll end up with that error

I’d also like to know what you see when you directly access your DoorBird directly with this URL (replacing the IP and username/password): http://<<doorbird_ip>>/bha-api/info.cgi?http-user=<<doorbird_user>>&http-password=<<doorbird_password>>

Thank you. I have been able to sign in now after manual entry. This should be written very boldly in the instructions. It is 2019 and everyone copies and pastes machine-generated passwords. I now have to click on doorbird in Homey several times to get it to open up to the video feed, etc. and I’m getting the occasional error message (503) in the opening process as well. Is this normal? Now I have the problem that “trigger default relay” does nothing and makes no sense as I have 5 relays, 3 of which are in use. Where can this “default relay” be defined and I hope more than one can be triggered at once, as my DoorBird triggers all three when entering. I do not see any place to define “default relay(s)” in Homey or Doorbird. My DoorBird model is the D2101KV and I’m using the external relay box with 3 relays (all hooked up). Thanks.

Did you report this to Athom so they can fix it? And feel free to submit a PR on GitHub to improve the documentation.

The 503 error is caused by to many connections. This is what is said about it in the API documentation from the DoorBird.

CONCURRENT CONNECTIONS
The device handles via this third-party API a maximum of 1 concurrent connection
per second for API access. Please keep in mind that the device is a Video Door Station, which handles in general - like all commercially relevant door stations - only one simultaneous audio/video call
for live communication. You get a status code “503” (Busy) if another user already took
the call. In that case you can notify the user with a message dialog on your GUI, e.g.
“Line busy” and additionally preview one still image (LIVE IMAGE REQUEST).

When this app was written there where only DoorBirds with one physical relay which acts as the default one. Since then more advanced models have appeared with more than one relay so there might not be a default one (I dont know since I dont own these devices). But with the current Homey firmware it’s impossible to add a button for all available relays so that might not work as expected for you. Perhaps on firmware 3.0 I might be able to dynamically add these buttons upon pairing. You can stull use the open door trigger card in flows where you can select which relay to trigger though.

Thanks for you help, I am all set for now!

How to test Sip Call in doorbird. and Audio receive,transmit. i have tried to sip call through Post man.it was not worked.even we not got any errors.any software can test this type sip call and audio receive and transmit

I tried to make sip call this url by Postman
http://192.168.0.1/bha-api/sip.cgi?action=makecall&url=sip:192.168.0.11&http-user=ggzxx&http-password=NwJ

i tried to get audio receive this url by Vlc

http://192.168.0.1/bha-api/audio-receive.cgi?http-user=ggzvxx&http-password=NwJ

Those Url not given any errors.How to test this

Push the button on the doorbird?

Hello. The “Doorbird rings” card is non-functional regardless of what the flow is set to do. So I can not make a flow where something happens when the doorbird rings.

Also, “Doorbird opened” is equally non-functional. Very frustrating. I am using the external relay controller if that is of any meaning.

Did you not have this problem before and wasnt it solved already. What changed?

Seems to be the same issue. Check your HTTP calls in the DoorBird app according to the instructions in the app store. Seems you broke something.

This is an entirely new problem. I have not before attempted to make such a card in Homey.