Homey Community Forum

[APP] Easee charger

If you don’t get access to a demo-account to an equlizer I can create an account on mine for you to play around with :slight_smile:

1 Like

Same here :slight_smile:

This should not be the case. If you check the advanced settings on the Easee charger device in Homey and scroll down to debug. There is both a last API error property and a log property - do you see anything interesting here?

There is also a last command response property, ie if you (or Tibber) trigger a command on the charger the response will appear here. If you trigger the same action multiple times, ie set dynamic current to 10A - then a command response is only generated for the first command, the following won’t be accepted since they didn’t change anything.

I have added a new action that will come in the next version where it will be possible to turn on and off smart charging. Thinking this should prevent any race conditions where Tibber wants one thing and your Homey flows something else.

Thanks Richard!
Acutally, I tried it once more and then it worked, for some reason. I have also studied the debug part, I will look into that prior to posting here. Thanks

GREAT, that will be awesome. I have seen Tibber’s sometimes smart charging to some really stupid stuff, so it will be good to disable that during daytime, for instance!

I just released a new test version of the app with support for the Easee Equalizer device.
This version also contains the new action, “turn on and off smart charging”.

Like a glove, will test that.
Anyway that we can see the possibility to change the schedule in the interface as well?

This is an API to override a schedule
/api/chargers/{id}/commands/override_schedule

Allows current session to charge immediately provided that schedule is the only mechanism stopping charge currently

There are also endpoints for what they call basic_charge_plan, to get, update/create and delete a charge plan. I’ll look into what can be done.

Awesome!

Available now in test version 1.1.1; create, delete and override schedule.

I also changed actions for smart charging since previous test version.
There are now three actions; Enable, disable and pause smart charging.

Like a boss, @Richard_B

Hi @Richard_B. I tried to change the allowed current now, and I got the red question mark when flow run. I check API error message that was triggered by the flow:
2021-03-31 22:08:50
Error: POST ‘/api/sites/0/circuits/0/settings’ failed, HTTP status code ‘403’, and message ‘{
type: ‘RFC 7231 - Hypertext Transfer Protocol (HTTP/1.1): Semantics and Content’,
title: ‘Forbidden’,
status: 403,
traceId: ‘|2374e835-496dfeff1904a9e5.’
}’
at /lib/easee.js:476:39
at processTicksAndRejections (internal/process/task_queues.js:97:5)

Any suggestion?

The error is clear I think, shouldn’t contain zeros in the path (unless you omitted the proper id’s on purpose that is?)

/api/sites/0/circuits/0/settings

Some API settings are rate limited, ie number of times you can call the API per minute.

For this API there is also this comment. Do you have more than one charger?

The Circuit current can only be set/read by accessing the master on the Circuit. Setting or reading these values on a Slave is not valid.

Yeah, I realize that something went wrong. But only thing I did was to run a flow, changing the allowed current.

Just for your info, I tested a flow looking like this, but it returns some errors:

2021-04-07 22:43:51
Error: POST ‘/api/chargers/EH663229/commands/override_schedule’ failed, HTTP status code ‘400’, and message ‘’{“errorCode”:410,“errorCodeName”:“ChargerDisconnected”,“type”:null,“title”:“Charger disconnected”,“status”:400,“detail”:"[Empty in production]",“instance”:null,“extensions”:{}}’’
at /lib/easee.js:476:39
at processTicksAndRejections (internal/process/task_queues.js:97:5)