Homey Community Forum

[APP] < group > (2.4.2 - Stable)

German language and the speed improvement have been deployed and are now available to everyone on 2.3.105

It requires that your Homey version be > 2.05


1 Like

i installed the new version today. thank you jamie! the latency is now very very small and not comparable as before. :slight_smile:

1 Like

Thanks Jamie, looks like the update seems to work for the speed issue. Thanks

Apparently there is a bug with in the Homey Core which is causing some app which use the WebAPI (read : this app) to stop working. I’ve been told it will only occur on people who have upgraded from Homey v1.

Apparently the issue has been fixed in the next release of the Homey Core, sorry for any problems this may causes you, it is also affecting me.

1 Like

Aaaah so I’m not the only one… Thanks for keeping is posted!

@Marcel_Visser there is a work around if you dont want to wait :slight_smile:

  1. Open up https://developer.athom.com/tools/api-playground in a private browser.
  2. Login
  3. Replace the text box with the following Homey.sessions; and hit run.
  4. Look for the value next to "id" in the response and copy it.
  5. Replace the request test with Homey.sessions.deleteSession({id:'THE ID YOU COPIED'}); and hit run.
  6. Restart the group app.

it should look something like this `


Looks like the mqtt hub app has the sam. Issue

I dont know if this is the same as the problem you talk about some rows up, but for me, all the groups suddenly stopped working today.
Noticed that my lamps in the windows was dark when arriving home.
Turning them on one by one worked fine, but when tapping on a group, containning a lot of lamps, the status just went on, and the directly off again.
Trying to go into the configuration of groups, just give me:
An unknown error has ocurred [session expired]
Restarting app made behavior different.
Clicking a group will now make the goup to stay “on” in the Homey app, but no lighths goes on. Still dark.
Same error when going in to configre.

So what to do?
The stuff in the developer-mode above, or is this something else.
I have an Early 2019, with 2.x on direcly. Not upgraded from 1 - 2.

Yes, the workaround mentioned by Jamie should do the trick.

Just tested, and can confirm this made the trick.
My groups are working again.
As this was a workaround, would I need to do something when a “real” solutions comes?

There is a fix in the last update 2.1.2-rc3

Hi guys. Thank for useful app. I have this issue. I am grouping my multiple Somfy blinds for each room in separate group. When I add the blinds group in the flow (open/close/set percetage of opening) in most of the rooms some of the grouped blinds do not run (e.g. two out of five or one out of two). I need to put all blinds in the flow separately which makes the flow overloaded and crashing. I prefer to add groups in the cards. Homey really struggles with excesive number of cards in the flow.

Since a couple of days i have a problem with the groups. I have 4 groups wich are used for turning on the lights. The problem is as follow. If i switch the group ‘off’ it turns off all the lights (Works okay) after a couple of seconds the group is showing it is on but actually it is not, the lights are still off.

Sometimes it also showing all groups are on in the Homey app while the lights are off ,As it should be, because there is no action given to turn on the groups. So it looks like the status of the groups is not handled correctly? don’t know if this is a problem within Homey, the app Groups, or Ikea(all lights are Ikea Tradfri).

Does anyone else recognize this issue?

What are the actual devices which are with in the app, showing as?

Within the group app you mean? they’re as far as i know, showing as lights. See screenshots below, if you meant something else please let me know :slight_smile:

Sorry I mean the actual devices themselves with in the Athom Homey App.

You turn off the group, and the lights physically turn off - but do they (ZITHOEK1, ZITHOEK2, ZITHOEK3) show as ‘off’ in Homey?

Hi Jamie, sorry misunderstand it. But yes, the lights itself are showing off within the Homey app.

Please restart the app, then turn on/off al the lights - then send an error log along which which group is showing as off when it should be on, and ill have a look.


Will do, it’s not always occuring though. I have restarted the app, when i notice the issue I will then generate the error log and send it to you. with description of the groups.

Thanks in advance! :slight_smile:


With the help of @Akumu and his testing/logs, I have pushed out a fix which will update the group

  • when devices are made available/unavailable. ie, should ensure that the group is the correct value after Homey restarts.

It also lays the ground work for allowing a delay when updating items in groups and several other fixes : Details below.

I am looking for a couple alpha testers to help me test prior to going to beta.


  • Remove redundant ‘states’ variable,
  • Update initValues to loop through each capability and call same code as state change
  • Add call to update a value when ever the device with in the group change status (go offline or come online)


  • Fixes to DE language
  • SV updates


  • Lay ground work for allowing groups to be delayed
  • New settings structure separating out set/get/about in .homeycompose
  • New settings for setting a device capability value.


  • Update athom-api@2.1.179


  • Attempt to fix issue #40, remove sanity check before updating capabilities.
1 Like