Homey Community Forum

[APP] < group > (2.4.2 - Stable)

Is it somehow possible to group for example Hue dimmer switches or other switches?

I started looking into moving all my lights into Homey instead of having a bridge for my hue lights.
Also looked into getting Yeelights as a cheaper alternative.

I found < group > and thought it would be a perfect way to control my lights.
On/Off - works with both Yeelights and Hue
Dimming - works with both Yeelights and Hue
Color / Light Mode - Doesnt seem to respond at all. Am I doing something wrong? Tried both Hue and Yeelights.

Hey, based on your intro im guessing “Hue Zigbee”?

If you are going to use color/temp you need to also have the light mode, thats generally the mistake people make. But it sounds like you have it under control.

I don’t actually have a Homey at the moment, but if you contact me perhaps next month hopefully the replacement will be here and Ill have a crack at adding some lights via zigbee. (not something I have done before - I use the hub).

Sorry I cant be more helpful right now.

Hi Jamie

Do you know how to group Xiaomi zigbee wireless switches, I have tryed several group types in your app but nothing detect them.

hope you can help, thank you



Hey Thomas, I would love to help you, but unfortunately I don’t have a working homey at the moment that’s setup.

I was sent a homey with the wrong frequency, and have not gotten any response from support. When/If I hear back from them I’ll let you know the eta of me getting a homey to test my app on. Until then perhaps someone else or app can help?

Isn’t it possible to find them with the device ‘Other (Advanced)’ and then use (in my case) the first option if it’s on or off as a capability? I am doing this for some smoke detectors I am not able to add in any other way…


Just started using and for the most part I’m really impressed. I have, though, a question - is it possible to add/remove devices from a group? I can’t seem to find a place to do so and one of the lights in my group is having mesh problems.

Go to More- Settings - and then the group app. There you can also set their behaviour.


@rindler Thanks! That seems to be working :smiley:

It would be great if you will look at it later as I have not been able to find any generic type that worked.



Sendt fra
til Windows 10

I have not been able to find any generic setting that detect the switch under advanced, so any good idea is apreciated.



Sendt fra
til Windows 10

What capabilities/functions do you have when you just use one switch? Is it added through an app or as a general zigbee device?

It is connected Via the xiaomi app and have 6 functions, it works perfect with homey and the original app, but when you have 10 switches we need a group function so you don’t end up with 10 flows

#Aliexpress US $8.78 11%OFF | 2018 Xiaomi Mijia Wireless Switch House Control Center Intelligent Multifunction Smart Home Device work with mi home app


Outlook til Android

Okey, at least my devices which have on/off capabilities at least can be found when added as ‘Other (Advanced)’. Have you tried using the built in flows triggered by Devices - Turn specific devices on/off, and then choose what ‘type’ and ‘zone’?

Ahh yes, good idea, I will try that way and see if I can get the results.

Regards Thomas

Outlook til Android

I have two Fibaro Smoke detectors in a group. During the week, got Smoke alarm from those when Homey restarted. I were told in this discussion that problem is because i have a group. Somehow the group when it initializes, triggers the smoke alarm on. See discussion in here Fibaro by Athom

Could this be fixed somehow?

Yes, group when restarted first goes on then off. This on/off triggers your flow. I had similar situation with contact sensors.

Hi @Jamie I having some issues with setting up group for contact alarm. “ Error: An unknown has occurred [invalid class]. He is my diag number 354f5c61-9647-4086-aef4-7804464f3566 if you can spare a cycle. Thanks

FYI, if I create under other it works fine. Created issue on git. https://github.com/hive/com.groups/issues/54

1 Like

@Jamie Seems the app does not support the upgrade to Homey v5.0.
After upgrade i can no longer group Zigbee devices.
Have posted issue on github.

Aware that this upgrade is experimental, just thought I’d let people know.