Homey Community Forum

[APP] Homewizard (2.0.2 stable, 2.0.8 beta)

Am not sure what kwh meter you refer to. Which section of Energylink do you mean? What does Homewizard app (original one) tell you? Could it be a wrong data get from the Energylink/Homewizard?
Only the Netto value from Energylink can go negative when you generate more than use in home.
But currently clueless which exact meter you refer to.

Sorry for too little info. I have the HWE-SDM230.
I see in the original HW app that the value is also negative. In Insights I see that the current yield has positive values. See my attachment.

Ok it is still beta code as I lack proper API output of these new devices.
Could you please sent me a PM with your API output directly from the SDM230? Thanks Ton!

Hi @Ton_van_Rijnsoever,
The first chart is ‘Huidige opbrengst’, the amount of power you produce. With your solar panels it gives a positive value.

The second chart is ‘Huidig vermogen’, the amount of power you use. This gives a negative value because you are producing power.

In my opinion the charts are right only a different perspective :slight_smile:

It is the same with:
‘Totaal verbruik kWh’ is negative because you produce
‘Totaal t1 teruglevering’ is the positive variant

1 Like

I can cover that with flagging the device as a solarpanel class…
Then yet again not all have it on solarpanels.

{
  "id": "my_driver",
  "class": "solarpanel",
  "capabilities": [ "measure_power" ]
}

Make it an option in the device settings? Or is that not possible?

Nope it must be set at device pairing, hence I need to cater for that during adding it.
Can’t recall there is a function that allows “setClass(solarpanel)”. Capability is not the issue, it is about flagging the behavior (ie. class)

1 Like

And adding two devices?
kWh meter 1 phase (generate / solar)
kWh meter 1 phase (use / car charger)

I probably found a solution for the kwh1

Beta 2.0.6

  • Populating missing meters/metrics (SDM230 & SDM630)
  • Flagging the SDM230/kwh1 as solarpanel if the active_power_w goes negative which means there is a solarpanel unit attached to it.

Installed the beta 2.0.6 but it is crashing. Restarting it won’t help.

Where can I install the 2.0.5 for now?

Will fix the bug and sent update later this evening (having dinner with kids)

1 Like

Bug fix 2.0.8

1 Like

Hi Jeroen,

This is working. Will keep an eye on it the coming days. Thanks for your effort.

1 Like