Homey Community Forum

[App] MCOHome App (v1.4.0)

Got an unusal problem, got some MCO double load light swiches that stopped working when i upgraded to the new firmware ver 7. Some remained visible, other where dimmed with a red warning triangle on the homey device screen, but none woud work.

Some are connected to a live load directly, but also when presed on or off, switch on a Aeotec smart switch for mood lighting or remotely located garden lighting.

Tried to role back to ver 6 but can not do it no matter what i try.

Have removed, reset and reinstalled the devices now and i can activate them through the homey interface, but they will not report back when they are activated physically at the switch. So none of the mood lighting comes on.

Before ver 7 everything was working just right.

Help

Andrew

I would like to report a similar problem. Update to homey ver 7 has caused to lights to stop giving feedback to homey.

When I physically turn on any lights, the physical state is not updated on homey.

Does not look like Ted has been on here since last Oct (2020), is this app still valid and being supported.
I have about 10 of these MCO switches so a significant investment if I need to go and change to another supplier.
Looks like it could be a Ver 7 issue as lukelinsj appears to have a very similar problem.
Andrew

@TedTolboom, can you tell us if the app will continue to be maintained? On GitHub I have also made two requests and have not received any feedback yet.

1 Like

I have a mcohome multi sensor a8-9. I try to add it to Homey, but after it shows the two green v’s it comes with a message er ving iets fout tijdens het toevoegen van het apparaat. Probeer het later opnieuw.
I tried it several times, I have also removed the Z-wave device from Homey and even reset the z-wave network, but it comes every time with same message.

Not sure if this is a fair and accurate statement. If you want 24x7 support, I will not be able to provide it.

The MCO home app is one of the smaller apps, based on multiple contributors; so I don’t have all devices myself to reproduce the issue.

I do expert that Homey v7 introduced a breaking change in Homey’s Z-wave update that is causing this. Can you send me the diagnostics logs of the MCO home app, with meaningful comments?

Morning Ted, don’t think anyone is demanding or even expecting 24/7 support.

It just appeared to a be a long time since your last visit and probably concerned myself and others who like me have a dozen non working MCO devices installed. Suspect you are right, Ver7 has broken something.

I like other appreciate the time and effort it takes to perform a service that I think Homey should be doing. You are acting as a free software developer for them !

Anyway, back to the issue, if you can look at this it would be much appreciated.

Diagnostics created, here’s the code - 2c6b8930-64f9-4a14-b60a-fbcb069a113a

I already checked the report, but I only see the MH7H thermostat reporting into the app:

2021-06-17 07:00:35 [log] [ManagerDrivers] [MH7H] [0] node.CommandClass['COMMAND_CLASS_SENSOR_MULTILEVEL'].on('report') arguments: [Arguments] {
  '0': { value: 5, name: 'SENSOR_MULTILEVEL_REPORT' },
  '1': {
    'Sensor Type (Raw)': ,
    'Sensor Type': 'Relative humidity (version 2)',
    'Level (Raw)': ,
    Level: { Size: 1, Scale: 0, Precision: 0 },
    'Sensor Value (Raw)': ,
    'Sensor Value': ,
    'Sensor Value (Parsed)': 42
  },
  '2': 121
}
2021-06-17 07:00:35 [log] [ManagerDrivers] [MH7H] [0] [dbg] _onReport() -> measure_humidity, SENSOR_MULTILEVEL -> parsed payload: 42

I don’t see any reports from the switch devices, which could indicate a mesh issue, that is not visible in the app’s diagnostics logs.
Can you contact Athom support (support@athom.com) and send them a Homey diagnostics report code ?(please share with me the code as well, so I can push it to Athom development).

Done

I had forgotten about the thermostat as it is summer it is not used for the last 2 months.

Diagnostics Report ID: 1B4BF4

Andrew

What is the Node ID of the device that isn’t reporting updates?

I can only agree with what @Rockhoppers wrote. Nobody expects or demands 24/7 support.
It was just a question, not a request or anything similar.

I have opened my requests on GitHub. The requests are #45 and #46.

If you can look at these issues it would be much appreciated.

85, 88, 89, 140, 146, 149 Why does that help you ?

So I can tell whether Homey received a command and passed it to the app or whether Homey never received an update from those nodes at all.
In your case the devices that aren’t updating are also not sending any updates.
I’d recommend re-pairing them, if that fails please make another diagnostic report.

I already tried re-pairing two of the switches but the same situation persists.
Andrew

Can you share a diagnostic report made after pairing?

That’s the one Ted has.
A

The Homey diagnositcs report (6 character code) @tjallingt is asking for.

Diagnostics Report ID: 1B4BF4

Just for info: tjallingt is software developer @ Athom.

Hi @TedTolboom thank you for looking into this issue. I have also generated a diagnostic report from my end.

Passkey as follow: 55cf6576-1c6d-495a-bc1b-d2a9f1e50466

@tjallingt I also generated a homey diagnostic report for you, ID as follows: 4A1833

My device IDs of all the switches are: 6, 7, 2, 10, 4, 9, 13, 17, 14.

All switches do not reflect the physical on/off states, however, they work well when triggered by homey flows, manual on/off via devices tiles on homey app as well as Google home voice commands.

Thank you!