Homey Community Forum

[App] MCOHome App (v1.4.0)

I only see that the devices are being initialized; no further communication.
Can you try on a specific switch to turn it on and off the switch, turn it on and off through Homey and again on and off through the switch and then send a diagnostics report?


Did as you requested, here’s the report passkey


Thanks, but still no results.
Can share send a Homey diagnostics log as well so that @tjallingt can have a look?

Thanks @TedTolboom

@tjallingt new homey report generated A406A6

Looking forward to good news both :blush:

I have a theory about what might be wrong but to confirm/deny it I need a diagnostic taken after pairing. Would it be possible for you to re-pair the device and then create a diagnostic?

@tjallingt new report generated


However I’m encountering an unknown error at the end of the pairing process.

I’m going to turn off homey and shift it closer to try pairing again. Will generate one more report if successful. Will update if it doesn’t work too

Edit: successfully paired the switch, device id: 26, report id E13A8D

Thank you~

Hi after 7.0 update. The flow that triggered from button don’t work any more.

1 Like

Same here. After updated to homey v7.0.0 this morning, the physical MCO switch cannot turn on the lights anymore

Same here,
No feeback anymore from MCO physical switches since the v7 update.
Homey control over the switches is still working.

It would be so great to have this app back !
My full support and encouragements to the dev of this app. Tell me if I can help.

1 Like

In generell it would be really helpful to give some more information like it’s mentioned in this thread:

Ok sorry for the lack of information.
In my case, here are the versions / device / what I have tried information :

Homey v7.0.0
MCOHome v1.4.0
Device TouchSwitch (4) Z-Wave plus

The 4 switches created in Homey after TouchSwitch association are not activated anymore when I use the physical Touchswitch. There is not feedback anymore since Home v7.0.0 update.
It was 100% stable before this update.

Note that Homey control on the TouchSwitch still works.
Which means Homey can “click” the physical buttons when I use them in Homey.

What I have tried :
Reboot Homey
“Reboot” the switch
Re-associate the switch - Re association works perfectly. But still no feedback.

Sorry for the lack of information too.

Homey Model: Early 2019
Firmware Version: 7.0.0
App version:

MCOHome v1.4.0
Device: MCO Home Touch Panel Switch

All my MCO switches cannot turn on/off the lights. The Homey app can still turn on/off the lights and also light up the MCO button according to my homey flow.

This happened this morning after the upgrade to v7.0.0. Before that, everything worked fine.

I have restarted everything, router, homey, hue bridge, including turning off and on my circuit breaker for all the lights and MCO switches.
I have also powered off the Homey and let it rested for 15 minutes to refresh the memory and cache in it.

Still not working.

Thanks all for providing the additional information.

A brief update, the problem is more complex than expected and appears not to be caused by a change that can be resolved in the app itself.
This problem appears to be similar in origin to the problem as observed with the ROBBsmarrt app (both related to Z-wave plus S2 devices), where the remote / wall controller do not report into Homey, similar to the switches of this app not reporting their state updates to Homey.

Athom development is looking with highest priority into this issue within Homey’s Z-wave core and together with AutomateAsia we are supporting where we can.

I will provide an update as soon as possible.


+1 to @tingsai and @Ludo_Heiligenstein

I have the exact same issue.

Homey v7.0.0 (Early 2018)
MCOHome v1.4.0
Physical Switches: MCO_MH-S312-EU-B and MCO_MH-S314-EU-B


  1. On/Off of the physical switches are not reflected correctly within the Homey App.
  2. This has resulted in the Flow not being able to run (due to Homey not being able to detect that the physical switch has been turned on/off)


  1. Within Homey App, the light is off. When i switch on physically on the MCO Switch panel, the light is still off seen as inside the Homey App
  2. However, if i turn on/off the light using the Homey App, everything is synced properly (e.g. physical light indicator on the MCO switch is turned on + the flow runs)

This was working before the update like what has been described in the earlier post.

I have tried basically everything but nothing works:

  1. Restarting Homey
  2. Restarting MCOHome App
  3. “Restarting” house’s physical circuit breaker to restart the physical switch

Bas from Athom told me a bug is fixed with adding the A8-9 multi-sensor to the Homey and I can expect an update soon. Can somebody tell me when the update will be available?

The issues with the switch state not updating should be resolved in the 1.4.1 version of the MCO Home app. If not, please let me know.


Just tried. It’s solved! Thanks Ted👍

Just tried and physical states are reflected on the app. Thank you for the hard work @TedTolboom @tjallingt

Bravo!!! Thank you for the work.
I confirm it is back to full operation now.

@TedTolboom I have the 1.4.1 version of the app, but still I cannot add a A8-9 multi sensor. It is giving an error message when I try to add the device.
I made a diagnostic report id F8874C.