Homey Community Forum

[App] Micro Web Server

don’t ask for directory, just copy your file to it when connected.

@Chris_Peters unfortunately I cannot even reproduce this at all. However, I can see a similiar issue when using WinSCP (which does not work for the same error). I will investigate further on this but this might take some time.

@Chris_Peters Maybe it is related to passive mode, which is currently not supported. Please check if you are using passive mode for the connection, and if so, disabled it please. Also make sure to use IPv4 for connecting.

Hi Shakesbeard,

I have tried everything possible, but nothing seems to be working. Probably a problem in my network setup since everyon seems happy with it. Thanks for trying to help me out. As an alternative I am putting the web pages which I wanted to serve, directly on an ESP8266 chip which I will use anyway.

Chris

is this app ready for Homey V5 ?

Hi @Joost_van_Kempen,
it should be. It is running SDKv2. However, I am not running on the test channel of homey so I have not done any testing myself yet. But if you encounter any issues on v5 please let me know. I will try to fix any issues asap.

I’m not running experimental either, because my home (and family) depend on Homey. That’s why I made a checklist for all my apps whether they are ready for V5. For most of them there is a list in the German part of the forum with tested apps. For all non-zigbee apps that are running SDKv2 I will take my chances.

Still need an update for 2 apps now before I can upgrade…

I’ll wait for stable release, so can’t help you with testing.

Thanks anyway for fast reply!

1 Like

I am trying to play a small mp3 file on a google home speaker, but i am not able to.

the server is running, i am copying the http://homey-5xxxxxxxx2e7186:5080 line and adds /Santa.mp3

when i run test on the phone app the google speaker makes a pling sound, but when i test on flow site on computer i get " Flow card error: Proimise was rejected with falsy value".

any ideas?

Hi @CB83,

Yes. that’s a know issue with the Athom Chromecast app.
You can use the “Cast Website” card instead for the MP3 URL.

thank you for the reply…
when i upload files from my computer to the server running om homey, should i not place the file in a spesific folder?

like now, i have just logged in, what do i do next when i shall upload a mp3 file?

This solved my problem, thanks! (192.168.2.22 is my Homey’s IP )

.22 you mean rc version?

Nah, he referrs to the last part of the IP address in the shared flow :smiley:

1 Like

I am not quite sure whether I understand the question correctly.
Basically you can organize the files on the Micro WebServer as you like to.

See picture.
I have just logged in to the server, and this is what i see.

No folders or anything.

Normal?

Ah yes. It is completely empty by default. Nothing preinstalled there.
Feel free to organize your files in folders as you please.

Ok, so if i upload a file to lets say folder name " christmas"

How, and where do i find the url i need to use in the flow?

See my flow, the file was placed in the “root”

The filename was “doorbell.mp3”

And with root, what fo you mean then? Without any folders like in my picture?

Perhaps its related to the ip address. I will try that

Yes as in your picture. The iP is as I use it, will be probably different for your Homey