Homey Community Forum

[APP] Netgear Router - Network control, Presence detection, Energy monitoring

I bought a new netgear wnr2000v5 €20 router and it now works.

could have been my old 3500 that was just to old.

1 Like

Wow, 20 euro’s is really a good deal on a new router. Glad it works for you. I will add the WNR2000v5 to the list of routers that have been confirmed to work. Thx!

The new version of the app is now available in the appstore as beta release.

v2.0.8 2018.10.23 Netgear module updated to 3.0.6.
More router types supported.
New xml parser. Condition cards added.
Router compatibility test added.

It supports more router types, has improved handling of corrupt xml messages coming from the router, and has improved address and port discovery during pairing.

Furthermore, if you are having problems to pair or use your router, you can now run an extensive test and upload the result to github. With this information I can try to solve the problem for you in a next app release🤗

1 Like

new flow cards available ^

After beta update again I’m not able to pair my r8000
I tried everything
only password
password and ip
password, ip and port
Nothing worked

I did a test giving:

starting test on Netgear package version 3.0.6
trying to auto discover the router...
{message:No valid SOAP port found on the host address}
{host:,username:admin,password:*****,timeout:10000,sessionId:A7D88AE69687E58D9A00,cookie:[XSRF_TOKEN=1222440606; Path=/],loggedIn:false,configStarted:false,soapVersion:3,loginMethod:1,guestWifiMethod:{},lastResponse:Firmware=V1.0.4.18_10.1.49\r\nRegionTag=R8000_WW\r\nRegion=ww\r\nModel=R8000\r\nInternetConnectionStatus=Up\r\nParentalControlSupported=1\r\nCircleEnabled=0\r\nOpenDNSEnabled=0\r\nSOAPVersion=3.21\r\nLoginMethod=2.0\r\nReadyShareSupportedLevel=29\r\nXCloudSupported=1\r\nSmartNetworkSupported=0\r\nDeviceMode=0\r\n}
getting currentSetting...
trying to login...
{message:Cannot login: host IP and/or SOAP port not set}
{host:,username:admin,password:*****,timeout:10000,sessionId:A7D88AE69687E58D9A00,cookie:[XSRF_TOKEN=1222440606; Path=/],loggedIn:false,configStarted:false,soapVersion:3,loginMethod:1,guestWifiMethod:{},lastResponse:Firmware=V1.0.4.18_10.1.49\r\nRegionTag=R8000_WW\r\nRegion=ww\r\nModel=R8000\r\nInternetConnectionStatus=Up\r\nParentalControlSupported=1\r\nCircleEnabled=0\r\nOpenDNSEnabled=0\r\nSOAPVersion=3.21\r\nLoginMethod=2.0\r\nReadyShareSupportedLevel=29\r\nXCloudSupported=1\r\nSmartNetworkSupported=0\r\nDeviceMode=0\r\n}

Discover router gives a red triangle

Hi @Canedje,

Is your r8000 set to router mode, or to bridge mode? The app only supports router mode! (Although a new stable version is waiting aproval that should work better with netgears in bridge mode)

Is indeed the right ip address of your r8000? If so, can you try running the test by manually entering this ip and using 5000 as soap port?

I did restart my router.
After restart I could connect again

The new version 2.0.9 has been released as stable version. This version supports even more router types, and has an auto discovery function during pairing.

Also check out the new flowcards to check if an ip address is in use, or if a new router firmware is available.

1 Like

I have setup my new Orbi RBK 23 as access point and i guess this is not working?
After adding the router it works for a very short time.
The internet connection is always shown as No
And after about 30 seconds it all goes to 0

If i do the test i do get this result

starting test on Netgear package version 3.0.8
trying to auto discover the router...
trying to login...
login method: 2
trying to getInfo...
{ModelName:RBR20,Description:Netgear Smart Wizard 3.0, specification 1.6 version,SerialNumber:**********,SignalStrength:-4,Firmwareversion:V2.2.1.210,SmartAgentversion:3.0,FirewallVersion:net-wall 2.0,OthersoftwareVersion:N/A,Hardwareversion:N/A,Otherhardwareversion:N/A,FirstUseDate:Sunday, 30 Sep 2007 01:10:03,DeviceName:NetgearWifi,DeviceNameUserSet:false,FirmwareDLmethod:HTTPS,FirmwareLastUpdate:2018_11.5_20:23:16,FirmwareLastChecked:2018_11.9_16:51:49,DeviceMode:1,DeviceModeCapability:0;1}
trying to get supportFeatures...
trying to get attachedDevices...
Number of attached devices: 38, method: 2
trying to get Guest Wifi Status...
2.4G-1 Guest wifi enabled: false
5.0G-1 Guest wifi enabled: false, method: 1
5.0G-2 Guest wifi is not available
trying to get trafficMeter...
trying to check newFirmware...
trying to logout...
test finished o.k. :)

If i look in the setup page of the router is says internet connect: Good

Is this because i am in AP mode on the router?


Hi @Gijsje

Actually, the test shows all is working good. The app is intended for router mode indeed. So the internet status and speed might be not working in AP mode. Did you enable traffic statistics in the netgear?

I do think that most flow cards should work. If you test it, let us know which work and wich don’t.


Thinking about the internet status. I think I can add an option to let Homey get the internet connection status, in stead of the netgear device. This would then give you the connection state, even if you use the netgear in AP mode.

I could add that to a next app release. Would anybody be interested in that?



First of all, very good work! This is awesome! :slight_smile:

I bought a new Netgear router and for some reason, the app will only work partly. The model I have right now is: Nighthawk Pro Gaming XR500. I can add the device and the test says that everything is fine (see below) but the traffic is not updating (always 0), it will not notify me if I deactivate/activate WiFi on my cellphone multiple times (presence). The first time it worked (when i Connected to WiFi) so it seems that the updates wont go into Homey all the time. When I check the log, it is not updating (even if I press Refresh button), any clues? Its running in router mode.

starting test on Netgear package version 3.0.8
trying to auto discover the router…
trying to login…
login method: 2
trying to getInfo…
{ModelName:XR500,Description:Netgear Smart Wizard 3.0, specification 1.6 version,SerialNumber:**********,Firmwareversion:V2.3.2.32,SmartAgentversion:3.0,FirewallVersion:net-wall 2.0,OthersoftwareVersion:N/A,Hardwareversion:XR500,Otherhardwareversion:N/A,FirstUseDate:Sunday, 30 Sep 2007 01:10:03,FirmwareDLmethod:Null,FirmwareLastUpdate:2018_11.23_15:9:33,FirmwareLastChecked:2018_11.23_22:23:34,DeviceName:XR500,DeviceMode:0}
trying to get supportFeatures…
trying to get attachedDevices…
Number of attached devices: 7, method: 2
trying to get Guest Wifi Status…
2.4G-1 Guest wifi enabled: false
5.0G-1 Guest wifi enabled: false, method: 1
5.0G-2 Guest wifi is not available
trying to get trafficMeter…
trying to check newFirmware…
trying to logout…
test finished o.k. :slight_smile:


Did you did enable traffic statistics in the router?

@Gruijter wonderful! :smiley: So simple and effective! Thanks! :smiley:

Any suggestions about the other issue? Example from today:

Came home and it detected that I arrived (which is nice) i.e. turned off the sensors (logic in homey). Then I went to bed and my iPhone is “going to sleep” so it shuts down the WiFi but when I woke up and re-connected to the wifi, it did not recongnize me as “a device came online”, same goes for other products that are “going to sleep”,(even if I restart the iPhone, it will not recognize it as online). If I turn on my computer, then it recognizes it as “a device came online”. Any known issue with products going into some kind of “sleep” mode?

According to the Netgear Router log, it only lists “OFFLINE” for my iPhone, not online.

The presence does not always work very well for iPhone. They have a weird sleeping strategy. Buy an android :wink:

You have your polling interval very short. I would leave it at the default of 1 minute. Also the ‘offline after’ is very short. This will cause erroneous messages ‘offline’. I use 5 minutes (300 seconds) and it works pretty well for my family, including some iPhones.

@Gruijter Okey, I will change my offline presence to 300 :slight_smile: and see how that goes. I used “Smart Presence” before and I had to increase the timing there to get it to work with my iPhone. Guess it will be the same here :slight_smile:

The polling of 20s is because I would like it to react as soon as possible - when arriving home. I would even prefer if it was possible to lower the number. Then it will “welcome me home” + “deactivate my sensors” immediately instead of 20 seconds after it has connected (in worst case).

Thanks for all your help :slight_smile:

V2.1.0 was just uploaded to the app store, and is waiting approval by Athom.

This new version has improved auto discovery, and also adds an option to check the internet connection status in a different way. This is usefull for netgear devices that are running in AP (access point) mode ( especially made for you @Gijsje :wink: )


Thanks, will let you know when it is installed

New version available in the app store now! Get it while it’s hot:



Version v2.2.0 is waiting approval by Athom. It has a fix for knownDevices storage, which causes weird behaviour in flowcards after a reboot of Homey or of the app.

It also has a cool new feature :sunglasses: WakeOnLan


So now you can wake your network devices from a flow (off course only for devices that support WoL)
I even added SecureOnPassword. This is the second field in the flowcard. Leave at 00’s if you don’t have a WoL password.

I don’t have a device that can use a WoL password, so is there anyone who could test that feature for me? :kissing_heart: