Homey Community Forum

[APP] Nuki Direct

Hello @Mark1541,

I try to summarize your support request.

You recently installed Nuki Direct v3.0.6.

Since the first time you installed it, you experienced occasional disconnections of Homey from Nuki Bridge (red exclamation mark for each Nuki device in Homey app for smartphone). The red exclamation mark does not provide any diagnostic information therefore you performed a pairing operation. The pairing operation briefly (< 1 sec) showed a picture of a globe, then it briefly (<1 sec) showed a picture of a Nuki Bridge and, finally, an ECONNREFUSED error message.

Thereafter Nuki Direct remains permanently in this disconnected state. The only way for connecting it again to Nuki Bridge is to restart your router/access point.

Well, my suggestion is to check the configuration of your router/WiFI access point (TP-Link?) which, from time to time, refuses the connection of Homey to Nuki Bridge.

Hope this helps. Anyway, I kindly ask you to send any further messages related to this problem privately. Thank you!

I don’t know but I have to recharge my batteries more often than before, normally every 3 months now every 1,5 month that is an use decrease of battery live.

I understand that now we are at home the whole day it takes more battery live but twice as much ?

Hello @ChrisBoer,

The Nuki apps for Homey (Nuki Direct and Nuki app by Athom) communicate only with the Bridges, so they cannot drain the battery.

Maybe your battery drain is caused by other reason, lower temperature, lack of mechanical lubrication, …

The Nuki app for smartphone reports very detailed information about the battery usage for lock/unlock operations.


There you can check if the consumption for an operation is too high and/or if a proper cleaning//lubrication of the mechanical parts may decrease the load on the SmartLock motor.

1 Like

I have the following problem.

The Nuki state changed card isn’t triggered if Nuki is opened by the Official Nuki Android App.
But it is triggered if it is opened by the Homey Nuki Direct app.

Is this normal? Or can I fix this somehow?

That could be the case LACK of Lubrication … good Idea :wink: Door lock maintenance…

WD40 for the win.

Hello @z3r0,

Sadly, this is “normal”: Nuki Bridge doesn’t always notify provisional state changes when and action is initiated by the Official Nuki Android App. I discovered that sometimes a Nuki Bridge doesn’t even notify the second of two state changes, if the two state changes are too close in time. Example: open (unlatch) the SmartLock from the locked state and push (or pull) the door immediately after the lock is unlatched; the Nuki Bridge may not notify the second event (door sensor contact alarm changed).

If you search on Nuki Developer Forum, you will find that this behavior is “by design” and that “currently, state changes still only trigger after finished lock actions” (quoted text from Nuki technical support).

Thanks for your reply! It’s clear for me then.
It’s a shame. Like you said, I only get a good trigger with a lock and unlock. Hopefully they can do something about this in the future :crossed_fingers:

You can better use the NUKI DIRECT app from the community store this works and don’t have this behavior.

I can’t find anything else then Nuki Direct in the community store. Maby you can send me a link? :grinning:

@z3r0 I mean NUKI DIRECT indeed

The NUKI LOCK does not have an IP only the BRIDGE has an IP address, so find the MAC address of your BRIDGE and make an DHCP reservation on your router or on the machine were your DHCP service is running on.

Problem should be fixed.

Who said that the Nuki Smartlock has an IP address?
The Nuki Bridge has a fixed IP address, just like most devices in the network. Nevertheless, the connection to Homey was interrupted again and again. Some say that such problems often exist in relation with a Fritzbox and I have a Fritzbox.
2 months ago I deleted the Nuki Direct App and installed the Nuki App again. Since then I had no more problems.
Very sad, because the Nuki Direct App is better.

1 Like

i’ve been reading this thread for some time now. I think there must be a relation with how your router handles ( at least the wifi). I have an Asus router and I have had no issues with connectivity fo the nuki direct app.

Btw, is your bridge connected through DHCP or did you set it to a fixed ip or lease ?

Thank you for trying to help me.

I don’t have much knowledge about the function and settings of a router. That’s why I can’t test any settings myself, because I don’t know what effects the changes can have.
But currently I have the following settings:

  • DHCP server enabled
  • Nuki-Bridge has a fixed IP address

did you exclude this ip from the dhcp range ? Otherwise you could have an ip conflict at some point.
Or did you do a MAC address reservation, so that the Nuki bridge get’s the same ip everytime the leasetime expires ?

No, the IP address of the Nuki Bridge is within the range of the DHCP server for IPv4 addresses.
IP address Nuki Bridge: 192.168.178.39
DHCP-Server IPv4-Addresses: 192.168.178.20 - 192.168.178.200

I do not know how to give the Nuki Bridge an IP address outside of the DHCP server IP4v range, nor how to make a MAC reservation, sorry.

You should make a reservation this is why when you have a power outage or a router reboot the possibility the bridge will get a new DHCP IP.

Do you use the DHCP on your Fritzbox then use this
https://nl.avm.de/service/fritzbox/fritzbox-7581/knowledge-base/publication/show/201_Netwerkapparaat-altijd-hetzelfde-IP-adres-laten-toewijzen-door-FRITZ-Box/

if you use the DHCP on your router I need to know the brand of router.

Or maybe I can help you with Anydesk so I can show you what to do

Thank you for the help.

Homey and the Nuki Bridge have a fixed IP address. Both IPs are of course in the DHCP range. I seem to have misunderstood @Rens_Hoekema, sorry.
Also, the 2.4 GHz frequency has a fixed channel.
So I think everything is set as it should be.

The Fritzbox uses 3 repeaters in mesh mode. Some users say that the mesh operation works bad with the Fritzbox. They suggest to give the 2,4 and 5,0 GHz frequencies their own SSID, but then I don’t have the advantage of the mesh function anymore. That is not what I want.

With the Nuki App from Athom I don’t have any disconnections with the mentioned configuration, but with the Nuki Direct App I do. So there must be a problem with the Nuki Direct App too. Maybe only in combination with a Fritzbox.
@Piero_F has already tried a lot to find a bug and supported me as well, many thanks again for that, but without success.
At one point I was annoyed and deleted the Nuki Direct App and installed the Nuki App.