Homey Community Forum

[App][Pro] Elgato StreamDeck Integration

@kinglevel
Well, it is kinda more than just a webhook :smiley:
You could try using your Homey’s cloud address start with https. Might actually work, in theory, but I never tested it that way.

@Shakesbeard Tried it now with my VPN to the homey location. I can ping homey etc, but the plugin wont refresh.

@kinglevel
Over VPN you need to use the IP. Hostnames usually do not translate accross VPNs.

@Shakesbeard Yeah i used the local ip

Where do one find the cloud adress?

@Shakesbeard ok i got the adress, for anyone looking it is:

https://CLOUDID.connect.athom.com/

You can find your CLOUDID under https://developer.athom.com/tools/system

Yeah. it basically is your homey’s hostname + .connect.athom.com
PS: Just tested the API access. It seems to work as expected.

@Shakesbeard ok hmm weird i still get the rotating ROD

@kinglevel
Well it should disappear after a moment. Also mind the refresh issue when it is the first button you add.

@Shakesbeard ok

It is weird tho that the adress and key i input disappear after i “refresh” the button.

@kinglevel okay that is a bit weird. Maybe it is due to the input events the SD configurator uses.
Try entering the hostname and key but before clicking another button just click into the Title/name field. Then select another button and click the button again. Unfortuately I have no better solution for this as of yet. The save data event is only called when the input fields lose the focus.

@Shakesbeard ok tried that as well, same issue. Do you have any debug log for the plugin?

@kinglevel
The plugin has no direct logging. You would need to enabled plugin debugging for your streamdeck app. I’ll PM you the details.

@Shakesbeard hey i got it now, reinstalled the plugin! *in streamdeck

@kinglevel oh. Well, guess something was off with the original installation then.

@Shakesbeard Yeah

It works with my local ip, over vpn, as expected, but having trouble with cloudid adress

@kinglevel
Oh. I am not sure but it might actually not work using the cloud address due to how the plugin assembles the calling URL internally. Sorry about that. I would not advice to use the cloud address. But I will put it onto the todo list for the plugin for now.

@Shakesbeard
Ok
Well thanks for all! Great work!

1 Like

@kinglevel
I added cloud support to the next version of the plugin. It might take a few days until it becomes available. Also updated the app FAQ. I hope this update also improves the onboarding process. I am now trying to display some reasonable error messages within the configuration view, if I can detect an issue.

hi,

Hello,

I come back to you because since the last update, I get this error. I can no longer use the plugin … :sleepy:

There are no more devices in the list. I tried to relaunch the Mac Stream Deck application + relaunch the plugin in homey but it didn’t change anything

Have you encountered this problem?

thank you so much

Hi @DinoRayn,
sorry to hear you are having troubles again. This is the first time I see this error. It works all fine for me. Maybe something went wrong with the latest plugin update on Elgato side. I noticed that sometimes the plugins are not correctly updated from the SD store.
Can you try to just uninstall the plugin from the “more actions” menu and then reinstall it?
Another problem I could think of is that something is hung with the Athom-API on your homey. A homey reboot would help in that case.

Let me know if either was helpful solving the issue.