Homey Community Forum

[App][Pro] Micro Web Server

@Shakesbeard thanks for this awsome app, and support!! :smiley:

@JPe4619 Thanks for the help, it worked :dancer:

2 Likes

@Shakesbeard

So, now that i have managed to get it to work, i am wondering about something.

Could i have lets say a folder named christmas and still use http ip etc? The software will look in every folder i have for the name i put in the http line?

Hope you understand what i mean😅

Hi @CB83,

the logic is simple. The folders are 1:1 refelcted to the HTTP URL.
Let’s say you got a file jingle.mp3 and you put it into a folder named xmas.
So in FileZilla (or whichever ftp client you use) the path is /xmas/jingle.mp3
The URL then is http://###.###.###.###:5080/xmas/jingle.mp3
But keep in mind the casing is important. /Xmas/jingle.mp3 is not the same as /xmas/Jingle.mp3

Thank you for that.
I manually have to pinpoint it as i understand :ok_hand:

1 Like

Before Christmas I’ve uploaded a Christmas doorbell .mp3 via Filezilla, everything worked like described at the top.
Now I want to upload another song, but I cannot connect to Homey anymore. Filezilla give me the following error:

Status: Verbindingspoging mislukt met “EAI_NONAME - Er zijn geen nodenaam en servnaam of ze zijn niet bekend”.
Fout: Kan niet verbinden met server

I’ve tried to restart Homey, to restart the Micro Web Server app, to change ports, but every time the same error. Is there someone who can help me with this?

What hostname are you using to connect to?

As Robert mentioned, double check the hostname. Also make sure you started the FTP server in the apps settings. It is not started automatically.

Hostname: homey-### , directly copied from the app, so no typos.
Schermafbeelding 2021-01-03 om 21.18.11

Hostname is double-double checked, and the FTP server is started in the app…

Try to use Homey’s IP-address instead (if you know it).

Now it will connect, but I can’t see any files, and I’m 100% sure there are files on it (I’ve put them there myself…)

Hi @FabianB,
That’s kinda weird. If you can still reproduce this behaviour I could have a look at your installation to check whether it is not a malfunction of the server app itself.
To do so, reproduce what reported and right afterwards send me a diagnostic report for the app.
You can do this by going into the Homey app menu “More…” -> “Apps” -> “Micro WebServer” -> Hit the litte gear icon and then the button reading generate diagnostics report. Please add your forum name in the message field so I know where it is coming from. The ID you get from this process is not required.

Did you perhaps uninstall and reinstall the app?

Hi @Shakesbeard,

I’ve send you the report, thanks for watching.

Kind regards,

I’ve did yesterday, after trying 10 times or more…but I didn’t helped…

@Shakesbeard is the ultimate authority on this, but I would assume that if you uninstall the app, all files will be removed.

Looks good on app end actually. I can see no issues and it seems to work actually. Look here:
2021-01-03 21:27:49 [log] [MicroWebServerApp] Upload: /userdata/files/Deurbel-ding-dong-single.mp3
2021-01-03 21:28:41 [log] [MicroWebServerApp] Requested: /Deurbel-ding-dong-single.mp3
2021-01-03 21:28:41 [log] [MicroWebServerApp] Resource found: /userdata/files/Deurbel-ding-dong-single.mp3 and is of type audio/mpeg
2021-01-03 21:28:41 [log] [MicroWebServerApp] Requested: /Deurbel-ding-dong-single.mp3
2021-01-03 21:28:41 [log] [MicroWebServerApp] Resource found: /userdata/files/Deurbel-ding-dong-single.mp3 and is of type audio/mpeg
2021-01-03 21:28:41 [log] [MicroWebServerApp] Requested: /Deurbel-Kerst2020.mp3
2021-01-03 21:28:41 [log] [MicroWebServerApp] Not Found: /userdata/files/Deurbel-Kerst2020.mp3

@FabianB

Do you use “Cast Website”?

@Shakesbeard
Yeah, I’ve uploaded the Deurbel-ding-dong-single.mp3 via the IP address as hostname, and before Christmas I’ve uploaded the Deurbel-Kerst2020.mp3 via the HomeyID as hostname…
Both work, very strange.
I will upload in the future via my IP address instead of my HomeyID, because that works fine.
Thank you very much for your help!

@JPe4619, Yes, in my flows I use the ‘cast webpage’ function, that works perfectly!

2 Likes

@CB83 Got the exact same error using the “cast a video Url” card": “Promise was rejected with falsy value”. Casting with the webpage card works.

1 Like