Homey Community Forum

[APP][Pro] Somfy Tahoma & Connexoon (v2.1.71, test v2.1.77)

Unfortunately not :frowning:
That’s why I also post on netatmo app post

Hello,
my homey being broken, I acquired a homey bridge.
The connexoon app does not appear to be compatible. do you plan to adapt it soon?
thanks in advance

The app could be adapted with a bit of rework (convert to SDK3) but unless Somfy come on board with Athom to publish it themselves then Athom won’t allow it.
I thought that by becoming a verified developer I would be able to publish my apps to the cloud but that is not the case.
I know Athom have reached out to Somfy but I don’t know how that has progressed. As this is my most popular app and is a perfect fit for the cloud, I would think it is a high priority for Athom but I’m not sure that Somfy feel the same.

Hello, does anybody experience authentification error when using the app in Homey. My credentials are rejected by the app but my Conexoon box app works fine with those.

I haven’t had any issues myself but I have had two logs sent with authentication errors (one on the 15th and one on the 17th).
As I don’t see any personal details in the logs I can’t comment of the correctness of them and all I see is the error 401 return code that means the request is unauthorised. When the log is not enabled, it only captures errors so I can’t even see the order of various attempts in those logs.

Somfy do occasionally have issues with synchronisation between their servers which means the security tokens obtained from one aren’t valid on another so the account gets temporarily locked out. The app should back off for 15 minutes to allow them to recover.
I don’t see the back off happening in those logs so I can only assume that the errors are during the initial connect attempt after the details have been entered as that overrides the back off.

How long ago did you create the Somfy account?

Hello Adrian, thank you for the quick reply and most of all thank you for the app !
I created my Conexoon account (it’s a cozytech conexxon bridge for an Atlantic heat pump, btw) one year ago.
I installed the homey app last month and I saw it work properly. But I did not implement yet my Homey flows. Therefore I did not see when exactly it stopped working.

For the three server options, I get the following code :
“Error : Request failed with status code 400”.

I run the v2.1.77 version of the app on Homey Pro (2019) v 7.1.3

Just in case it might explain the situation : I had a power outage for a couple of hours, one week ago.

Needless to say, I rebooted the app in homey, no change. And I un/re installed it but as well no change.

Checking the Information log, I also have the odd error code 401. I sent my log via the app.

Could try the following:

  1. Tick the Enable Log option (it turns blue when active),image
  2. Clear the log,
  3. Disabling the app for about 30 minutes. If the account has become temporarily locked then every login attempt will fail and reset the lockout timer. The app should automatically back off but I can’t see it doing that.
  4. Allow it a bit of time to log the login attempts and then send the log.

By ticking the Enable log the app will log more detailed information.

Hello I did as instructed, wait for more than 30 minutes for the reset to happen.
Upon reactivation of the homey app, insertion of login … and still same error 400 for the three servers.
I sent the log at 2PM32 GMT.
Thanks again for your time.

Could you change your Somfy password and then try again. I’m just wondering if something is out of sync.

Hello,
Thanks Adrian for your response.
I will therefore put the question to Athom; it is essential to be able to control the shutters by the flows; if the answer is no or not clear, I will have to return the Bridge; to move on ... but what? It seems that only the Tahoma can control the io protocol.
I used your app on my Homey, it broke down it worked wonderfully!
thanks again

Athom are working on Somfy so I guess they won’t be able to give you an answer yet but I feel there will be a positive outcome one way or another so fingers crossed.