Homey Community Forum

[APP][Pro] Support for ONVIF compatible cameras (1.1.32 & test 2.0.0)

:grin::grin::grin::grin::grin::grin::grin::grin::grin::grin:

That would be awesome…

The Homey Hikvision App is buggy and doesn’t really work anymore… This is my last hope.

The update is available in the /test channel. Let me know if it works for you.

I gave it a few goes. I managed to get it to work briefly a few times but then for some reason it stops working.

For some reason the manual snapshot also seems to not load occasionally when I try to refresh it, , I’ve also tried doing the repair option that also seems to randomly time out.

I’m not quite sure but I have a feeling the ONVIF app is losing network connection with the camera . It’s almost as if they are losing communication somehow … ?.

Strange. I current have 6 cameras, all different brands, and they don’t miss a beat. My HikVision camera probably gets the most triggers as it is looking down the side of my property that runs alongside a public footpath.
image

It’s got me …

All of my network seems to be ok , though my Homey gets fairly horrible latency figures when ever I ping it. I think the Wifi chip they use might be crap.

When I first add the camera in the OnVif App everything seems to work fine. It responds to manual snap shots quick. It responds quickly to line cross motion events. After a while though the motion events don’t respond as quick and start to get a bit patchy. After a period of time eventually all motion events stop responding.

Doing a repair doesn’t seem to fix it. After awhile the repair feature actually stops working and it starts to time out and snap shots also stop working. It’s as if the app loses communication with the camera.

If i delete the camera from the OnVif app and re-register it again it works perfectly for awhile , but then eventually degrades again.

If I log into the camera Via the Hikvision app , the camera seems to be fine. The camera has good access to bandwidth on my network, it streams video quick with no lag and also has good latency figures when ever I ping it.

My camera is one of the newer HikVision Generation 2 series turret camera’s. Would that be a possible cause do you think ? Maybe the newer cameras have a different Onvif setup ?

Russ




This is the ONVIF version that the camera is using …

I can’t see any changes in there that would affect the app.

I did some further fooling around tonight.

Some more observations.

One thing that seems to always occur is whenever I set the settings to Analytic Service, save and exit , none of the new abilities show up in live Alarm monitor screen. I have to restart the ONVIF app for the new abilities to show up…

One thing I tried tonight (as an experiment) was set it up as a new device , set to Analytic Service , save and exit , but then reboot Homey rather than restart the App…

The new abilities show , but I can’t set the motion detection button to be on or off… It’s just blank. If I click on it I get an error.

Not sure if this is of any help or gives any further insight …


I am making a major update to the app to convert it to SDK3. If testing goes OK I will publish a test version soon.

:grin::grin::grin:

Just thought I’d share some new developments…

As of today it’s mysteriously been working perfectly. :flushed:

Up until now I was lucky to get it to work for 10 minutes…

Now here is where it gets interesting. :crazy_face:

I don’t know if you recall I mentioned in one of my previous posts that I was getting crap latency results when pinging my Homey Pro (the older 2016 , 512mb version) …,

(I call it a Pro as Athom now say that is what “all” the white spheres are now called) :roll_eyes:.

I have a late model Ausus Wifi 6 base router controlling my network. Last night I was experimenting around to see why my Pro is getting such horrendous latency… I’ve also been getting bad latency issues with a spare 2018 model Homey that I also have… (bought it secondhand for $200AUD)

Last night just for the hell of it I thought I’d setup a seperate SSID on my router to my main Wifi SSID . I set it to 2.4Ghz only. I assigned my Homey Pro to that new SSID… I was still getting crap pings. I thought , ohh well , and then went to bed. .

I got up this morning to discover my Hikvision camera now works perfectly with the ONVIF App…???

It works every time I walk past it and responds quick… ???

Changing the Wifi setup for my Homey Pro appears to have fixed the issue (I think) …

The big question is how in the hell could my Wifi connection affect the OnVif App… ???

I’ve also been having issues with my MQTT broker App over the last few months. I essentially had to ditch it and setup a seperate Mosquito server on a raspberry PI as I was getting major lag and response issues., I’m now going to now re-test that again tomorrow with this new Wifi connection to see if that is also related…

I’ve heard rumours that the Wifi chip in the Homey Pro’s is pretty crap and a bit flakey… Could it possibly cause all of thisbto happen when used in conjunction with a Wifi 6 router… None of these things ever happened with my previous Wifi 5 router …

It’s a weird one…

I have heard that Homey can have issue with a dual band SSID. I have always separated mine as I have a few other devices that just don’t work in dual mode.
If Homeys network is flaky then it’s possible that the app was getting a lot of connection timeouts and again I have heard that can cause memory issues with the network stack.
I have nearly finished with the SDK3 rewrite so I will hopefully publish a new test version today.

Thanks.

This sounds like a fairly major flaw with the Pro’s…

You gotta love Athom …

They create a product that solely relies on Wifi. They put crap Wifi into it. They refuse to put in Ethernet…

What ever drugs they are on I want some…:crazy_face:

I look forward to trying the new SDK.

I have published a new test version that has been updated to Homey’s SDK3.
Also added a few more capabilities whilst going through it.

2 Likes

Hi,
Is it possible to adapt this app for the bridge as well?
/Niklas

Unfortunately this app will never be a candidate for the bridge as it doesn’t support local network access and ONVIF is only local.

Bonjour,

pourriez vous me dire si il est possible d’integregrer le fibaro intercom dans votre application sous homey?

j’ai un message d’erreur lorsque j’ajoute la camera manuellement

cordialement

Welcome to the forum,

If you could please keep the conversation in English as much as possible, then more people will be able to participate and help you. If you would rather not or can’t communicate in English then please check out Non-English boards/categories:
https://community.athom.com/c/non-english

Please translate your post.