Homey Community Forum

[APP][Pro] SwitchBot (version 0.3.16 live, 0.3.20 test)

What method are you connected with (Bluetooth or bridge)?

I haven’t seen anything for the password mode but will look into it.

I have published a new test version that has support for BLE bots with a password.

Ensure the password has not been set in the SwitchBot app when you want to add the Bot as it will not send the advertainment data required to be detected.
Once the Bot is added to Homey you can set the password in the SwitchBot app and then set the same password in the Advanced Settings of the device in the Homey app.

Note: At the movement, once a password has been set, Homey will not get status updates, as the Bot does not publish that information when it is protected. I have asked SwitchBot if it is possible in some way to obtain the status and I am awaiting a reply.

I had some good news today that SwitchBot will provide more help for me to develop this app.

For the last couple of weeks I wasn’t sure if they were going to take over the app but I have received an email from the Co-founder, BD and Marketing Director of SwitchBot offering assistance for me to continue and has put me in touch with other contacts at SwitchBot.

Hopefully this will ensure I can keep the app up-to-date with new products and features as they come out.

7 Likes

Would be a very nice addon if you could select TV channels from a TV remote through the Hub mini. Currently you can go up/down one channel, but my tv standard goes to the last channel when turned off.

So if I want my TV to turn on and go to channel x at time y i cannot create that flow unfortunately.

Any chance of something like that? Or is the API too limited?

I have added a flow action card to version 0.3.11 that can set a specific channel.
During testing I did find it would occasionally miss a number (e.g. 2 instead of 12) but that could be because my hub is not in direct line of sight with my TV.

1 Like

You could also create a scene for some often used TV channels in your switchbot phone app and the use/trigger these in (the) Homey (app).

Or even create a screne in the switchbot phone app for each number and so let homey trigger a scene for each numer.

Every (learned) (ir) button can be made available by creating a scene in the switchbot phone app.

Great! Will give it a try and test it. Thanks for your really quick update :+1:

It’s almost working, it’s exactly like you said, sometimes it doesn’t get all the numbers, and mine is right next to the TV. When I use the switchbot app it does work all the time (so far), so could it be that there a delay is too long or too short, so that it doesn’t get all numbers?

Also I noticed that if the TV is on and i run the Turn on card in a flow the TV turns off (I understand why, it’s a toggle on/off and i can make a check TV on with Better Logic or through a powerplug), just wondering why there are 2 flowcards, or does it work different on other devices (or TV’s)?

And ofcourse thanks for the very very quick add of this feature! :+1:

Been testing a bit more and so far any 1 number channel always works, 99,9% of 2 number channels work, but 3 nummber channels almost always end up with just 2 numbers on the TV, might give you some insights in what might be causing it

I will have to contact Switchbot about this.
The API just takes a text version of the required channel number, e.g. “123”. So it’s down to the Hub to send each digit. If I split the digits into separate commands then it does select channel 1, then channel 2 and then channel 3.

Edit: I have reported it to my new contact at SwitchBot so we shall see what happens. In theory they now have a Homey so they should be able to test it for themselves.

Superb, thanks for your effort :+1: For now it’s functional for me, mostly use it for 1 or 2 digit channels, so i’m happy with your update. Thanks!

Oh sorry, haven’t seen your reply. It does work again. Dunno why. I use switchbot without switchbot hub.

Thank you for helping and adding PW support!

1 Like

Hi!

I have some issues with the motor. I want update this motor. How can I do this? It’s now on version 2.6.

Thanks!

You will have to contact Switchbot and update the firmware through the Switchbot app.

1 Like

Hi,

Since a 2 days I keep getting a ‘Timed out 3000ms’ message when operating the curtains. The flows also no longer work.

I’ve rebooted both homey and the Switchbot hub. I also updated the token to try if that works. Controlling the curtains directly in the switchbot app does work.

Firmware is up to date v1.3. Anyone have an idea? Only thing I haven’t tried is resetting every bot in Homey because then I also have to adjust all flows.

Thanks.

Have you added the curtains to Homey via BLE or the hub?
I have just tested mine using both and they are working OK so I’m not sure why yours have stopped.
Could you open the More > Apps > SwitchBot > Configure App > Log and then select Basic Information from the drop list. Then try to operate the curtains from Homey and wait for the error message. Finally go back to the Log and tap on Send Log.
That will send the information to me so I can maybe see what is going wrong.

What firmware is this referring too?
My curtains are on version V2.9 and my hub is on V3.6-2.3.

Switchbot Homey App v0.3.11
Bridge: v2.2-1.8 (The bridge with leds in the shape of a cloud)
Courtain: :v2.9

all is working :man_shrugging:

1 Like

Thanks for you quick respons.

I use added the curtains trough the hub.

2 of my curtains are on version v3.1,
2 other curtains on version 2.7
and my hub on 1.7-1.9. Maybe there is the problem…?

Try to send the log but I also then get an error… Copied the error message below:

10:25:40.137: * ------------------------------------ Polling BLE Finished

10:25:40.139: * Next BLE polling interval = 30000
10:25:53.751: * {
“$__type”: “Error”,
“data”: {
“message”: “getaddrinfo EAI_AGAIN api.switch-bot.com”,
“code”: “EAI_AGAIN”,
“stack”: “Error: getaddrinfo EAI_AGAIN api.switch-bot.com\n at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:64:26)”
}
}

I received the log OK so that did work.
The error in the log is EAI_AGAIN which is a DNS error. It basically means that Homey couldn’t convert the api.switch-bot.com to an IP address.
Have you tried rebooting you internet router?

Ah ok, sorry if you received the log 3 times then. Tried it 3 times :wink:.

I will reset the internet connection later today and let you know.

Thanks

1 Like

Rebooting the internet router worked. Thanks for your help. Wil try this next time first :+1:

1 Like