Homey Community Forum

[APP] Samsung SmartTV

OK, thanks.

Can you check that you have “Secure connection” checked (Yes) in “Advanced settings” for the Samsung SmartTV app ?

It might take up to 5 minutes before the list of apps is available in the flow editor.

It works!. Thank you so much

1 Like

I can only switch off my Samsung 2018 Q9 tv.
When I switch off and wait a few seconds and want to power on the tv again it’s not working.
Secure connection is checked(Yes)


Yes, there’s a control that checks that the TV is actually on / off when you switch on / off…

So when the TV is in powering on / off mode… you have to wait around 20-30 seconds before switching on again.

1 Like

I’ve got an QE65Q7FAM, how can I find if it supports Wake-On-Lan? I cannot seem to find it anywhere or to turn it on. The power on function doesn’t seem to work.

Could it have to do something with network settings?

Oh, btw, tnx for this app!

edit: Nevermind, does work.

Good to hear !


I have some problemes with turn on and off my samsung Q7 series TV. Sometimes it works and sometimes it won’t. Sometimes i get the message when i test the flow that te tv is already turned on even if it is still off or homey tells me that the tv is off even if it is still on.

To check if homy knows the correct state of the TV i have made 2 flows, the first give me een push message if the tv is turned on and te second send me an push message if the tv is turned of.

The strange thing is that i get push messages all te time, it lookt like if the tv goes on and off every cople of minutes even if nothing happends on the tv itself.


Checking that the TV is really on / off is not so easy… The app checks the response from a HTTP - request, and after the TV is switched off, the network interface of the TV is online for a while. On my TV it is online for about 20 seconds before if shuts down.

And some times the network interface switches on… even if the TV is off…

So the app behaves strangely sometimes… You can try to adjust the “Polling interval for TV status” in advanced settings. Change from 10 seconds, to 60 or even 120 seconds and see if that is better. And I recommend not switching the TV off and then on again too fast.

I use a Fibaro smart plug with meter myself. Mainly because I want to switch off the power for the TV for a minute every day to avoid trouble with ARC that stops working… And I can also check if the power is more than 10 Watts … Then the TV is really on. But that’s a workaround :slight_smile:

1 Like

Thanx voor your reply

I have re started the app and now it look like it work as it shoot be. Maybe i tried too hard en tried the flow to many times…

Bit off topic, but i’m using a smart plug for the same thing. Also sometimes the liveTV feed looks like its on 15hz, after a power cycle it’s normal again. PowerCycling every night seems so solve both issues.

The last days i heave don some things withthe settings of my TV (Samsung Qled Q7 series) and the solution was not a restart of the app but turn off Anynet+ whas the conclusion. I had multiple problems with the combination of my chromecast (which is put in to my receiver) and the TV… When i stream spotify to the chromecast it turn’s on the tv and when i turn the TV of by myself it also stop spotify… When i turn of Anynet everything works correct and te connection between Homey and my TV works great if i turned of Anynet. So i think te problem is the CEC functionality of the TV that gifs some problems and the problem has noting to do with the App of on the Homey

For now i am happy that the tv turns on and off correctly when homey whants to turn on and off te TV

The only problem is now that ik can not use dolby digital+ because thats only possible whit HDMI in combination withARC (that’s part of the Anynet+ setting) The optical connection between the TV and receiver only makes normal dolby digital signal possible… But thats not a problem of the homey app but a Samsung problem :wink:

1 Like

I have an UE58J5200AW (2015) but I can’t seem to add it to the Homey.
When I try the webpage it says I can’t connect to the server. I also gave the TV a static IP address and added it manually but it doesn’t work.
Thanks in advance

Hi Keecha,

Leave the TV on, and find the IP address, and the try to access this link, but with your IP-address from a browser:


With the last slash…

See if you get a response… If you don’t, then there must be some issue with your WIFI / network…


I am using your app with a Q7F. Can switch on and off without any problem but am not able to switch directly to HDMI 1 where my ziggo box is located. It even seems that i can not select any of the HDMI channels direclty. When I use HDMI it toggles between HDMI2 and 4 but not 1.

Sorry, but I don’t think this due to the app …

On my TV the HDMI1…4 does not work either, but HDMI toggles between all inputs.

Have you tried Ziggo on HDMI 2 ?

When ziggo box is on, it toggles also to HDMI1.

If i use the ir version of the samsung app, I am able to directly go to HDMI1. So strange that is not possible with your version. I guess it is a matter of finding the correct code.


I already posted before, having issues with connecting to my UE46F8000SL Samsung Smart TV.

Now you have added the encrypted connection, that finally connects! However, the power-on and power-off doesn’t work. Changing volume and channels works perfectly.

Any idea?

Hi @Paul_Kessels

Power on does only work if the TV supports wake-on-lan / -wireless-lan.

But power off should work. Can you try to send POWER_OFF - key ?

For powering on it should be possible to cast a webpage using a Chromecast that is powered from an adapter (not an USB port), but that’s a work-around.

thanks for the quick reply. Power Off doesn’t work. The button turns black for 20 seconds and then turns back white without error message.

In case it might help, response from http://192.168.X.XX:8001/api/v2/
Cannot GET /api/v2/

And this is the response from http://192.168.X.XX:8001/ms/1.0/
“Model”: “14_GOLFP_SEK_F”,
“NetworkType”: “wired”,
“IP”: “”,
“FirmwareVersion”: “T-FXPGDEUC-1030.0”,
“CountryCode”: “NL”,
“DeviceName”: “[TV]Samsung LED46”,
“DeviceID”: “SHCM4M3HMJIPA”,
“ModelDescription”: “Samsung TV RCR”,
“ModelName”: “UE46F8000”,
“UDN”: “1017df80-000e-1000-b1b5-90f1aa753061”,
“Resolution”: “1920x1080”,
“ServiceURI”: “”,
“DialURI”: “”,
“Capabilities”: [
“name”: “samsung:multiscreen:1”,
“port”: “8001”,
“location”: “/ms/1.0/”

The encrypted-version is for H, HU, J, JU and JS models.

And your F-model should use the legacy version, I think. Have you tried that ?