Homey Community Forum

[APP] Shelly

Ps what is Coap which is mentioned in the Shelly App?

Yes it has :slight_smile:
Goto: Internet&Security - Restrict Login
Enable it and fill in an username and a password.

Thx Marco,

Will have a look!

There is none setting within the Homey Shelly App to operate the screen?
That what I would expect :wink: instead of creating your own flows!?

And have no clue to setup a flow for an up/down action per screen / multiple screens…

I’m having trouble adding a Shelly 2.5 relay with the latest firmware.

When I add the device, select 2.5, then see a list of 2.5’s in my network, also containing the Shelly I want to add. I select it, the login-popup appears, and when I enter the correct credentials the popup closes. But there is no device added in Homey! I do see the CoIoT-address was changed of the Shelly, so there was some form of communication.

Diagnostics: 7491b1ae-e827-4721-b3d1-eb16a0fddbf8
The Shelly app is also up-to-date (stable). The 2.5 is setup just as my other Shelly’s, but the others were added a longer time ago (with older firmware).

Thank you for your help, and please let me know if you need further information, or if I can help you with anything.

Can someone show me the interface in homey of a Shelly 2.5 with roller shutters please.



Thank you.

Could someone with a Shelly 2.5 rollershutter try and use the position slider from the device screen and tell me if this works. I had two reports of this resulting in a 400 error but have not been able to identify the cause of this issue. I need to know if this happens on all Shelly 2.5 rollershutters.

Yes it works without any problem here.

Homey 6.1.0
Shelly App: 3.0.42
Shelly 2.5 Roller with 1.10.4 Device ID: C4C98C

1 Like

@Phuturist I see with some devices that there is an AND flowcard with ‘a firmware update is available’, but I don’t see such a flowcard with my Shelly 1L’s. Is it possible to add it to that device?

Will do. Seems I missed the Shelly 1L.

Thanks for the fast respond! Look forward to the next release then. Donated you a beer!

1 Like

v3.0.44 - 2021-05-10

  • Workaround for firmware issue with auto discovery of Shelly motion sensor
  • Add firmware check condition card and firmware update card for Shelly 1L
  • Remove temperature and humidity capbility for Shelly 1/1PM/1L if no external sensors are present
  • Fix issue with switching between color and temperature mode for Shelly RGBW2 Color
1 Like

Hello @Phuturist,

thanks for the update, good news: remove temperature and humidity capbility for Shelly 1/1PM/1L if no external sensors.

It’s possible to show the temperature as “measure_temperature” ans not as “measure_temperature.1” if no external sensor ist connected? It would solve the problem with vThermo.

Thanks a lot.

Philipp

Nope, some devices already use measure_temperature for the internal device temperature. There is a generic capability parser behind it.

With regard to your question about Shelly 2.5: I have the 404-error when I use the slider button to 0 (bottom button) on Shelly dimmers, but not on Shelly 2.5 rollershutters. They work flawless with the slider controls.

At first I thought it might be on dimmers with a minimum brightness set, but this one has no minimum set. I get this error when I use the button to dim to zero. Seem to have it on all dimmers. Haven’t reported it before because I never use this button anyway (I use wall switches, not homey app)
image

Also, since today I’m getting the above error on a Shelly RGWB2. Already rebooted RGWB2 and Homey, but still this error on everything I do (even switching on/off through Homey devices dashboard). So I can’t control it atm. With Shelly UI I don’t seem to have any problems. IP is set correctly (192.168.1.216)
Another RGWB2 I have works perfectly. Both are on v1.10.4

Thanx for the info. Could you confirm the slider error is actually a 400 error instead of a 404 error like you mention it in the post above. And can you confirm you only get the error when changing the dimmer to 0, other values do not result in this error for your dimmer?

About the 404 error on your RGBW2. A 404 error indicates an incorrect username and password.

The error 400 on the dimmers is only when dimming to 0, both using the slider or the “dimtozero” button

On the RGBW2, I know it worked two days ago; I have some flows that change color, I used them on monday, no problems. Doesn’t work atm, but as far as I can remember I did not change anything with regard to this RGWB2
What username and password? I’m not using any username/password with regard to the Shelly’s. I checked and there’s no restricted logon set on this one (or any other Shelly, just checked)
It’s on static IP assigned by my Ubiquity network.

edit: I just changed to to another static IP, and this new IP is picked up by Homey/Shellyapp - so its connected - , but I still get the 404 error…

Do I need to re-add my Shelly 1L devices for the firmware check flow to show? Because right now I don’t see them anywhere.

I’ll solve that in a next release.

Restart the app, wait one minute, trigger the flow that generates the 404 error and send me a diagnostics report afterwards. Not sure if that tells me anything though.

Dont think so, should be available under the device condition and action flowcards.