Homey Community Forum

[APP] Shelly

I have not changed anything in that area so I doubt it’s in issue in my app. Send me a diagnostic report and the output from http://shellyip/status, perhaps there is something in there.

Thanks for the quick response. I tried rebooting the wifi network, homey and the Uni. At first instance nothing fixed the problem. Everything was read out (temp sensors and contact status) but ADC value seemed to be stuck @0,86V while the real value was much different. The adc value was read out 11h ago while the rest was readout almost live. The next day the problem somehow fixed itself. Strange…

Hi,

Best way in my opinion is to toggle the hue lights with the “status from input” flow cards.
So for example; when Input has changed, then “switch on or off”
The other one is not working for me.
I have a few Shelly’s set up as a detached switch to control some hue Lights connected to Homey and this work fine :slight_smile: .

Not really related to this app, but it is relato shelly:
I reported connection issues about a week ago. Since then I tried some different setups. One thing that worked for a couple of day for me was giving the Shelly’s a fixed IP using the Shelly’s webGUI instead of using DHCP. Since then, no connection issues anymore for me! Only downside is that in the Shelly app, the devices often show as offline, but since I barely use that app, it’s not a problem for me.

Just wanted to share this since maybe it can help others who experience Shelly connection issues.

Thanks Ronald, that did the trick :grinning:
I couldn’t see the input status cards so I had to re-add the Shellys one by one.
Then I modified my flows and it’s working like a charm.
I noticed that with the “action event” at every press of the button the “state of the input” it’s cycling through Yes and No. The Hue lights seem to respond only on Yes hence the double press to have it work. I am not sure if because of that the Short and Long Push are still working. Anyway I was not using them to much as was quite tricky to differentiate between them.
Thanks again, this was driving me crazy, and thanks to you everything is back to normal :grin:

Glad to help :+1:t2:

My shelly 1pm keeps losing track of the total amount of used kwhs in case of a power outtage. It then starts at 0 again every time while the correct total amount of kwhs is visible in the shelly app. Can this be fixed? If shelly can show it it will probably be available using the api

My app just reads out the value from the API. It gets reset after each reboot. The value shown in the Shelly app might be data saved in the cloud which I have no access to. Can’t do anything about that.

You could keep track of the value yourself in a variable or virtual device though.

Hi, after a short power loss, homey can’t read the status of my Shelly i3, both of them. I have power cicled all device, homey and the WiFi router. What to do?

Do they have a static IP address assigned? If not, check if they changed and update the settings accordingly.

Yes they have a static ip address. i can access to web server on the i3, Homey can recognize the device, but the flow based on event don’t work

Ok, I’ve solved. I had to reset the Shelly to factory default and then reconnect to my wireless network (the static ip is preserver by the router rules) and it worked again

Not related to Homey, but to Shelly.

Is it possible to use Shelly 1L as a standalone unit? One would connect to 1L WLAN hotspot with mobilephone and control the 1L.

Other question is that how long range does the 1L WLAN hotspot have?

In an earlier version of the app I’ve used the Shelly Action (before the breaking change some versions ago). However my Shelly 2.5 in roller shutter mode isn’t available in the drop down menu for “Select your Shelly …” within the Action event. The Action Event I’ve used was “roller_stop”. But I can’t use it anymore as the drop down doesn’t mention any Shelly 2.5 in roller shutter mode, only my Shelly 2.5 in relay mode. @Phuturist is this normal or shall I open a bugticket on Github?

It’s normal. The roller state has been removed from the action events as you can use the capability trigger cards for this. No need to use an action event.

I guess that you are referring to the options directly available on the device itself. I’ve checked that, but nothing correlates directly to “roller_stop”. Or do I have to use one of the “Input X …” options? Eg. “Input 1 turned off”? I’ll try that tomorrow.

Screenshot (one option is missing far below)

It’s the top one. The state has changed.

Ok, thank you :slight_smile:

Could it be possible the motion sensor doesn’t work the same as other motion sensors? For example, I have a normal (at least, its what I do) light scene.

If motion detected, then start timer and turn on.
If timer finishes then turn off.

In normal situations this ensures the timer restarts on every motion. Thus the lights won’t ever turn off if there is constant motion.

Now the shelly motion sensor has a pretty long blind time (minimal is 1 min). I have my timer set up to 10 minutes. So theoretically I’d say, if there is motion within those last 9 minutes, the timer resets.

Now I think, and that’s just a hunch, if motion is detected, it will not go into a off state and won’t trigger a new motion.

I see the motion physically becoming active (light goes on), If I look at the sensor within homey it says motion is detected, but if I look at the timeline, there is no new motion for 11 minutes.

Goedemorgen,

Ik heb een Shelly 2.5 aangeschaft. Maar krijg hem niet goed werkend in Homey.

Ik heb netjes de Shelly app geinstalleerd en daar de Shelly 2.5 toegevoegd ( vanuit deze app werkt het prima )

Toen toegevoegd aan de Homey, En daar installeert hij dan de Shelly 2.5 Relay 1 en de Shelly 2.5 Relay 2.

Nr. 1 werkt zoals het moet, Nr.2 blijft een rood driehoekje in beeld. met de tekst. Apparaat is onbereikbaar: Cannot read property ‘hasOwnProperty’ of undifined.

Ik ben een beginner kans is groot dat ik iets fout doe of over het hoofd zie… Maar ik kom er niet uit .

Help ! :slight_smile: