Homey Community Forum

[APP] Shelly

Did someone managed to update the FW of the Motion Sensor to 2.0RC? I can’t seem to get it to update. It just doesn’t find the beta update.

Just tested this again. Works fine on 3.3.8. Did you test with this version? Or do you perhaps have some alternate configuration like set it to a reversed switch? And you have you already tried to remove the action card and re-add it to the flow. This sometimes resolves issues as well.

It’s really hard to see what’s going on here. I dont own a rollershutter and this functionality is custom functionality of the Shelly app for Homey so there is no documentation to fallback on. Could you install this test version to see if that fixes the issue: Shelly | Homey

hi there,

i have also have problems with my flows using shelly 1. i use this shelley to open/clos my garage and this is also included for nuki keypad->ifttt->garage->nuki smart door for the kids to come home without a key…

when i press the big device icon button, it works, but within the device now two “taste” buttons are available and both do not work. the flow also does not work. maybe this information helps to fix it?

matze

Could you post your flow?

Just tested this again. Works fine for me on 3.3.8. Do you perhaps have some alternate configuration like set it to a reversed switch? And have you already tried to remove the action card and re-add it to the flow. This sometimes resolves issues as well.

hi phuturist,

i just re-added the shelly1 card and changed from switch state temporary to switch on. this works (the other card not). i am happy again.

cheers

v3.4.0 - 2021-09-14

  • Fixed an issue with dimming on Shelly Vintage.
  • Possibly fixed an issue with the intelligent action for Shelly 2(.5) roller shutter.
  • Added support for Door/Window, Motion, Flood, Humidity/Temperature and Smoke sensors on Homey Cloud.

Hi @Phuturist

I’ve installed the new test version, intelligent action on roller shutter still doesn’t work.

I’ve created a simple flow to test it “when- this flow is started/ then - intelligent action on a roller shade”

If you want me to send you a diagnostic report or anything else for you to check just tell me the steps i should take to send you whatever info you need, also if i should do it with the stable or the test version.

Thanks.

Apologies for slow reply I didn’t receive any notifications and have been working. I am now on version 3.4.0 of the app and still not working. I don’t have Shelly set to reversed switch. Power On default is set to Off, Button type is set to Detached as it has been. I can still activate the Shelly via Devices Tab but it doesn’t work in flows, other devices in those flows are still working.
Have noticed that since most recent firmware update for Shelly my Door Window sensors are shown as offline in Shelly app as well as Homey.

Interesting, do you then have another card for turning Shelly 1 back off again after a delay?

Not that’s interesting as that does work in a flow. I replaced the Switch On Temporarily Card with Turn On and Turn Off (with a 1 second delay) and the flow works again.
Happy nut curious behaviour

Can you test the version in the test channel. Shelly | Homey

Can you test the flipback action card for the version in the test channel: Shelly | Homey

Yap, intelligent action it’s working again on this test version.

I have a flow which uses the Shelly 1 Switch State Temporary card, but I’ve found that maybe for the last few weeks (even months) it’s not been working.
It’s related to a temp call so assumed the temp was the fault but changed it and it seems this call isn’t working…
Anyone else using this and seeing issues?

Edit: should probably read the messages above… Looks like it’s not just me! :rofl:

Awesome. 3.4.1 smart actions are working again. Many thanks

v3.4.1 - 2021-09-15

  • Initial state of devices added to Homey Cloud is now updated.
  • Fixed the intelligent action for rollershutter devices
  • Removed some deprecated flow cards, make sure to fix your flows if you missed the previous announcements.
1 Like

Tried a couple of time with manual update and now works.

Thanks for the app (seems to be) working great, one thing I was missing an option of seeing the connection quality per device, e.g. the WIFI RSSI DB as it’s mentioned in the shelly webapp

would this be possible?

Sure, please submit a feature request on GitHub for this.