Homey Community Forum

[APP] Shelly

I keep the random isseus that some or all Shelly1 devices are not found anymore by homey. They have a static IP and the wifi coverage is excellent. This is withholding me for buying more devices. They are always reachable by the native Shelly app.

It is known the WiFi connection of homey isn’t the utmost reliable. So maybe it isn’t the connection of the Shellys, do they start responding after restart of the app?

No not on restarting the app. Restarting homey resolves it. Leaving them after a while they are back again. Like now two hours later

That might actually confirm what @Martijn_Hoogenbosch is suggesting. Homey polls the Shelly’s and shows a Shelly as offline when it can not reach it. My app will continu to poll the Shelly at a lower frequency to see if it’s comes online again. If a response is recieved the Shelly is registered as online again.

So restarting Homey or seeying them come online again indicates a network issue between Homey and the Shelly’s.

FWIW: I have the same issue with the Sonoff app (example), where the app loses connection to some devices after a while. The Sonoff app maintains a permanent connection with the devices, which apparently breaks regularly. I also suspect Homey’s networking.

Is this something more users would see? Or am I the only one. And is there anything I can do to resolve this?

Yes, as @robertklep mentioned, other users and apps are experiencing this as well. Although I know we are getting a “little bit” offtopic I’d like to share my personal experience; I personally don’t have any problems in regarding to connectivity issues and my Wifi connection works just fine for Homey. Don’t know what you can do about it, don’t know your wifi. I’m using a separate SSID for all my home automation with only 2.4ghz enabled on a channel which is not used by any other wireless networks in the area. Be sure to only use channel 1, 6 or 11 due to overlapping frequencies and preferably try to avoid 1 because it is the same frequency as the Zigbee channel is in Homey (and cannot be changed).

@Phuturist
Is the Shelly WiFi 3500W plug supported? Is it not listed under the supported devices. Thanks!

There is no specific Shelly WiFi 3500W plug. The Shelly Plug supports up to 3500W if that is what you mean. And yes, that one is supported.

Ah, I see it is listed, but with a black image (I was looking for a white one). Thanks :wink:

@Phuturist
I installed the Shelly 2.5 Relay to operate my tv-lift. In the shelly app, it works fine, but in Homey I get error messages. When installing in Homey, I get two devices, Relay 1 and Relay 2. When I press them, I get the message “something went wrong, try again later”. I have restarted both Homey as the Shelly Relay. Also deinstalled the Shelly App and reinstalled again, same result. Any Idea what to do?

As what type of device have your configured the Shelly 2.5 in the Shelly app?

As Shelly 2.5 Relay

I now added it as Shelly 2(.5) Roller Shutter. That works. Not sure if that is the intention, but as long as it works the problem is solved :slight_smile:

Yes, that was the reason for asking … :wink:

1.14.1 - 2019-12-11

Skip the login credentials screen during pairing for devices that do not have authentication set up.

Hi, I can’t add new devices after app version 1.14.1

Is the Shelly Dimmer (not SL) supported? I’m not able to add it.
It’s not listed between the supported devices, only the SL version.
Tried to add it as an SL, but it’s not working.

After reading your comment, i deleted a device and tried to add it again, i was having problems adding a shelly dimmer, but after deleting a Shelly1PM i’m no able to add it again.

So it looks like a general issue adding new devices since the update today to 1.14.1

Correct, just noticed that version 1.14.1 has a bug and only the Shelly 1 can be paired at the moment. I just pushed version 1.41.2 to the app store but it’s awaiting approval by Athom and that can take up to a couple of days in the worst case. Please be patient.