Homey Community Forum

[APP] Shelly

Yes, turns out it’s available through CoAP as well. Don’t forget your promise … :wink:

1 Like

Homey version 5.0.4
Shelly latest Version of 1.9

I re-register the Shelly 1 with the Homey. During the process, the Homey loses the connection to the WLAN and restarts. After that, the Shelly App is on the Homey but the Shelly 1 is not. Then the Homey starts to restart every 2 minutes, permanently.

You have to deactivate the app after the restart. Then the Homey restarts and you can uninstall the app again. After that, the Homey runs again without any problems.

This also happens with a completely new Homey.

Do you know this behaviour?

Sounds similar to this issue: Shelly app causes Homey to restart continuously and show a red ring · Issue #28 · jghaanstra/cloud.shelly · GitHub

If you have a Synology NAS try disabling the Bonjour service.

(p.s. firmware 1.9 is not the latest firmware for the Shelly 1, if you dont see an update connect it to the cloud first.)

1 Like

I’m trying to pair the RGBW GU10 spots with Homey, which seems to work. Homey finds the IP addresses, but after that I need to choose an icon, but can’t do so. How can I pair properly?

Try rebooting Homey.

No success…

Error: Time out after 30000ms.

Try using the developer tools for pairing: Homey Developer

And while pairing have the developer console in the browsers open (press F12 and select tab console) to see if there are any meaningful errors.

Tried to do so with macbook, but F12 won’t do that…

Still no luck…

" Error: Network request failed"

The problem only occurs with the RGBW GU10.

The white GU10, dimmer 2 and plug S paired without any problem.

Use a proper browser like Google Chrome.

Which is strange as this is shared code between all drivers. At least in all recent versions of the app.

Hey,

@Joep_Vullings, I’ve been facing the same issues. I’ve been talking with Shelly about this GU10 RGBW alot lately and it seems their firmware is not working well (and not very well with Homey as well). I’m now running a Beta firmware from their side and that has improved things. I’m able to add them again in Homey. Also, the ‘scenes’ from the shelly app work well now, which i had reverted to as Homey was not able to talk to the lamps.

If you access the lamps IP address in your browser, you are probably able to update the lamps also to the Beta firmware (under settings).

1 Like

Good suggestion. Will try!

I have contacted Athom with this issue. Will report if I have news.

Updating to Beta firmware didn’t help to pair the RGBW.

I can choose to pick an icon, but after that, it seems to do absolutely nothing.

Athom states that choosing the icon is done within the app.

(“Dat is wel gek, het kiezen van iconen komt in principe vanuit de app, dat is een van de afrondende stappen van het koppelen als ik het goed begrijp.”)


Update:
Updating to beta software did the trick!

Choosing a custom icon is indeed specific functionality that I have created for my apps. It’s the second step in the pairing process directly after device discovery. So there has not even been any communication with the specific Shelly device other than the mDNS discovery which is also part of Homey core. When looking at the screenshot and errors you send me through PM you are not able to actually select if you want to use the standard or a custom icon. The pairing template just does not render completely. It seems this is due to some javascript errors that are generated and which reference functions from Homey core. I already had forseen Athom would be pointing to me to fix this but I see no way on how to do this.

Waht makes it’s strange is that this only happens to the bulb and only for you (at least for now). I can pair my first gen bulb just fine. Also the pairing templates are shared over all drivers. So if you are pairing a different device that does work it is actually using the same code within my app. Why it does not work with the RGBW GU10 Bulb I do not know.

Ok, something apparently went wrong when updating to Beta software this afternoon.

Now I updated to the beta software and pairing worked like a charm.

I’m sorry for the fuzz.

I have issues adding the second shelly Uni to homey. The first shelly Uni could be added as 2 separate channels one for every input/output.
The second shelly cannot be added the same way. I can only add the first channel of the second shelly. When I try to add the second I can only find the IP address of the first shelly again

The second channel does not need to be paired. It’s added when pairing the device (it adds a device for each channel when pairing one physical device).

Unfortunately it does not work like described. When adding the second shelly Uni it shows only one of the two channels. Could it be a SW bug that only occurs when adding 2 shelly unis?

Ok, I’ll fix it when I find the time for a next release.

1 Like

I need some help or maybe an idea of what could be going on. I have had a Shelly 2.5 controlling two lights for maybe a year or so, probably a little longer.

All of a sudden, some days ago I’m not exactly sure how many, it stopped responding in Homey. Homey said that the device was unreachable.

So I double checked the IP address and checked in my Shelly phone app. It was the correct and actual IP and it worked in my shelly phone app. It also worked in my Home Assistant installation.

So I figured it was some kind of bug. I deleted the device from Homey and tried to re-add it. But I can’t add it again, it says “connect EHOSTUNREACH x.x.x.x:80” where xxxx is the actual IP. It does find it automatically in the “add” list.

What I’ve established:

  • Homey can connect to every other (wired) shelly app I have with no issues. I have quite a few.

  • I’m very confident in my home wifi and the stability of it.

  • The shelly phone app can access the device, my Home Assistant install can access the device and my computers and phones can access the device (and control it).

What I’ve tried:

  • Power cycle Shelly device.
  • Reboot homey.
  • Factory reset shelly
  • Update firmware on shelly.
  • Change IP address of shelly.
  • Reinstall Shelly homey app on top of existing app (i think?).
  • Restart shelly homey app.

What I haven’t tried:

  • Delete and reinstall Shelly homey app.

Something i DID do which COULD be related (since it’s within the same timeframe but I’m not sure if it’s exactly correct) is that I had the experimental tag on the shelly homey app and I reinstalled the “non-test”-version over the experimental one. I’m not sure how else to go back to stable channel or if it was the correct way to do it. I’ve tried to go back to /test version but I don’t think there is one right now?

Something odd that I found is that in the list when I try to add the Shelly 2.5 it also find my other shelly 2.5 that’s already added and fully functional. It does not do this for any other already added devices. I only have 2 shelly 2.5s and it finds both IPs even though one is already in Homey.

I’d prefer not delete and reinstall the app because it will be quite a big hassle and it’s not even guaranteed to work. But I guess that it might come down to that if there’s no one else who can suggest something.

Can it be that the Shelly homey app somehow has a ghost device already added that it didn’t get rid of when I deleted it? Is it any way to kind of remove cache files of apps without deleting data they currently use or something? I’m just throwing ideas and have no idea really…