Homey Community Forum

[APP] SolarEdge

Hi I see the same here,
Tested with App version 1.0.6
I have a SolarEdge: SE5K-RW0TEBNN4
and Enabled ModBus using the SetApp method and Local Wifi - 172.16.0.1.
Connection is on LAN (Still on a DHCP Address).
Default port here is 1502 as in the documentation, but I changed it to 502
Also tested by restarting the SolarEdge but still no luck.

@Arnold_vd_Linden I think I found the bug, at least it worked for me.
It is on the SolarEdge side.

I will post the solution in post *2

At least you can use v 1.0.5 again, because this fix will set the device ID to 1

@Dijker

I received your log. Do you have a Modbus energy meter connected?
Your connection is fine, it is something in the app.
My guess is that you don’t have the Modbus meter, and that the app crashes on that.
For this I will release an update tomorrow with a separate device

Edit: I was able to reproduce this crash, so I think what I assume is correct.
I will cleanup the code and issue an update tomorrow.

1 Like

Nuo I have just the SE5K nothing more en use the other app using the cloud connection now but lik to get more data :wink:

Thanks fow your work, no hurry.
Nice to see these new possibilities, already thought about buying the ZigBee module.

That’s also not working. :cry:
I have tested it with v1.0.4 and v1.0.6 because v1.0.5 was not available from the link provided.
I have also sent a diagnostic report.

I think I’m gonna wait till someone else this has working on his system.:slightly_frowning_face:

Has anyone gotten it working yet? Done everything but can’t get any data to show up in homey. Values remain empty:(

V1.0.6

I noticed a few bugs, I will release an update soon.

It will have some breaking changes, so you will have to re-add the device, but it will be more futureproof.

The current version only works for Solaredge inverters with a Modbus meter!

2 Likes

The app for configuration of SolarEdge converter has been pasword protected by the seller.
An other point that I think Modbus is only running at direct TCP connection and not on WIFI connection.
May be I was wrong.

  • The password should be written on your inverter
  • it works over wifi (As I am already doing that)

The new version is sort of finished. (v1.1.1)
You can test it at Solaredge

I advise you to first remove the app and then reinstall the newer version.
I hope this is the last time you will have to remove the app.
Please also read the configuration info in the first post

StorEdge is implemented but not yet operational.
I will finish this as soon as my own battery is functional

I got contact with the seller.
One of the service guide tels me a simple way how to get contact with the unit setting screen
Push the red tumble switch for one second to left.
Hereafter the internal network start dhcp server and connect your phone to the converter.
Select the converter network (SEDG-…… )
the login code for converter network is above the Big QRcode you wil find the network password.
Start webpage 172.16.0.1 and you are in the setup webpage.

1 Like

Small update to test: v1.1.1
Fix: Avoiding crashing of the app when entering the wrong IP address

Also, does the new version only work with modbus meter like the previous version or now without?

No by default the meter is disabled.
You can enable it after installing the inverter.

It should work with all inverters now

Probably, I am still not doing something right. Done all the steps but values remain empty :disappointed: The protocol should be “none” and then restart the inverter?

I have the same results :frowning:
And display on the SE says Modus: Connected.

Does your inverter shows ‘Connected?’
Try to restart the app

If it doesn’t work, please send me the diagnostics report.

Diagnostics report is send to you.
ID: dbea274c-301e-4c22-a4cd-e832036b6665

Diagnostics report:
58a1cd04-1094-498f-b341-429f6ecdd5db

Thanks for the reports, It’s hard to test things which I don’t have :slight_smile:

I think I found the bugs, It was still trying to pull some data from the (non-installed) meter

Solaredge 1.1.3

Could you try again, thanks for reporting if it works or not