Homey Community Forum

[APP] SONOFF Zigbee

Weird. I open the app on my phone, go to apps, select your sonoff app, swlect the gear icon, and pressed the “Maak diagnostic report”

Here is another one: bdd9da09-5c37-45e9-80c2-82d6e6f88424

Thx, got this one :slight_smile:

Hallo last week i received 2 sonoff zigbee mini switches.
Just after I upgraded from version 4 to 5.
I the app you ask to press the switch 8 seconds to start pairing.
My new switch tries pairing imidiatly after the power is applied. ( led starts blinkend on/off) This is correct according to the user instructies in the box.
Unfortunatly nothing happends .I tried this several times. After that I tried to pair as a genetic zigbee in the homey app. No succes. Any idea what causes this

If you are unable to pair a Zigbee or Z-wave device as a generic device the problem is not in the app but a generic Homey issue.

What you can test/check:

  • Make sure you have enough router device (grid powered) among the first 15 devices you add to Homey.
  • Reset the device (see device specific instructions) before trying to pair it
  • Restart Homey (11 minutes without power)

@johan_bendz

  "ids": {
    "modelId": "MS01",
    "manufacturerName": "eWeLink"
  },
  "endpoints": {
    "endpointDescriptors": [
      {
        "endpointId": 1,
        "applicationProfileId": 260,
        "applicationDeviceId": 1026,
        "applicationDeviceVersion": 0,
        "_reserved1": 0,
        "inputClusters": [
          0,
          3,
          1280,
          1
        ],
        "outputClusters": [
          3
        ]
      }
    ],
    "endpoints": {
      "1": {
        "clusters": {
          "basic": {
            "attributes": "UNSUP_GENERAL_COMMAND",
            "commandsGenerated": "UNSUP_GENERAL_COMMAND",
            "commandsReceived": "UNSUP_GENERAL_COMMAND"
          },
          "identify": {
            "attributes": "UNSUP_GENERAL_COMMAND",
            "commandsGenerated": "UNSUP_GENERAL_COMMAND",
            "commandsReceived": "UNSUP_GENERAL_COMMAND"
          },
          "iasZone": {
            "attributes": "UNSUP_GENERAL_COMMAND",
            "commandsGenerated": "UNSUP_GENERAL_COMMAND",
            "commandsReceived": "UNSUP_GENERAL_COMMAND"
          },
          "powerConfiguration": {
            "attributes": "UNSUP_GENERAL_COMMAND",
            "commandsGenerated": "UNSUP_GENERAL_COMMAND",
            "commandsReceived": "UNSUP_GENERAL_COMMAND"
          }
        },
        "bindings": {
          "identify": {
            "attributes": "UNSUP_GENERAL_COMMAND",
            "commandsGenerated": "UNSUP_GENERAL_COMMAND",
            "commandsReceived": "UNSUP_GENERAL_COMMAND"
          }
        }
      }
    }
  }

@Wout-1976 ? Are you having issues using this device? (been supported since long…)

Don’t get it working oops … wrong sonoff app. Try again :wink:

Dispite your very much appriciated suggestions and many houre’'s of trying out, I did not succeed to get one of the switches I have to get paired.
Not in the Sonoff app and also not in the Homey app.
So I suspect something wrong in the Homey.
I even replaced the power supply and removerd all other zigbee sensors.
For the moment I will focus on other projects with the Homey

Hi @Gijs_Roekel, sorry to hear.
There are two more things you can try before giving up.

  1. If you have the backup service, make sure you have a successful backup and then reset your Homey (turning upsidedown etc…) and make sure that you keep the ALT button pressed on your keyboard when Homey starts to download updates. This will enable a full installation of the operating system. Once your Homey is up and running you then can restore a last backup and you should be good again.

if this don’t work or if you don’t have backup services:
2. A last thing to test would be to reset your Zigbee network, this will remove any Zigbee unit you have attached to Homey and they will have to be re-paired, but it has proven useful if nothing else works.

Johan, many thanks for your help.
Resetting the zigbee network solved my problem with the Sonoff ZB mini.
After the reset the Sonoff switches( and all my other sensors) paired at the first try…
Again thanks you for the support.
Gijs…

1 Like

Hi Johan,

If it’s not to much trouble, would it be possible to add an trigger flow card for “Device switched on or off”? I have a number of wallswitches and it would greatly reduce the number of flows I need; with that new trigger card and a condition card (device is on) I can use the else for actions.

Hope you are willing to implement this. TIA!

Hi there.
I’m not sure I understand what you ask for. There is already Turned On/Off trigger cards and Is turned On/Off condition cards for all the switches. What device do you miss these cards for?

Hi,

There is trigger card for “Aangezet” (turned on) and a trigger card for “Uitgezet” (turned off). But what I would like to have is a trigger card for “Aan- of uitgezet” (turned on or off).

Aha, now I understand. A flow card for when the device change state. :smiley: I’ll have a look at it.

Thanks :ok_hand: Donated again, have some beers of coffee, whatever you preffer!

1 Like