Homey Community Forum

[APP] Surveillance Station 2

Surveillance Station 2

Adds support for camera’s available in Synology Surveillance Station

App store : https://homey.app/en-gb/app/com.synology.ss/Surveillance-Station-2/

Features

  • Native homey camera support
  • Supports all camera’s available in Surveillance Station

Camera

Motion detection

  • Enable/disable motion detection when installing device and in advanced camera settings
  • Motion detection pushed by Surveillance Station

Flows

  • Action to update camera image. This can be used in doorbell flows
  • Actions for recording (start / stop)

Surveillance Station

Home Mode

  • Manage your Home Mode by adding your Surveillance Station to Homey

Flows

  • Actions to manage the Home Mode
  • Triggers for Home Mode (enabled / disabled)

Getting Started

  • Install the app on Homey
  • Add a device
  • Select the Camera or Surveillance Station
  • Provide the credentials to your Synology
  • Select your device
  • Done!

Reconnect/Repair your device

  • Go to the devices settings, choose “Maintenance actions” and then “Repair”.

Tested with

  • DSM 6.2.2-24922 Update 4
  • Surveillance Station 8.2.6-6009
  • Homey 3.2.0+

Troubleshooting

  • Problem: When your Synology reboots, the connection is lost with your device.
  • Solution: Go to the devices settings, choose “Maintenance actions” and then “Repair”.

Note

  • This app is not officially maintained by Synology.

What’s new

2.3.0

  • Added flow triggers for Home Mode, renamed Home Mode states to enabled and disabled
3 Likes

Nice app, thanks a lot!

It works well (almost). Very pleased I can take snapshots and push them throw notifications as the old Surveillance app would fail after first screenshot.
The one part I have problems with is that the motion alarm gets stuck on Yes. Although it has been acknowledged to be turned off on the next page.

See here:

But all good in here:

Homey firmware 4.2.0
Thanks and let me know if more details required.

EDIT: restarted Homey and now all looks OK. Weird in first instance anyway.

Hi @danone,

Strange thing. Not sure if something is wrong with the Synology app or with the Homey app. Please let me know if it happens again.

Update 2.2.1 is live!

  1. In this version I have fixes some pairing issues (layout an security)
  2. You can now start or stop recording via a flow action
4 Likes

Update 2.3.0 is live!

  1. In this version I have added flow triggers for changes in Home Mode
  2. Home Mode states are now renamed to “enabled” and “disabled”
1 Like

Thanks for a great app. I recently updated to Surveillance Station version 8.2.8-6335 and I have some issues with my cameras now. I constantly get the red warning symbol on my cameras, when I try to repair it seems to work at first, but as soon as I get back to the camera screen I get error messages again. Someone experienced this?
Screenshots are hard to retrieve since the error message disappears quickly.

Hi @Exile82,

The only thing I can think of right now is when the storage is full on your NAS/Surveillance Station or Homey’s storage. The reason you need storage is to store a token on both sides to communicate and to save the camera image. Could you please check if you have sufficient free space?

Thanks for your response! Of course, on my NAS I have 1.28 Tb of free space and the Homey says storage is fine.
The app says that connection is expired. After repairing it says that it was successfully done:

,

but the app immediately says that connection expired

Strange, I am running the same version as you do without any problems.
Can you check your Logs in the Log Center (Main menu on your Synology).
Maybe the logs tells us something…

Hi! Well, there are a nunch of things there, like people constantly trying to hack my Synology. :slightly_smiling_face:
But nothing that seems incorrect with Surveillance Station.
What version of SS do you run?

I run these versions

  • SS version 8.2.8-6335
  • DSM version 6.2.3-25426 Update 2
  • Homey version 4.2.0

Do you connect with your SS via ip address or hostname?

Just checked SS again, seems that there are some issues with the camera itself, actually. I am gonna check that first and see if that resolves the issue. Thanks