Homey Community Forum

[APP] Surveillance Station 2

Hi @Joel_Walther, I am not sure why some camera’s don’t respond with a valid snapshot path from synology but in the next release I will try to find out and hopefully I can fix this.

ok, thanks. If you need something from me, let me know !

Hi again @bookmarc, I did check on Synology side, and in the Surveillance application I updated the Device Pack. After that I have deleted the device, make it new again, and it works. I have now both camera working with snapshot. I also did an update of the DSM. I’m not sure if the resolution comes from the package update or from the system with the reboot.

Greenshot 2020-12-22 09.49.44

Hi @bookmarc, first of all thanks for the nice app, was using the old one but after I had to replace my NAS it did not work anymore. installed your app and it works flawless… what I used to use is the option to enable or disable the camera’s, Is this difficult to add ?? and are you considering to add this feature, anyway thanks again…

Hi @Robebare , great to hear you like the app. The next version is almost finished and should make the connection with the NAS more stable. I will add the enable/disable camera feature on the roadmap. Not sure when I have the time to develop it, but I will look into it.

Nice and no hurries, I do understand its not your day job so appreciate your efforts.
have a :beer:

1 Like

Thanks for your donation, very generous of you!

Hi Marc,

I also have trouble connecting my Synology Station. I have version DSM 6.2.3-25426 Update 3 and use port 5000 through http (and tried HTTPS with 5001), with my admin account. Also I rebooted by NAS as someone suggested that.

What can I try more to connect? The app looks very promising but without connecting there is nothing :-).

After reboot of my nas, Homey and iPhone I tried it again and in http:// mode with port 5000 it worked!! With Https I received an certificate error (https would be nice).

I disabled home-modus and enabled movement while installing the my outside camera’s, but jumping before my camera’s did not enable any movement. What can I further change? Thanks for the advice.

Then solve the certificate issue :wink:

Hi @Jomi , if you wan’t to use https you need a valid certificate for your hostname.
More information about this topic can be found @ Synology: DiskStation Manager - Knowledge Base | Synology Inc. .

When you enable motion detection, the app will install an action rule on your NAS/Surveillance Station. When your Surveillance Station detects any motion it will inform the Homey. Please check your Surveillance Station first to be sure it detect movements/motion.

A new version in the test-channel of this app with changes:

What’s new in v3.0.0
Credentials moved to Surveillance Station with option to save credentials for auto reconnect

1 Like

Thank you @Henk_Renting,

A new test version is available (3.0.0) and with this version the app is capable of reconnecting when a connection is lost or invalid. (if you have selected the checkbox to remember your credentials)
Connections could get lost when your 2fa/mfa token is expired or when you reboot your Surveilance Station.

This version requires you to have the surveillance station as a device added to your homey first. After that you can add your camera’s (or repair) them and select the surveillance station device it is connected to.

Feel free to test this version and please let me know if you run into any problems.

2 Likes

Installed 3.0, will test! Does the On/Off button of the surveillance station device do anything (didn’t seem to)?

BTW: And did you also look into making the alert timeout configurable?

Hi @JeeHaa

The On/Off button is for the “Home Mode” on the Surveillance Station. Depends on your settings on the NAS what it does. (could be nothing).

I prefer to release early and often and the priority on this release was the connectivity issues.
In the next releases I will add the motion detection timeout setting and an option to enable/disable a camera.

1 Like

Thanks for the tips on https/certificate settings, it all works now.

What is not working is ‘movement, the reason for installing this app’. In the SS DS CAM app I see the blue lines confirming there is movement. In the app and using a simple flow to make a notification in the timeline after movement, nothing happens. Home-mode is off.

Any idea?

Hi @Jomi , could you please validate 2 things for me that needs to be ok for motion detection to work properly.

1 - Advanced setting on the camera in Homey

The motion detection should be ‘active’.

2 - Action rule in Surveillance Station

Could you please login to your Synology and Surveillance Station and go to ‘Action rules’.
There should be a rule “Homey Motion Detection for [name of camera]” for the camera.

Hi Marc

The camera advanced settings are set OK, the rule Homey Motion Detection for ‘name of camera’ indeed did not install automatically. The Home Mode did install well.

I can make my own webhooks, but how do I install the default ones?

Please make sure that the user belongs to the administrator group in your Synology.
https://www.synology.com/en-global/knowledgebase/Surveillance/help/SurveillanceStation/action_rule

When you disable the motion detection setting for your camera in Homey (save it) and then Enable it again (and save the settings) the rule should be automatically installed on your Surveillance Station.

1 Like

Great, that did it. Everything is perfect now, many thanks for the fast feedback!!

1 Like