Homey Community Forum

[App] Tasmota MQTT

I checked overall system memory and CPU usage. Those are fine.

I also checked those APP’s usage. They are also fine,

I don’t have many devices. If I restart one device , it works perfectly fine for a while the others still operate slowly…

There are no other lags with my system. My Wifi based Yeelights turn on very quick and responsively from the Homey APP…

It’s got me stumped.

The Homey broker has flaws in handling retained messages: MQTT Hub/Gateway - #968 by scanno

1 Like

That wouldn’t account for messaging delays, though (I don’t think Tasmota works with retained messages at all, apart from certain specific commands, and only if you configure for it specifically).

It doesn’t explain the delays indeed, that’s resources as you already mentioned. But it is the reason why devices are unavailable in HA (as @mvanlijden mentioned).

Any ideas on a possible fix … ? I’ve tried re-installing MQTT broker… Doesn’t have any effect…

Here’s the broker logs…

20210911-21:22:00 Packet published {"Time":"2021-09-11T12:21:55","Uptime":"0T19:43:20","UptimeSec":71000,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":5,"POWER":"OFF","Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"Mode":"11n","RSSI":96,"Signal":-52,"LinkCount":2,"Downtime":"0T00:00:04"}}
20210911-21:22:00 Packet published {"POWER":"OFF"}
20210911-21:22:00 Packet published OFF
20210911-21:22:02 Packet published 10
20210911-21:22:02 Packet published ON
20210911-21:22:03 Packet published 10
20210911-21:22:05 Packet published ON
20210911-21:22:06 Packet published {"StatusSNS":{"Time":"2021-09-11T12:22:01","Switch1":"ON"}}
20210911-21:22:09 Packet published {"Time":"2021-09-11T12:22:09","Uptime":"6T21:32:44","UptimeSec":595964,"Heap":26,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":46,"POWER":"OFF","Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"RSSI":62,"Signal":-69,"LinkCount":22,"Downtime":"0T01:06:25"}}
20210911-21:22:10 Packet published ON
20210911-21:22:12 Packet published {"Time":"2021-09-11T12:22:02","Uptime":"0T19:43:27","UptimeSec":71007,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":5,"POWER":"OFF","Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"Mode":"11n","RSSI":94,"Signal":-53,"LinkCount":2,"Downtime":"0T00:00:04"}}
20210911-21:22:12 Packet published {"POWER":"OFF"}
20210911-21:22:12 Packet published OFF
20210911-21:22:12 Packet published ON
20210911-21:22:13 Packet published 12:22:09 MQT: tele/roof_exaust_fan_and_temp_sensor/STATE = {"Time":"2021-09-11T12:22:09","Uptime":"6T21:32:44","UptimeSec":595964,"Heap":26,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":46,"POWER":"OFF","Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"RSSI":62,"Signal":-69,"LinkCount":22,"Downtime":"0T01:06:25"}}
20210911-21:22:15 Packet published {"Time":"2021-09-11T12:22:11","Uptime":"3T03:50:37","UptimeSec":273037,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":35,"POWER":"ON","Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"Mode":"11n","RSSI":84,"Signal":-58,"LinkCount":16,"Downtime":"0T00:04:05"}}
20210911-21:22:15 Packet published {"POWER":"ON"}
20210911-21:22:16 Packet published ON
20210911-21:22:19 Packet published 10
20210911-21:22:25 Packet published {"Time":"2021-09-11T12:22:20","Uptime":"0T19:43:45","UptimeSec":71025,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":5,"POWER":"OFF","Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"Mode":"11n","RSSI":98,"Signal":-51,"LinkCount":2,"Downtime":"0T00:00:04"}}
20210911-21:22:25 Packet published {"POWER":"OFF"}
20210911-21:22:25 Packet published OFF
20210911-21:22:28 getUserArray called
20210911-21:22:30 Packet published {"Time":"2021-09-11T12:22:20","Uptime":"0T19:43:45","UptimeSec":71025,"Heap":25,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":21,"MqttCount":5,"POWER":"OFF","Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"Mode":"11n","RSSI":96,"Signal":-52,"LinkCount":2,"Downtime":"0T00:00:04"}}
20210911-21:22:30 Packet published {"POWER":"OFF"}
20210911-21:22:30 Packet published OFF
20210911-21:22:30 Packet published {"Time":"2021-09-11T12:22:20","Uptime":"0T19:43:45","UptimeSec":71025,"Heap":24,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":21,"MqttCount":5,"POWER":"ON","Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"Mode":"11n","RSSI":96,"Signal":-52,"LinkCount":2,"Downtime":"0T00:00:04"}}
20210911-21:22:30 Packet published {"POWER":"ON"}
20210911-21:22:30 Packet published ON
20210911-21:22:30 Packet published {"StatusSNS":{"Time":"2021-09-11T12:22:20","ENERGY":{"TotalStartTime":"2020-11-14T14:10:15","Total":65.900,"Yesterday":0.012,"Today":0.001,"Power":0,"ApparentPower":0,"ReactivePower":0,"Factor":0.00,"Voltage":0,"Current":0.000}}}
20210911-21:22:30 Packet published {"Time":"2021-09-11T12:22:20","Uptime":"0T19:43:45","UptimeSec":71025,"Heap":24,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":21,"MqttCount":5,"POWER":"ON","Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"Mode":"11n","RSSI":96,"Signal":-52,"LinkCount":2,"Downtime":"0T00:00:04"}}
20210911-21:22:30 Packet published {"POWER":"ON"}
20210911-21:22:32 getLogLines called
20210911-21:22:33 Packet published 10
20210911-21:22:34 Packet published ON
20210911-21:22:39 Packet published {"Time":"2021-09-11T12:22:35","Uptime":"3T03:51:01","UptimeSec":273061,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":35,"POWER":"ON","Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"Mode":"11n","RSSI":74,"Signal":-63,"LinkCount":16,"Downtime":"0T00:04:05"}}
20210911-21:22:39 Packet published {"POWER":"ON"}
20210911-21:22:39 Packet published {"StatusSNS":{"Time":"2021-09-11T12:22:32","ENERGY":{"TotalStartTime":"2020-11-14T14:10:15","Total":65.900,"Yesterday":0.012,"Today":0.001,"Power":0,"ApparentPower":0,"ReactivePower":0,"Factor":0.00,"Voltage":243,"Current":0.000}}}
20210911-21:22:43 Packet published ON
20210911-21:22:43 Packet published {"StatusSNS":{"Time":"2021-09-11T12:22:35","Switch1":"ON"}}
20210911-21:22:51 Packet published {"Time":"2021-09-11T12:22:47","Uptime":"1T02:31:46","UptimeSec":95506,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":14,"Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"Mode":"11n","RSSI":100,"Signal":-26,"LinkCount":11,"Downtime":"0T00:02:25"}}
20210911-21:22:52 getUserArray called
20210911-21:22:56 Packet published {"Time":"2021-09-11T12:22:51","Uptime":"1T02:30:14","UptimeSec":95414,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":14,"POWER1":"OFF","POWER2":"OFF","POWER3":"OFF","Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"Mode":"11n","RSSI":62,"Signal":-69,"LinkCount":11,"Downtime":"0T00:02:42"}}
20210911-21:22:56 Packet published 12:22:47.680 MQT: tele/rfbridge1/STATE = {"Time":"2021-09-11T12:22:47","Uptime":"1T02:31:46","UptimeSec":95506,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":14,"Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"Mode":"11n","RSSI":100,"Signal":-26,"LinkCount":11,"Downtime":"0T00:02:25"}}
20210911-21:23:01 getLogLines called
20210911-21:23:16 getLogLines called
20210911-21:23:27 Packet published {"Time":"2021-09-11T12:23:28","Uptime":"1T02:37:24","UptimeSec":95844,"Heap":27,"SleepMode":"Dynamic","Sleep":50,"LoadAvg":19,"MqttCount":15,"POWER":"ON","Wifi":{"AP":1,"SSId":"RusTyNet","BSSId":"A8:5E:45:FD:0E:88","Channel":7,"RSSI":100,"Signal":-48,"LinkCount":12,"Downtime":"0T00:02:39"}}
20210911-21:23:31 Packet published {"Time":"2021-09-11T12:23:28","DS18B20":{"Id":"3C01D6076730","Temperature":20.3},"TempUnit":"C"}
20210911-21:23:37 Packet published 11
20210911-21:23:37 getLogLines called

Thanks for this app, it allowed me to add a PMS5003 sensor I’ve connected to a Wemos D1 running Tasmota :slight_smile:

There’s only 1 downside: the values cannot be graphed in the insights… does anyone know why that is?

Just a quick update.

After spending many exhausting hours and many late nights testing through trial and error and screwing around with every combination of things you could imagine I’ve come to a possible conclusion that MQTT broker in Homey is broken…

A broken broker… :woozy_face:

I tried just about every possible thing. I reinstalled everything on Homey until I went blue in the face. i I changed router settings, I even reflashed my Tasmota devices to earlier versions., but nothing …

The last thing I tried (which was today) was to redirect MQTT client and all of my Tasmota devices to a different broker. In this case a free online broker called Http://broker.emqx.io

Drum roll…… It now all works… :grin:

I must of fully uninstalled and re-installed MQTT Broker about x 5 times… Anyone got any theories as to why it’s permanently broken even after doing this … ? I see it hasn’t had an update in about 2 years.

Russ

I’m currently surviving on that temporary 3rd party free online MQTT broker but any advice or any theories on what’s causing the problem would be really great guys .?

:disappointed::disappointed::disappointed::disappointed::disappointed: no response …

I heavily rely on Tasmota and MQTT to control all the motion activated lights in my house.

One of them in particular controls a light for narrow stairway at the rear of the house. At night it’s fairly important for that particular light to turn quickly before you get to the first step. The young girl that lives up there has nearly fallen over a few times.

It would be great to get my system back to normal as this free online MQTT broker that I’m currently using can’t be truly trusted and relied on. Just a few seconds makes a big difference, or she could trip and fall…

Thx

1 Like

I don’t think there’s an inherent problem with the MQTT Broker app, and its developer is always busy with non-Homey related stuff. If you want a quick fix, look into running a local MQTT broker (something like Mosquitto or Mosca), just not on Homey. If you have a NAS or a Raspberry Pi in your home network, you can use those to run it on.

Thanks Rob. Unfortunately don’t have a PI or the time to set that all up.:frowning:

One of the main reasons I coughed up a massive $600AUD (€370) for my Homey was to not have to screw around with that sort of stuff.

Homey is meant to be an all in one solution. I really shouldn’t have to create a hacky collection of other hardware and bits of pieces to make it run properly.

What would be great is to have a developer for the MQTT broker app that basically hasn’t abandoned it , keeps it up to date, and is available for customer support for when ever its needed and have an offical section in the forum for it…

Sorry Rob… Just having another one of my cranky grumbles . :unamused::unamused::unamused::unamused:. I’m sure you guys are sick of me by now… lol

If you’d like an out of the box solution you should avoid MQTT and use supported ZigBee or Z-Wave devices.
Never failed on me.

Install an App, assign a user name and password.

Enter an IP , user name and password , topic name on the device.

Seems pretty easy to me…

Though they are two different technologies MQTT is far more simple, reliable and robust , (when the Broker implemented properly).

You might be lucky with your particular setup but I see many many issues with Zigbee with others

Also Zigbee is not unified. An MQTT device can always communicate or control any another MQTT device or broker. Doesn’t matter which company has manufactured it.

Try getting a Chinese Zigbee button to turn on a Philips Hue light. A lot more complicated.

MQTT is basically just a transportation protocol, but there’s nothing standardized about what it actually transports. Could be binary, could be JSON, could be whatever. On top of it you can build a communication infrastructure for devices to be able to talk to and/or control each other, but that’s completely implementation-specific.

For example, a Tasmota device has no idea how to communicate with an ESPhome device, which has no idea how to communicate with a MySensors device, even though they all use MQTT as their transport protocol.

Zigbee at least has a standardized cluster library that’s relatively well supported.

Actually, it’s not. Both devices will likely support the On/Off cluster.

(post deleted by author)