Homey Community Forum

[App] Tuya Cloud

Because this system needs a permanent connection, battery powered devices are not gonna be supported.
Because of power saving, those devices only seek connection when a signal has to be sent. If the signal has been sent, the connection is shut down again.
So the only way to communicate with those devices is during the (very short) timeframe when they come online to send a signal.
I suggest using Tuya Zigbee battery devices, they shoud work with the Tuya Zigbee app.

There is new test version to fix some connection bugs:

2 Likes

Thanks! This morning connection was lost and I sent you a crash report just in case. But the app didn’t crash, so ignore it pls😊

The crash report did reveal an error I didn’t see earlier, so this is fixed also.

2 Likes

Oh nice to hear! And thanks for the quick fix again, Jurgen.
A beer is on it’s way.
Cheers

1 Like

Again, thx for the quick “scene select” bugfix, Jurgen.
v0.0.15 solves it!

1 Like

@Jurgen_Heine Great app, managed to install 20 Calex GU10 RGB lights at a friends place this weekend using this APP, I just had 1 issue, the rgb options doesn’t seem to show up in Homey, although these lights are RGB lights (which can be controlled using the TUYA, Smartlife and Calex app, tried all to set them up)

Everything else seems to work fine, just the rgb option seems “missing”, is there anything I can do/try to get that fixed?

The Tuya API, this app is using, doesn’t support color changing for all devices. It’s a known problem I can’t fix, only Tuya can fix this. You can try to use scenes to call “tap to run” action.

Ah okay, that explains why i couldn’t get it working :slight_smile:

I’m not a developer, but I found this while searching for the Tuya rgb issue this weekend while I was trying to figure out why I couldn’t get it working, not sure if this means that it is now part of their API, seems they use HSV and not RGB values

https://developer.tuya.com/en/docs/iot/open-api/standard-function/lighting/categorydj/f?id=K9i5ql3v98hn3#title-8-colour_data

Hope this may help you to get this feature working :+1:

It’s a different API, this app uses the Tuya API for home-assistant. I was aware of this API and already looked at it. First it’s for businesses and did you see the pricing: Pricing-Documentation-Tuya Developer. It’s a no go for me.

Yeah that is ridiculous, didn’t see it was a paid API, is there any good way to bypass this issue and make it possible for rbg control through homey, or is a local setup the only option then? (for example through nodered and mqtt etc)

@Chris_nl , did you miss this? It is a workaround but I use it for many things:
If you create tap-to-run “set light to green” on your phone,
Then in Homey flow editor, you can select Tuya Cloud action card “Trigger a scene”.
Then you can select “set light to green”.
Now when this flow is run, it sets your rgb light to green.

Examples:
Tap-to-run scene:

Phone tuya app:

Homey Tuya Cloud app:

Cheers

1 Like

Ah great! Yeah I think I missed that one, will have a look and see if I can get that to work, thanks :+1:

1 Like

I just realized I already wrote an how-to:

2 Likes

Hi,

When adding a light its added ok, but as soon its added I get an exclamation mark on it. Its the same on stable and experimentell app.

I have created a diagnostic code: 9cab205c-4d8b-49f7-b976-70c7bd1f580c

image

//Erik

@spajder_ua And you did read some of the info available here? It could be this (and solved now, it’s 11mins later)

1 Like

Thanks, that was the problem. My patience :slight_smile: Thanks for answering :slight_smile:

1 Like

something strange: in homey found my switch and it works. only when i press the switch itself it does not notify homey that it is on. so there is no action to the lamp. If I turn it on in homey app, it turns on the LED of the switch and has the action with the lamp.

so from homey to switch is ok, but not from switch to homey

Only once in 10 minuten the status can be retrieved from API, this is a limitation of the Tuya API, i can’t do anything about. So when you switch the device it can take up to 10 minuten before the status is shown in Homey. Sending commands are direct executed by the API.

Beste Heine,

Dank voor de snelle reactie, ik zit met een dubbele switch. Ik heb hem reeds wel via tuya-cli wizard kunnen achterhalen key en id. Echter is de rechter dan niet te gebruiken, ik hoopte dat dit soepel zou gaan verlopen via de “cloud app”. Dit functioneert echter ook niet naar behoren. Heb jij nog ideeen?