Homey Community Forum

[APP] Tuya Zigbee App

Try adding the units when they are close to a routing device (a grid powered zigbee device) and not close to Homey.

With the latest 0.1.34 version my BlitzWolf BW-SPH13 devices are not reachable anymore. Tried to remove and add a device again, but that is not working also. Everything worked fine before the update.

Hi there @Monema, a fix is out… and a new fix for correction of the meter/measure values is on its way

Thank you so much for the fast response. Everything is working again :slight_smile:

And @johan_bendz has added a great unique feature that allows us to apply a correction factor to compensate for inaccuracy of each individual plug! :+1:

I compared a few BlitzWolf BW-SPH13 plugs with a Voltcraft power meter for a load of 50 and 1000W, and it turns out Tuya based Smart Plugs typically report power consumption about 10%-15% too high (also reported in other HA related forums).

1 Like

Hi @johan_bendz ,

First of all, thanks for this great app !

I just bought 2 kind of switches modules. Could you add them to you app please:

  • MS-104Z: 1 gang 2 Way ZigBee+RF Switch:
    "modelId": "TS011F",
    "manufacturerName": "_TZ3000_zmy1waw6"
  • MS-104BZ: 2 gang 2 Way ZigBee+RF Switch:
     "modelId": "TS011F"
     "manufacturerName": "_TZ3000_pmz6mjyu"

Best,
Jérôme

Hi @johan_bendz ,

I finally directly created the PR in you github repo!

Best,
Jerome

Hi @johan_bendz,

Your rabbit hole on TUYA devices expended rapidly! :wink:
Nice work though!

I’ve expanded my zigbee network to 70 devices and TUYA really likes TRADFRI power sockets to mesh with. Some weeks ago I had to factory reset homey because the zigbee manager completely failed after the last homey update to 5 RC50. The best thing is that all devices connect fast and without problems on every spot in and around the house after starting with connecting routers devices first. Every one of them could be added with the switches so non of them had to be accessed in their build in location behind switches or ceilings. hopefully this will help others in the community.

I also received a new version of the curtain module and looking forward to replace the roller shutters since they are the few remaining z-wave devices I stil have. Hopefully You get them to work aswell.

Here is the interview:

  "ids": {
    "modelId": "TS130F",
    "manufacturerName": "_TZ3000_vd43bbfq"
  },
  "endpoints": {
    "endpointDescriptors": [
      {
        "endpointId": 1,
        "applicationProfileId": 260,
        "applicationDeviceId": 514,
        "applicationDeviceVersion": 0,
        "_reserved1": 1,
        "inputClusters": [
          0,
          4,
          5,
          258
        ],
        "outputClusters": [
          25,
          10
        ]
      }
    ],
    "endpoints": {
      "1": {
        "clusters": {
          "basic": {
            "attributes": [
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 0,
                "name": "zclVersion",
                "value": 3
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 1,
                "name": "appVersion",
                "value": 64
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 2,
                "name": "stackVersion",
                "value": 0
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 3,
                "name": "hwVersion",
                "value": 1
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 4,
                "name": "manufacturerName",
                "value": "_TZ3000_vd43bbfq"
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 5,
                "name": "modelId",
                "value": "TS130F"
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 6,
                "name": "dateCode",
                "value": ""
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 7,
                "name": "powerSource",
                "value": "mains"
              },
              {
                "acl": [
                  "readable",
                  "writable",
                  "reportable"
                ],
                "id": 65502
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 65533,
                "name": "clusterRevision",
                "value": 2
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 65534,
                "name": "attributeReportingStatus",
                "value": "PENDING"
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 65504
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 65505
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 65506
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 65507
              }
            ],
            "commandsGenerated": "UNSUP_GENERAL_COMMAND",
            "commandsReceived": "UNSUP_GENERAL_COMMAND"
          },
          "groups": {
            "attributes": [
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 0,
                "name": "nameSupport",
                "value": {
                  "type": "Buffer",
                  "data": [
                    0
                  ]
                }
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 65533,
                "name": "clusterRevision",
                "value": 2
              }
            ],
            "commandsGenerated": "UNSUP_GENERAL_COMMAND",
            "commandsReceived": "UNSUP_GENERAL_COMMAND"
          },
          "scenes": {
            "attributes": [
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 0
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 1
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 2
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 3
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 4
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 65533,
                "name": "clusterRevision",
                "value": 2
              }
            ],
            "commandsGenerated": "UNSUP_GENERAL_COMMAND",
            "commandsReceived": "UNSUP_GENERAL_COMMAND"
          },
          "windowCovering": {
            "attributes": [
              {
                "acl": [
                  "readable",
                  "writable",
                  "reportable"
                ],
                "id": 8,
                "name": "currentPositionLiftPercentage",
                "value": 99
              },
              {
                "acl": [
                  "readable",
                  "reportable"
                ],
                "id": 65533,
                "name": "clusterRevision",
                "value": 2
              },
              {
                "acl": [
                  "readable",
                  "writable",
                  "reportable"
                ],
                "id": 61440
              },
              {
                "acl": [
                  "readable",
                  "writable",
                  "reportable"
                ],
                "id": 61441
              },
              {
                "acl": [
                  "readable",
                  "writable",
                  "reportable"
                ],
                "id": 61442
              },
              {
                "acl": [
                  "readable",
                  "writable",
                  "reportable"
                ],
                "id": 61443
              }
            ],
            "commandsGenerated": "UNSUP_GENERAL_COMMAND",
            "commandsReceived": "UNSUP_GENERAL_COMMAND"
          }
        },
        "bindings": {
          "ota": {
            "attributes": [],
            "commandsGenerated": "UNSUP_GENERAL_COMMAND",
            "commandsReceived": "UNSUP_GENERAL_COMMAND"
          },
          "time": {
            "attributes": [],
            "commandsGenerated": "UNSUP_GENERAL_COMMAND",
            "commandsReceived": "UNSUP_GENERAL_COMMAND"
          }
        }
      }
    }
  }

Lidl strip only RGB works. No white LED active. Why?

I guess because of this (see first post): “Known Issues. Work in progress!”

2 Likes

Indeed nice addon!
Thanks and keep up the good work guys!!

1 Like