Homey Community Forum

[APP] TuyAPI / Neo Coolcam wall plug WIFI app

@Rens_Brandwijk
Hi Rens,

I bought a battery operated curtain motor set, and i know that battery operated Tuya devices are not supported by the app because normally they go to sleep…
But i thought let’s be clever and bought NOT the regular version. :sunglasses:

This is the set: Zemismart Tuya Smart Gordijn Driver Voor Romeinse I Type U Type Gordijnen Track Smart Leven Timer Alexa Google Home Control|Automatische Gordijn Control Systeem| - AliExpress

As you can see on the pictures it is a set with a remote based on handheld 433Mhz remote control.
Beside the remotes there is a USB based controller with 433 communication to the motors but with Wifi Tuya integration towards the Smart life App. And because the USB Wifi controlles is on continous power it stays always on !

I tested them and they operate fine.

Integrated them in your App as ANCCY curtain motor switch, and i can control them.

It is not working perfectly yet, every time i press the button the motor runs for one second instead of walking completely to the end of the rail in one run, but it is a good start i think :slight_smile:

This is the dataset i pulled from the app:

Can you integrate it in your app please ?
If i can help with more information or testing please don’t hesitate to let me know.

Thanks in advance Rens, and keep up the good work !
Rob

Yes, i bought one that was able to connect to continuous power and not only on battery’s
This one:

https://m.nl.aliexpress.com/item/4000336956505.html?spm=a2g0n.orderlist-amp.item.4000336956505&aff_trace_key=28f9a5c0e7004d62b6af1f6bf5ead7bd-1550252639640-06707-yjq3vrZ&aff_platform=msite&m_page_id=9302amp-NlOX9vqp7uugiKaIVwtkDA1607173830452&browser_id=23c88fa4db17443d9f98265b38368ef9&is_c=

Added it as wall plug but unfortunately NO code is showing up in the data attribute log.
:cry:

Bell works fine but not possible to connect this type of doorbell to homey would have been nice to get a flow card :tired_face:

@Rens_Brandwijk
I wanna add a power plug but am unsure which icon to choose.

chrome_2020-12-09_08-00-57

Neither. It mixes things up. First install stable, add devices, then upgrade to experimental. Devices are persistent across versions, dev already promised to look at it.

@Rijswijker @Rens_Brandwijk

Hi Rens and Rijswijker,

So I also bought this Aofo powerstrip, you Rijswijker also bought. Got the ID and key, like I did for other Tuya devices I have. Added the device to Homey as the Aofo powerstrip with success, but for some reason not a single command is coming through. Turning on or off all sockets at the same time or one at a time, the device does not respond. When giving the command in the Homey app, Homey gives no error. I also tried to give commands from Homey Developer, but nothing happens. Despite that the Homey Developer site shows sending the command.

The device is working perfect from the Smart life app. And I logged out of all sessions of the Smart life app on my devices so no double TCP connections remain.

Now, after trying the Tuyapi app, I tried the Tuya Cloud app from Jurgen Heine, and this app recognises the device as 5 separate devices. 4 Sockets and the USB switch and I can control all of the Sockets. Using the Group-app I can turn on or off all sockets at the same time.

While it works with the Tuya cloud-app I rather use your app.

Do you have any ideas what is going wrong in this case? Is there any other information I can give you to make this work.

Hope to hear from you.

Regards,

Dennis

@Rens_Brandwijk

Hi Rens,

I’m loving this project, would it be possible to request a new device? It is a floor heating thermostat (https://www.amazon.co.uk/dp/B08HGXTR1J/ref=cm_sw_em_r_mt_dp_TxW9FbHBDEYKK)

I have managed to get it to connect to Homey just by picking a device (in this case the ANCY Shutter Timer Switch) and then filling in the required details.

The information I get from the Data attribute log is:
NEW DATA ATRIBUTE:
{“devId”:58542378ecfabc45dda0",“dps”:
{“1”:true,“2”:20,“3”:24,“4”:“0”,“6”:false,“12”:0,"101"0,“1
02”:“0”,“103”:0,“104”:2,“105”:false}}

Not sure if it is helpful or not but the thermostat is reading a room temperature of 24 C with a target of 20 C at the time that this data was pulled.

Please do let me know if you need any other information or would like me to test anything.

Many thanks,

Oscar

Hi!
Will you add support for garage door? I succesfully grab the key, the id and of course the IP.
It only miss the support by the app.
It’s a short contact and a sensor.
It will be great if you can add into you app!

Sorry for my bad english.

It would be great if the blind motor devices are added to the app as well (or tell me how to do it manually). Product ID = q5ymhtoa6sdjymwx with standard function set (is equal to standard state set):

Code Type Values
control Enum {“range”:[“open”,“stop”,“close”]}
percent_control Integer {“unit”:"%",“min”:0,“max”:100,“scale”:0,“step”:1}
control_back Boolean {true,false}

Peter

So, first of all. I’m sorry for being silent for so long. These are very busy times for me.

I’ve published the SDK / 5.0 version to live. As far as i can see this version should not have the icon bug. But let me know if i’m wrong.

i will look into new devices when i have time. I won’t add the video devices because those are not supported by the tuya API. Same goes voor the battery operated devices.

I am willing to look into the curtain devices and thermostat however i do need to know what parameter stands for what attribute.

1 Like

ik kom erg ver maar de laatste stap (4) lukt me niet. Daar houden mijn computer skills op. het betreft:
4. On the command line, run tuya-cli wizard . It will prompt you for required information, and will then list out all your device names, IDs, and keys for use with TuyAPI. Copy and save this information to a safe place for later reference.

Kan je mij hier een omschrijving voor dummies voor geven?

open command line (windows sign cmd)
type tuya-cli wizard
If installed correctly a wizzard wil start asking you to fill the credentials in the previous step and a ID from a random device (can by found in the Tuya app)

After that it will return the key’s to you.

ththnx fot he quick awnser
then i need your help with installing the CLI tool.

‘tuya-cli’ is not recognized as an internal or external command,
operable program or batch file.

@Rens_Brandwijk

Hi Rens,

That would be amazing, please do let me know what info you need, happy to help in any way I can with getting parameters and testing.

Oscar

Hey all,

I have tried to add the Tuya “Kruidvat” lights with the app from @Rens_Brandwijk
All the steps from the Github readme are done.
I can see the devices on the commandline, the devices are added to the Tuya app on my iPhone.
Via the macaddress I can see the local ipaddress of the device given by my router.

Also via the app I can see the device ipaddress (that is the ipaddress of my wan network, public ip)

5 days ago the app was updated, maybe that has something to do? I just cannot get it working.
I hope someone can help me out.

Thanks for this App. I was able (with all the information here) to add my Wifi Smart Plug with the ID and Key to Homey (tried the cloud app first), but unfortunately it doesn’t read the power consumption, one of the reason I bought this device. I can only set the power manually for off and on. Is there any way that the App can read the power consumption? I can see the power consumption in the Tuya App.

Thanks again for all your hard work making this app!

Hi,
I added my Aofo Wifi smart power strip but now I get “This device is currently unavailable” message.
Why? :disappointed:

EDIT: actually, seems like the app crashed

@Rens_Brandwijk can you fix it?

After reinstalling app, it doesn’t crash anymore.
But the power strip is still not working :disappointed:
Any suggestion?

I checked in a fix into the test build. Can you test this for me.

have you added it as the NEO_Smartplug_3600 device?

1 Like

what kind of device this is?