Homey Community Forum

[APP]TuyAPI / Neo Coolcam wall plug WIFI app

For people looking for the key. Tuya has changed something in there app so in the latest version (3.13.x versions and up) don’t release the key’s anymore. Use 3.12.6. They are working on it see https://github.com/codetheweb/tuyapi/issues/280

Thanks for the quick Update @Rens_Brandwijk, appreciate it.

To fix the issue regarding obtaining the key with a different app, instead of downgrading Smart life APP. Testet only for Android, as i dont have an iphone.

  1. Download “STL Smart Home”
  2. Make an account
  3. Add your device ONLY to this app first.
  4. Follow normal instruction to obtain your KEY and ID. Note this down.
  5. Delete the device from “STL Smart Home”
  6. Add your device to “Smart Life” APP.
  7. You might have to restart Tuya APP in homey (try without)
  8. Add your device to homey.

There might be other issues down the road. I just added a LED Strip and i dont receive any attributes anymore. It might work on Smart Plugs, i havent tried yet. I still have some unused once that i could try to verify if there is other issues on devices i KNOW works.

Update: I do not get the 3600W Power plug to work with homey either if i add a new one. Even if i do have the new ID and KEY. Works in Smart Life app, also can add it to homey but i cant get any attributes and it wont respond to any commands.
The old 3600W Power plugs still works though.

Update 2:
Now I have tried both the STL app and the old version of the smart life app that still gives the is and the key. Issues is: they give they key, it’s just not the same key even though it’s the same app… so guess it’s not that simple.

So another update… And its not good news.

Sadly it seems that the developer of the Tuyapi has given up on the current API. Tuya has implemented some SSL pinning techniques that make it impossible to get the key’s from the devices with current versions of the app and also the communication between the plugs and the Tuya network is shielded better. Even if they break the code tuya will fix it fast and the chase starts all over again.

In short connected devices with homey keep working (for now), unless you update them but you cant add new plugs.

The only positive about this is that the developer of the Tuyapi is trying to make an app that works with the official TuyaAPI. If he gets this working i will try to build it back to homey. The benefit from this would be that it would make it possible to also add the more advanced features of the devices in the app. The other tuya app in the store uses a old cloud app (that is also on the nomination to be discontinued) with limited functionality (only basic classes).

From the topic i wrote about before.

and

Where did you find the key?
/Thomas

Finally, after lot of investigation, got the app working with my LSC led filament.

I won’t explain how to get the key, it’s explained over the WEB but I used the deprecated method here (works with latest LSC firmware)

Once I get the key the trick was the setup in homey app. I needed to remove ID, and just enter IP and Key (and name of course) but not the ID, then restart the homey Tuya App and suddenly all worked fine.
Be sure LSC app is closed on your phone prior that, so the device accept the connection (yes LSC accept only one).

1 Like

It works for me too!!!
Since a powercut at home, i cannot again my bulb in homey but my lightstrips work well.
With your method i confirm is working again.
Thank you so much

App crash sometimes

Ik heb de key ook eindelijk. Apparaat is toegevoegd alleen als ik nu het rolluik pijltje naar beneden klik gebeurt er helaas niks… Iemand een idee?

@Rens_Brandwijk I bought a Tuya Curtain motor. Much like the curtain switch but then integrated in the motor. I was able to get the key using the new method. Can you help me to get it supported in your app?

I also have one and have the key but there is no support unfortunately

Does anyone know this will work with homey/€ 53,53 31% Off | Avatto Smart Gemotoriseerde Keten Rolgordijnen, tuya Wifi Remote Voice Control Schaduw Sluiter Drive Motor Werk Met Alexa/Google Thuis

Hi @Rens_Brandwijk,
Great work on this app! After some initial hurdles, I finally got my LSC Smart LED Light Strip to work… Well, almost at least. Once the strip has been turned on manually, I can change colors and so on. However, I can’t turn it off or on from within Homey. Really weird… Any ideas why this is?

I have been looking into this but cannot seem to get it. I have created an dev account on the page. Created an app and linked the tuya smart app. Ive entered the Secret Key and ID but it keeps saying it’s the wrong Key of lenght is not correct, but it is exactly the same 100%.

Or am I missing something?

I didn’t find it particularly easy to figure out the correct key and ID to use in the Tuya app for Homey, so it’s difficult to guess as to what went wrong in your case. I can give you an idea of how long the keys should be by posting a screenshot of my settings from within Homey for an LSC Smart LED Light Strip.

Did you follow the steps from the first (recommended) method as described on https://github.com/codetheweb/tuyapi/blob/master/docs/SETUP.md ?

I’m trying to do so. I’m stuck at the ‘virtual ID’, don’t know what they mean by this.

to make it a little bit more clear, i’ve done everything. I also have added the device to the TuyaSmart app. I can see there is one device in the cloud development linked devices. When i get to step four:

Once your account has been linked, run tuya-cli wizard . It will prompt you for required information, and will then list out all your device names, IDs, and keys for use with TuyAPI.

I have to put in the ID and key, next question is the Virtual ID of the device. Don’t know what I have to enter here.

The ‘virtual ID’ can be found in the Tuya Smart app. To find it:

  • Click on the device from the home screen.
  • On the next screen, click in the top right corner. (I suspect this is the settings option, but it doesn’t show correctly in my app. I suspect due to a missing translation string.) See:
  • Now select ‘Device Info’ (‘Toestel Info’ in Dutch). See:

There you’ll find the Virtual ID. What kind of device are you trying to add? Like I said before, I’ve got a LSC LED strip, but despite that I’m able to change colors, I’m unable to turn it on or off. :frowning: