Homey Community Forum

[APP] YouLess and Enelogic Belgian and Dutch P1 Smart Meter Reader

Hi, has anyone still problems with the screensaver under v2. Currently running homey rc11 and the app om latest version.
Led ring dit it once on rc3 but after a reboot of Homey it stopped and shows spectrum. I can change the behaviour and close different other screensavers

I cannot test myself, because Im on stable version 1. If ledring is still a problem under v2 stable I will investigate further.

I just removed the app, rebooted homey, reïnstalled the app, added device ls120p1.
The screensaver still shows the same problem, device is woeling correct

With the LS110 i get a parse error when i set a password on the youless, if i remove password on the youless and leave it empty it is Added.
But then after a while it gives wrong password errors in the app log and does not update use anymore.

Can you submit an issue on github please? Provide details on device firmware and homey version. And post the app logs that show the error you get.


1 Like

v2.3.0 will soon be available in the appstore.

It has improved compatibility with Homey V2 concerning icons, insights and ledring.

So to be clear, there are two apps, this one and a youless only app. Both have the same information for my ls120. Which app do you prefer?

The youless only version will be phased out eventually. I will only update the Enelogic and Youless app from now on.

So the app you would want to install for youless is this one:

1 Like

This is a nice link showing what pulse sensor you would need for different water meter types:

I could make a special Youless S0 Water driver to support these type of meters. But I would need a pulsemeter myself to develop and test: https://www.ecozo.nl/nl/pulssensor-hri-voor-sensus-watermeters

Is anyone willing to sponsor a device (82,50 euro) ?

With the v2.3.0 update, the led-ring is changed to green/red and overrules my screensaver. How can i turn this off?

Ok thx. So my attempt to make the ledring work for Homey V2 failed then :unamused:.

Can you not select a different screensaver anymore?

The Enelogic Energie screensaver is not selected but is the active screensaver. When i switch from off to weather the correct screensaver is active again.

After updating to 2.0.2 and a reboot the screensaver got activated but luckily I was able to disable it. And it stays off. Nice feature but not for me :wink:

I noties in the logs that there’s an error related to the screensaver :slight_smile:

2019-01-28 21:08:04 [log] [ManagerDrivers] [LS120S0] entering LS120S0 driver
2019-01-28 21:08:04 [log] [ManagerDrivers] [LS120] entering LS120 driver
2019-01-28 21:08:03 [log] [ManagerDrivers] [LS110Water] entering LS110Water driver
2019-01-28 21:08:03 [log] [ManagerDrivers] [LS110] entering LS110 driver
2019-01-28 21:08:03 [log] [ManagerDrivers] [enelogicp1] entering Enelogic driver
2019-01-28 21:08:03 [err] [MyApp] error parsing logfile: Unexpected number in JSON at position 20478
2019-01-28 21:08:03 [log] [MyApp] { Error: invalid_screensaver at Object.JSON.parse (/opt/homey-client/system/helpers/jsonfns.js:1:1190) at JSON.parse () at jsonToObject (/opt/homey-client/system/helpers/jsonfns.js:1:1083) at function.e.data.map.e (/opt/homey-client/system/manager/ManagerApps/bootstrap/sdk/v2/lib/HomeyClient.js:1:1379) at Array.map () at HomeyClient._onMessage (/opt/homey-client/system/manager/ManagerApps/bootstrap/sdk/v2/lib/HomeyClient.js:1:1372) at emitTwo (events.js:126:13) at process.emit (events.js:214:7) at emit (internal/child_process.js:762:12) at _combinedTickCallback (internal/process/next_tick.js:142:11) message: ‘invalid_screensaver’, code: 404 }
2019-01-28 21:08:03 [log] [MyApp] capturing stderr

I suspect a bug in the Homey firmware that is causing the ledring to fail. I tried the led-ring collection app, but also that fails on Homey V2.

In fact mine works, at least I get a green ring with a tiny bit red. But since I don’t know how it should work I don’t know for sure.

I made a new version v2.4.0, soon available in the appstore.

This has a workaround for the ledring bug in Homey V2. Also in this version the app settings page is optimized for V2 on a mobile device.


Hello, Great app. But for some reason the Led ring is always using Spectrum.
I am currently using version 2.3.0 and I see in the changelog that you made a fix. It has worked on Homey v2. Anything I can try? Already restarted Homey and the app.