Homey Community Forum

[APP] YouLess and Enelogic Belgian and Dutch Smart Meter Reader

Thx 4 the compliment :kissing_heart:

Homey Energy has no seperate class for EV. I just name my EV charger ‘car charger’ :thinking:, and it shows the energy usage just as any other energy socket. Why would you want EV to behave different in the energy tab from e.g. your dish washer?

FYI I’m using the S0 input of my youless to measure the production of my solar panels. When using the new homey energy function I had to switch the “solar panel” function in the advanced menu of youless S0 off and back on to get homey to see that solar panels produce instead of use electricity.

1 Like

App version 3.0.0 is now available in the app store. This and future updates will only be compatible Homey firmware 3+ due to the added capability switching from the device settings. You can now disable/enable production on the fly for instance

Changelog:
Compatibility Homey V3+. Fixed readme images. Device pairing process updated. Capability switching added in device

I still don’t get it to work. I have ©2x a Youless 120 with firmware v1.4.3-PO on it. one Youless120 is used to measure the output of my solarpanels, the other one is measuring my bruto energy consumption.
Both are connected to a DIN rail kWh meter via the S0 option.

The upload of data to PVoutput works flawlessly, however…I miss the same data via the app in my Homey

I run the latest verion of your app. I add both the Youless devices via the ‘LS110/120 E’ option as is adviced in the Help menu.

The result is that I only see the ‘meterstand’ of the youless, but not the actual ‘S0 meterstand’…so…the result is 0W energy

There is your problem. You need -EL firmware

the -PO firmware does not provide local readout of the energy data.

Also this does not make sense if you connected the solar panels to the S0 port. You should use the LS120 S0 driver to read out the S0 port. Where in the help menu does it say you need to add it as LS110/120 E?

I ordered a YouLess LS120 to track my P1 data and S0 data for my solar panels. I’am a bit confused witch device I must choose in Homey, the P1 or S0? I understand that if I choose the S0 there is less data available on P1 correct?

P1 is the connection that can only be used for your smart meter. It will monitor your power and gas totals for your entire home.

S0 is a connection that can be used for pulse meters. So if your solar panels provide a S0 compatible pulse output, you can use it to monitor the power production of your panels.

The youless LS120 supports simultaneous connection of P1 and S0 on 1 youless device. If you use the -EL firmware in the youless Homey can read all data from both P1 and S0 without problem. But you have to add it as 2 seperate devices in Homey (P1 and S0). During pair of S0 you can select that you use the S0 as power meter (and not as water meter). After pairing, you can go to the device settings and select that it is a solar panel meter (meaning, it is measuring power production in stead of power usage)

I hope this clears things up🤗

Loud and clear :sweat_smile: Thank you for your quick response :+1:

FYI: The Youless LS120 is compatible with

  • Dutch and Flamish smart meters via P1 (including day/night tariff, production/usage, and gas)
  • any S0 pulse meter
  • any meter that can be read with a optical sensor (e.g. LED pulse or turning wheel)

For Flamish-Belgian P1 smart meters you need to install new firmware:

http://www.youless.nl/blogpost/items/ls120-fw143-vlaanderen.html

For Homey to be able to read out the youless it is required to install the -EL version firmware.

I live in the Netherlands so no problem but thanks for your information.

Where in the help menu does it say you need to add it as LS110/120 E?

In andere gevallen kies je LS110/120 E…Het staat er toch echt.

It also states that you have to use P1 if you have a P1 connection to your smartmeter, and that you can add S0 as an additional device.

Add a new device via the Homey tab `Devices`. Use the `LS120 P1` if you have a P1 connection to your smart meter. Otherwise choose the `LS110/120 E`. On request enter the fixed IP address. If you want to use the S0 and/or the water meter, you can simply add these as an additional device.

But I see I can make the text a bit more clear

@Gruijter

For feature request is this the right place?
If not point me in right direction.
Else,
I’m using the S0 input to track the production of my solar panels. What I would like to have added in the overview of the device (currently showing current production and production total) is for example the total production of the day and peak production of the day. I now have made numerous flows to create this data, but can only be viewed as variables in logic.

Understandable request. And you are not the first asking for it. I would also like to have it in Homey. But I strongly feel this should be a core reporting functionality of Homey itself. See for instance this discussion:

In the mean time I am using http://www.enelogic.com for my overview insights.

Point taken and very understandable from a developer point of view. Too bad history tell us that waiting for athom to make such features can take a while :wink:
But if you feel bored somewhere over the next few weeks nobody here will stop you to do so anyway :grin:

Day production would be a very nice option.

Got bored this aftenoon :stuck_out_tongue:

https://community.athom.com/t/20535

1 Like