Homey Community Forum

Apps for Husqvarna automover

Dear All,

Has someone of you alreary thinking or strating to develop an apps for the Husqvarna automover?

Thanks and kind regards.

Alex

1 Like

Hi,

I am actually developing an app for the Husqvarna Automower. Hopefully a first test version will be ready soon. The use case that made me look into this is parking the mower before running the lawn irrigation sprinklers. Sure, there is IFTTT but that is not as fun. :slight_smile:

There is a rate limit on the Husqvarna API so status polling probably can not happen more than every few minutes or so. But flow action cards for controlling the mower would of course work even with the status polling disabled.

1 Like

Hello,

Very good news and many many thanks. Yes I already heard about some limitations about polling rate for the Husqvarna Automower.

Please let me know when you’ll have something available for testing.

Kind regards

I have published a first test-version to the app-store today but it seems i need an Athom certification before i get the link for others install the test-version. As soon as i get it i will let you know.

To get some testers onboard before everybody put their mowers in winter-storage i have got the app deployed (thanks @MaxvandeLaar) to the community store.

Homey Community Store

Ping @Kfk that made a request for an Automower app back i May.

Would be great if you could give it a try :slight_smile: thanks in advance.

3 Likes

Thank you!

Sadly I have already put my mower for winter storage. But now I look forward to the spring even more! :smiley:

I will ping @Utakurt here as i see that he also was interested in an Husqvarna Automower app in this thread NeuVorstellung...der Kurt vom dhc geschädigt

hi BufferOverflow,
Thank you for your work it’s really cool! I just installed your application for my 450x, I will be able to have fun with flows :smiley:

When log in the Homey Community Store, install V1.0.0 button is inactive --> Your Homey does not support this SDK version!

What I should do?

Thanks for your support. Kind regards

Alex

You need homey v5 firmware

Thanks; updated!