Homey Community Forum

Aqara & Xiaomi Smart Home - Zigbee App (v0.8.0)

1 Like

I need small advice - I have Aqara Switch WXKG11LM and Occupancy sensor RTCGQ01LM and I can’t add them to Homey (I have more then 25 different Zigbee devices including Aqara, Xiaomi etc.). The pairing mode is activated but Homey never recognize it. Xiaomi Aqara Hub recognize them immediately even on long distance. I keep pushing button, I tried to pull battery out, nothing is helping. Is it possible that I have some odd unsupported or Chinese market only version?

And just be sure, you try to add them close at homey?.

Its a know thing that larger amounts of zigbee devices good give this trouble.

For advice best to search the forum

Yep, like almost on the Homey sphere. Just before I added without any issue door contact sensor 10m far from Homey (another Aqara)

Can anyone recommend Zigbee routing devices to strengthen my network of Aqara devices? I seem to have reception issues. They don’t need to do anything. Only routing would be sufficient.

Every main powerd Zigbee device will do the job, so lot of choise

I had this issue too. Do you even try to restart the app? This worked for me!

1 Like

Ikea signal booster does the trick for me.
Or the Ikea ‘plug in socket’.

Yes, I even restart whole Homey - still can’t join those devices. I’m suspicious they changed something in those products, as I can see “Chinese” versions and even “International” versions of Aqara Switch WXKG11LM and Occupancy sensor RTCGQ01LM available on different shops - but they have the same product number and looks the same (as already described somewhere else here)

Just a summary of attempted steps if anyone has got any additional idea :

  • removed battery
  • pairing mode enabled (3 blinks)
  • tried different revisions in Homey (eg. 2018 button)
  • have 3 devices (1x WXKG11LM and 2x RTCGQ01LM ) - none can be added
  • moved devices as close as possible to the Homey
  • keeping button pressed each 2 sec
  • restarted Homey / Xiaomi Zigbee App
  • tested ZigBee pairing on another Xiaomi Contact Sensor - worked flawlessly and on the first attempt
  • two times I got to the next step after pairing enabled and it did time out
  • I have non-collision Wifi frequency set on all my Wifi APs

—> on Xiaomi Gateway (Chinese region) it’s working always and immediately

All other Zigbee devices are fine (around 25 of them) and routing as they should (no problem with mesh or reach-ability), I have even active routers in the network (IKEA Tradfri )

Is there any way how to troubleshoot it ?

Sorry than I have no other idea! You have all done you can do in my mind. :pensive:

1 Like

Perhaps try a different Homey? Someone might have one near you.

hi, could you please advice how to implement the following: using aqara motion sensor (with light sensor) when the motion is detected and luminance is XX percent then … . For now I can only choose one of these option: motion or luminance, but not both at the same time. Thanks.

Hi Corvum,

This can be done by;
When: Motion Sensor Activated
And: Logic luminance is less then VALUE (The luminance is measured in lux)
Then: The action you want

1 Like

Someone made a nice post about that.

1 Like

I’ve experienced some devices, temperature sensors and switches, losing contact and it means that I have to delete and re-add the devices, and then edit all the flows that use them.

One of my buttons controls a hue lamp (no hub) and there is often that I can’t turn on the lamp. I’ll then either manually do it from the app, or ask google to do it. The button will then work to turn it off and on as normal again. As if it wakes up the button… very strange.

I also had a wall heater be on for two days because the aqara I use for temperature control suddenly stopped updating. After reconnect - fine (but had to change flows).

I’ve thought of adding a safety measure for the heater so it warns me if there are no temperature changes. The wall heater itself is only set at 5C higher than normal anyways, so it won’t go crazy.

use 3 of this type, never had problems, always work, also with 1, 2 or 3 pushes.

Never tried anything but one click. The one with the light has the most issues. I’ve had issues with one that opens a balcony window for the first time recently, and now the temperature sensor.

Maybe you also suffer from the general Zigbee problem that is waiting for the re-write,
I only have 13 Zigbee sensors/buttons and no lamps or plugs, never problems with them, I use Z-Wave mostly for the lighting.

Next time try to re-pair the device without deleting it first in Homey. You will see a message that it is a duplicate. After that I guess that the device in Homey will work again.

Does anybody use wall switch no neutral (lumi.ctrl_neutral1,2) without any problem? As i saw in the web they are works good only with gateway.