Homey Community Forum

Be carrefull, "rollershutter 3" from Fibaro does not work on Homey for venetian blinds

Homey’s application for the fibaro roller shutter3 does not know how to tilt the slats of venetian blinds. There is only the UI widget for up, down, stop or percentage setting of the open. Homey has completely forgotten the widget for the orientation of the slats !!! for the venitian blind (parameter 151,1,2)
The other home automation box manufacturers have a dedicated widget for the slats.
As there is no widget there is therefore also no “card” which allows to make very basic “flows” such as closing the slats in the evening and another to open the slats in the morning …
The primary function of a Venetian blind is to open and close its slats !!! it’s a shame …
If someone has found a “tip and trick” to achieve the two basic flows … thank you

Having the same problem right now. Since the Venetian Blinds Mode is a basic function of the Roller Shutter 3 I assumed I could control my blinds as such. Disappointed I can’t. I have contacted Athom with the question why this isn’t supported and if it can be added. But for now, if someone has suggestions how to solve it, please explain.

It’s a known issue. So my suggestion is: @Thierry_Sabatier please contact Athom!

But there are some workarounds:

(Sorry, only in German)

Because I don’t have Venetian blinds I don’t know if it works.

This parameter will be set by choosing the type (Roller blinds, Venetian blinds, others… / don’t no if these are the right names in English) after tapping the gear wheel.
You can check it in Developer → Tools → Devices.

Btw, I guess you mean: 151,1,2.
You can do a raw configuration if some parameters are missing in advanced settings of the device.
You can do it in the Advanced Settings → Raw Configuration, via Flow Then… > Z-Wave → Send unprocessed command or in Developer → Wireless → Z-Wave → Send Raw Data.

2 Likes

My workaround for missing secondary device control for slats is working in my house fine…

it’s incredible that since the release of the roller shutter3, Athom has not reacted … it shows a contempt for their users

Hello, I have already written to Athom, their answer is as one would expect politically correct and very vague !! :
I will forward your suggestion to the developer regarding the rollershutter 3.
*I do agree it will be simpler as it easier to use when connected to venetian blinds. *
I have added it internally to our list of feature request, so we can discuss this with the development team.
Please keep in mind that we cannot give any guarantees on if and when we will implement your suggestions, as there is already quite the development roadmap laid out. That being said, it is definitely noted.

My apologies it is indeed in raw settings 151,1,2 for venetian blinds; and my parameters are all good … to succeed in closing the slats in the evening in a flow, maybe as you advise me: add a Zwave Then> Z wave> send unprocessed command, but afterwards ?? I have to indicate node ID then parameter and I have no idea what to do … !!!

I guess this was a misunderstanding. I thought that you don’t know how to adjust parameters which are not listed in the advanced device settings. So I just wanted to let you know which possibilities are available.
This has directly nothing todo with the adjustment of the Venetian blinds. For this you can try the workarounds.

Athom has responded that they will be implementing the Venetian Blinds mode in the short term. No exact date but they’re working on it at least.

hello, have you read the answer Athom gave me? :
Please keep in mind that we cannot give any guarantees on if and when we will implement your suggestions, as there is already quite the development roadmap laid out. That being said, it is definitely noted.

it is very politically correct! and not very reassuring :thinking:

I did. And did you read mine? :slight_smile:
That was their answer to my question.

yes but who to believe ??? This is the problem… :wink:

Since I have a direct contact I do believe him. I’m a little more reassured now. :slight_smile:

Athom 's response that I posted dates from the day before yesterday and you?

Today.

Hello, I just read your workaround for roller shutter3 and venetian blinds…
I have three questions:

First question :
Why make an “insecure” inclusion with the Walli Outlet device because all the description you give to create a flow in order to tilt the slats, you can do it after having made the inclusion directly from the roller shutter3 …
I am normally paired in “secure” with Roller shutter 3 and I can do the flow you describe …
Then> Z-wave> send raw command> Nod ID and Parameter.
So why do I have to go through pairing via the Wallli outlet?

Second question:
For the opening of the slats or their closing the parameter to be written is the same, only the last digit differs? 99 to open and 0 to close

Third question:
The Node ID is the Device id? Because in Advanced Settings I have: Device ID, Manufacturer ID, Product Type ID and Product ID

Thank you

Yes,yes,yes
I tried to include it yesterday as walli and ended up with having to put the code of the device and it include as s2(authenticated) . Got annoyed by it and for now i just use in the scene set position 5% twice, seems to work as first time it runs and second time it stops, just like it works with the switches.

hello,
I don’t understand … Did you make a classic inclusion with the Roller shutter3 or did you include it via the Walli outlet?
On the other hand in the flow you created, did you put 5 at the end of the hexadecimal code? ie: 0x60,0x0D, 0x13,0x02,0x26,0x01,5 ??? because in this place we do not put a percentage ??? !!

do you have a venetian blind?

This workaround to include unsecure no longer works. Hasn’t since firmware V7. So if S2 security is supported, that is used. S0 security is now off by default. As yet there is no way to prevent S2 security level to be used.

I include it as walli. It then comes up as rollershutter 3.
As I noted, it is included as S2(authenticated) . Therefore no possibility to send raw z-wave signal ,which is not encrypted.
The flow is just telling to set position to 5% twice. Regular way , no sending raw z-wave commands.
I have a venetian blind, multiple actually. One on each version of fibaro rollershutter modules combined with somfy sonesse wt 40

So what did you do as “flow”? Then> ??? (an example?)

What do you mean by 5%? Did you manage to close only the slats and open them? Thank you