Homey Community Forum

Beacon - An app for presence detection using BLE beacons

Hi all,

I went through the thread to look for a similar problem as I am experiencing.
I have a Homey Pro with version 2.3.0. and use the beacon app version 1.2.9.
Detection of my Tile Pro’s works fine, but I can only sync/detect by pushing the button on my Tile.
Detection afterwards only works when I push that same button. The Tile is then detected until roughly a minute after, what looks to me as a sync mode on the Tile - with the melody, stops.
Then the Tile isn’t detected anymore.
I tried reinstalling the app, re-adding the Tiles (I have two, both have the same issue), but to no avail. Tried PTP as well (although it took some time to find out that PTP means pull the plug :joy:).
What am I missing?
Thanks for any replies,

Jack

I am not sure but it maybe depends on each beacon how it behave itself. Maybe its software sets it to sleeping mode, in other words its not detectable without ptp. I have bought several cheap beacons from ali and it seems only two are suitable for me (first and last one). I use them for presence of family members (attached to the keys). Some of them stop to be detected after some time and neet to be woken up. My settings you see below. I give it some time to have the beacon recognized as away.

You have disconnect the tiles from the tile app.?

Just place the tile that you using with homey on hide in the original tile app on your phone

Haven’t installed the Tile app in the first place, 'cause I read about the problems. So fresh out of the package…

Jack

You have to install the app first to register the tiles

For me, that turns out not to be the case.

I’ve got the same issue, sortof…
I’ve got two flows;
1 - IF tile is out of range AND tile is out of range THEN message away.
2 - IF tile is in range AND tile is in range THEN message home.
Sometimes they get triggered, sometimes they don’t. There is no logic behind it.

However, the device always diplays correctly if it is in range or out of range.

Am I doing something wrong or is there a bug in triggering of flows when tile is within range or out of range?

And what is you leave the “and” colum empty.

I don’t see the logic here. Sounds like “IF lamp is on AND lamp is on”
Can u tell us the benefit of this besides reading this a few posts up?

1 Like

Hi,
Seems to work now.
I figured out now what I did wrong.
In the IF section you can select the Beacon app (with sub choices) OR the Beacon (tile) itself.
What I did when setting up was select the Beacon app instead of the Beacon itself.

So: to get flow triggering to work just select the beacon (tile) itself instead of the App.
In the beacon itself choose In range/out of range.

Thank you all for the quick replies!

I tried bluetooth itag software, that finds my miband 3. (and the itag, nuki, and some mi flowers)
But the homey does not see my mi band 3 :frowning: Any idea?

Hi,

Is there a way to add support for Beacon simulator apps on mobile phone ? E.g. Beacon Simulator on Android can simulate iBeacon, AltBeacon and Eddystone protocols.

This allows us to use any mobile phone that supports BLE as a beacon.

I don’t always carry around my keys, but I do my phone :slight_smile:

Thanks in advance!

2 Likes

Hi all,

Anyone else has the problem that after approx. 2 days Tile pro device are not found anymore?
After reboot homey everything is working again.

I had this problem before, but now It worked ok for a long time.

Grts
Ron

1 Like

I had no good experiences with the Tiles (Pro and Mate). They often lost contact to Homey although they were nearby. Now I use NRF51822 beacons for presence detection which are much more reliable! works well so far.

Hi Azid,

What range do these NRF51822 beacons have?

Thx

No problems with the tile pro’s overhere

In mi case approx 6 meters

Same here, so hang your keys somewhere near your Homey :smirk:

Annoying thing is, that it does not have anything todo with the range, If It works It detects the tiles If I am entering my street. It just wont see them until I reboot homey. Just restarting Beacon does not help.

I never had this problem until few firmwares ago. 2.5.x firmware problem?

Must be a very tiny street, or you have tiles with sterorides :thinking: